× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

Re: upgrade from 6.8.1 to 6.9 disabled eth0,1,2,3

scottonaharley
Aspirant

upgrade from 6.8.1 to 6.9 disabled eth0,1,2,3

I upgraded my readynas 4220 from 6.8.1 to 6.9.0 and the three onboard ethernet ports are showing DHCP enabled in the gui but do not link to the switch.  It seems as if they are administrativly disabled.  I have tried factory reset and os reinstall as well as restoring the network configuration from a 4220 with the same configuration (as a matter of fact they are of exactly the same manufacturing run so the motherboards are identical) with no sucess.  how can I get the system to rediscover (actually renable) the onboard ethernet ports?

Model: ReadyNAS-4200|ReadyNAS 4200
Message 1 of 4

Accepted Solutions
scottonaharley
Aspirant

Re: upgrade from 6.8.1 to 6.9 disabled eth0,1,2,3

No the interfaces were not bonded.

I was able to solve the problem by executing the following steps:

 

1) enable ssh access

2) login and su to root

3) ifconfig <interface> down (for each non-functioning interface)

4) restart

5) went directly to ssh before opening Frontview

6) login and su to root

7) ifconfig <interface> up (for each non-functioning interface)

Interface links came up and bi directional data flow started.

8)Frontview correctly displayed the link status and was able to control the links where as before the links stayed down in spite of enabling them in Frontview.

 

I'm not sure why this worked.  A factory reset should have worked as I would think that at first boot after the reset the hardware would be scanned.  Without studying the inner workings of frontview its hard to say if it was an O.S. issue, Frontview issue or combination.

 

We can mark this as problem solved but root cause unknown.

 

View solution in original post

Message 3 of 4

All Replies
Marc_V
NETGEAR Employee Retired

Re: upgrade from 6.8.1 to 6.9 disabled eth0,1,2,3

Hi @scottonaharley!

 

We had issues reported on ReadyNAS models regarding Network interfaces getting disabled an/or reset after the update.

 

Were your Eth ports configured as a bond? You may want to check on the Beta FW ReadyNASOS 6.9.1-T129 Beta 2.

 

Please let us know if this helped.

 

Regards,

 

Marc
NETGEAR Community Team

 

Message 2 of 4
scottonaharley
Aspirant

Re: upgrade from 6.8.1 to 6.9 disabled eth0,1,2,3

No the interfaces were not bonded.

I was able to solve the problem by executing the following steps:

 

1) enable ssh access

2) login and su to root

3) ifconfig <interface> down (for each non-functioning interface)

4) restart

5) went directly to ssh before opening Frontview

6) login and su to root

7) ifconfig <interface> up (for each non-functioning interface)

Interface links came up and bi directional data flow started.

8)Frontview correctly displayed the link status and was able to control the links where as before the links stayed down in spite of enabling them in Frontview.

 

I'm not sure why this worked.  A factory reset should have worked as I would think that at first boot after the reset the hardware would be scanned.  Without studying the inner workings of frontview its hard to say if it was an O.S. issue, Frontview issue or combination.

 

We can mark this as problem solved but root cause unknown.

 

Message 3 of 4
StephenB
Guru

Re: upgrade from 6.8.1 to 6.9 disabled eth0,1,2,3

You might want to reboot the NAS and see if the work-around sticks.

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 1169 views
  • 0 kudos
  • 3 in conversation
Announcements