Reply
Contributor
Posts: 53
Registered: ‎2006-02-25

Cant access shares using CIFS

I can't find if this is answered anywhere so I will create a new post. I just purchased a Ready Nas Pro 6 and am trying to connect using a Mac Book Pro with Lion installed. I have both AFP and CIFS enabled. The problem I have is if i try to access the share as an authenticated user the share disappears from the shared list and I can't access it. If i try to access the share as guest I can see the files. If I connect forcefully using the go connect to folder then it works fine. Has anyone had the same problem? The issue is that once the shares drop off time machine can't find the server anymore and all backups fail.
NETGEAR Moderator
Posts: 38,548
Registered: ‎2011-06-07

Re: Cant access shares using CIFS

What version of RAIDiator?
Contributor
Posts: 53
Registered: ‎2006-02-25

Re: Cant access shares using CIFS

4.2.19
NETGEAR Moderator
Posts: 38,548
Registered: ‎2011-06-07

Re: Cant access shares using CIFS

Contributor
Posts: 53
Registered: ‎2006-02-25

Re: Cant access shares using CIFS

Is the beta stable. How long do you think i'll be running the beta before its released? Its been in beta for quite some time.
NETGEAR Moderator
Posts: 38,548
Registered: ‎2011-06-07

Re: Cant access shares using CIFS

The beta is pretty stable. Not sure how long till a production release, but hopefully not too far off now.
Contributor
Posts: 53
Registered: ‎2006-02-25

Re: Cant access shares using CIFS

I read through the issue posts for the beta T40 and I am concerned installing it because of some of the problems. So I will wait on that.

UPDATE:
I came home today and time machine on my mbpro wouldn’t connect to the time machine share on the ReadyNas. The readynas was on and I could connect to directly so it suggested there was a problem with the discovery services. After rebooting the router all of the services appeared in the Bonjour browser and the time machine backup worked. I thought that fixed the problem however when I clicked the NASPRO 6 (AFP) share, it disappeared again. Here are the results of the dns-sd command while I was doing all of this:

Brandts-MacBook-Pro:Files Brandt$ dns-sd -B _afpovertcp._tcp
Browsing for _afpovertcp._tcp
Timestamp A/R Flags if Domain Service Type Instance Name
17:12:27.552 Add 2 4 local. _afpovertcp._tcp. NASPRO6 (AFP)
17:12:27.602 Add 2 4 local. _afpovertcp._tcp. AFP on NAS01
17:24:38.839 Rmv 0 4 local. _afpovertcp._tcp. NASPRO6 (AFP)

The Rmv appeared right after I clicked on NASPRO6 name in the shared menu. When I clicked on the AFP on NAS01 share, the share didn’t appear and I was able to browse the shares. The difference between the two system is that I am connected as a Guest on the NAS01. If I try to connect using credentials I get an error message because the radiator version on the NV doesn’t support the new authentication necessary for Lion. Allowing guest access for either CIFS or AFP on the NASPRO6 allows me to browse the shares on the system so something is going on with the readynas. Searching other posts it seems like this is a common problem without a solution. It just doesn't make any sense to me why this occurs and I am getting very frustrated.
Discussion Stats
  • 6 replies
  • 10 views
  • 0 kudos
  • 2 in conversation
Top Contributors