Reply
Initial Contributor
Posts: 4
Registered: ‎2013-05-14

SSH on new RN 102 with OS 6.0.5

Brand new shiny RN 102. Upgraded firmware to 6.0.5. Public, static ip address (ie not private space 192.168.X.X) . Both laptop and Netgear on the same local subnet. Https to Frontview from my laptop running FC 17 seems to work as expected. I enabled ssh in Frontview. Ssh on my laptop to localhost works. Ssh from laptop to a non-privileged user on Netgear requests a password. I enter it. The connection is immediately closed.

/etc/hosts.allow is ALL:XXX.XXX.XXX.XXX:allow
iptables is -A INPUT -s XXX.XXX.XXX.XXX/32 -m tcp -p tcp -j ACCEPT

Thoughts please. And thanks in advance.

- Jeremy
Esteemed Contributor
Posts: 16,075
Registered: ‎2007-09-24

Re: SSH on new RN 102 with OS 6.0.5

You can only SSH in as user root. User admin or other users will not work, they don't have a shell set.

Once logged in as root, if you want to grant login to other users; viewtopic.php?p=336971#p336971
Moderator
Posts: 5,321
Registered: ‎2009-09-02

SSH on new RN 102 with OS 6.0.5

Only root account is allowed with admin password
If you like my add-ons - Si vous aimez mes add-ons :
EN/US: --- -------- FR: or Paypal @mail: readynas@orange.fr
Where I'm teaching
4B Perros
Initial Contributor
Posts: 4
Registered: ‎2013-05-14

Re: SSH on new RN 102 with OS 6.0.5

Thank you both. The enable root access addons that are available (sparc, x86, arm)
won't upload. I get a popup that says only debian is permitted. Where is the appropriate .bin located?

- Jeremy
Esteemed Contributor
Posts: 16,075
Registered: ‎2007-09-24

Re: SSH on new RN 102 with OS 6.0.5

Its a toggle option in the GUI under System>Settings>Services in R6.

Initial Contributor
Posts: 4
Registered: ‎2013-05-14

Re: SSH on new RN 102 with OS 6.0.5

Yes, that is turned on. Without that I wouldn't have expected to get a password challenge. It seems to me that there's a permission error. But I can't get to a command line to poke into it. Frustrating.

- Jeremy
Moderator
Posts: 18,814
Registered: ‎2015-07-16

Re: SSH on new RN 102 with OS 6.0.5

So SSH is turned on. When you connect with SSH to the NAS you are entering "root" as the user name, and then the admin password. Is that correct?

What SSH tool are you using? Putty?
Initial Contributor
Posts: 4
Registered: ‎2013-05-14

Re: SSH on new RN 102 with OS 6.0.5

Thank you for the help. The problem turned out to be sort of dim. I thought I had read that admin and root were treated as the same. ssh admin@XXX didn't work. ssh root@XXX works fine.
Also changing /bin/false to /bin/bash in /etc/passwd allows non-privileged ssh. And then su - if root is wanted. Maybe just me, but it seems better than accessing root directly.

Thanks again.

- Jeremy
Contributor
Posts: 25
Registered: ‎2013-06-29

Re: SSH on new RN 516 with OS 6.1.9

am trying to setup an SQL database on my readynas RN516 to service multiple XBMC machines. I have installed mySQL server and phpmyadmin. I have created a user xbmc with full privileges and port forwarded port 3306 in my router.

But xbmc is unable to create a database - I get the error "Can't connect to MySQL server on '192.168.1.22' (10061)". I tried to telnet into the server on port 3306 and it is not open.

I tried to ssh into the server to change the "bind address" but once I log into root via putty and type in the command /etc/mysql/my.cnf and press "enter" and nothing happens.

Is someone please able to help.......thanks
Discussion Stats
  • 8 replies
  • 260 views
  • 0 kudos
  • 5 in conversation
Top Contributors
User Kudos Count
30
23
16
10
2