Reply
Follower
Posts: 1
Registered: ‎2011-03-08

missing files and folders when streaming

I'm playing back video and music through my WDTVLive, when I first got the ReadNAS duo, everything worked ok. But as soon as I put on the firmware update half of my files and folders are missing when I select to play files via the ReadyNAS as a Media Server. If I select to play the files via the ReadNAS as a network share the files and folders are all there. The only problem being selecting the network share method is that it sometimes takes several attempts to connect to the ReadyNAS as a network share, connecting as a Media Server is instant. No matter how oftern I rescan the folders (under the streaming media service bit in the websetup) they just don't appear on the media server playback. Its really annoying that it worked when I first got it, and I don't want to downgrade the firmware as its supposed to loose data.

Has anyone else had this problem and did they manage to fix it?
Aspirant
Posts: 2
Registered: ‎2011-03-10

Re: missing files and folders when streaming

put me on this list... just updated my NV+ yesterday and a lot of mkv, iso etc files are no longer visible to my WDHD Live...

maybe install Twonky media server?

anyone?
Aspirant
Posts: 2
Registered: ‎2011-03-10

Re: missing files and folders when streaming

update :-)

after FW update all permissions on the shares has been reset.
so after updating the share permissions all work perfectly again :-)

its important that the WD can write/read to the NAS because the WD has to place the WB.bin file on the server
to be able to read the correct shared files :-)
Aspirant
Posts: 28
Registered: ‎2011-04-14

Re: missing files and folders when streaming

Can I do a firmware update of 4.2.16 over 4.2.16 to force this?

How did you diagnose it was permissions?

I have a similar problem with DLNA not updating / showing all folders but all are accessible by browsing on pc or by readynas remote
Aspirant
Posts: 28
Registered: ‎2011-04-14

Re: missing files and folders when streaming

Fixed by removing DV containing files for now till 4.1.17 is released
Aspirant
Posts: 1
Registered: ‎2011-05-02

Re: missing files and folders when streaming

Can you please post the steps you took to solve?

Brgds,
a.g.h.
Aspirant
Posts: 2
Registered: ‎2011-07-12

Re: missing files and folders when streaming

Hi All, i have the same issue, dont believe any update has happened. I run a WDTV live and a ReadyNAS NV+, but the WD only see's like 2 or 3 folders and not 5 or 6 like it should.

I have been working on this for a while and cant seem to come up with a solution. Had a look through these forums and couldn't see anyone else have a definite solution either.

Is there someone to contact about this issue as it was working fine for months then just started doing this.

Any advice would be appreciated.

Cheers
Dan
Aspirant
Posts: 87
Registered: ‎2010-10-02

Re: missing files and folders when streaming

Maybe updating ReadyDLNA is a option? > viewtopic.php?f=76&t=27946
Frontview > Services > Streaming services > Under ReadyDLNA hit the 'Rescan media files' button.

@vic20ian:
Do you browse the ReadyNAS with DLNA protocol from your PC?
NAS:Netgear ReadyNAS NVX Pioneer Edition RNDX400E
Network:Linksys WRT54GL, TP-Link WR1043N
Clients: Windows 8.1 Update 1,Hyper-V Server 2008, Freecom MusicPal, Xtreamer MK1(Sidewinder kit), Sony BRAVIA KDL-40NX700
Aspirant
Posts: 2
Registered: ‎2011-07-12

Re: missing files and folders when streaming

Hi, i tried that and still missing folders when viewing on WD live box.

I can see them when viewing via PC, or on the NAS itself. Currently out of ideas.

Cheers
Dan
Aspirant
Posts: 2
Registered: ‎2011-07-15

Re: missing files and folders when streaming

Hi,
I have the same problem.
With upgrading my Ultra6 to 4.2.17 (from 4.2.15) mediascan does not complete and only 2 folders of many more are found.
DLNA upgrade to 1.0.20 does not help. With 4.2.15 there were no problem.
Furthermore I have a NV+ with RAIDiator 4.1.7 and an old dlna version. Works with no problem. But its urgent that the Utra works.
Has anyone any idea and/or suggestions to fix this problem.
Up to now, I does not found anything in this forum which could help to fix my problem.

Sometimes I think this problem seems insignificant for Netgear.
Altough there exist customers which use and bought their product ONLY for media streaming,
no updates/comments/workarounds in sight???

thanks a lot for any suggestions which could help.
thanks for any reply that gives me the feeling that I am not alone.
Ultra6 RAIDiator 4.2.17 dlna 1.0.20 and NV+ RAIDiator 4.1.7 dlna 1.0.18.2
Aspirant
Posts: 87
Registered: ‎2010-10-02

Re: missing files and folders when streaming

Corrupt Files?
viewtopic.php?f=76&t=48738
NAS:Netgear ReadyNAS NVX Pioneer Edition RNDX400E
Network:Linksys WRT54GL, TP-Link WR1043N
Clients: Windows 8.1 Update 1,Hyper-V Server 2008, Freecom MusicPal, Xtreamer MK1(Sidewinder kit), Sony BRAVIA KDL-40NX700
Aspirant
Posts: 2
Registered: ‎2011-07-15

Re: missing files and folders when streaming

I think not that there are corrupt files (but I will check next weekend),
because I copied the movie folder from my Ultra to my NV+ and my NV+ (with RAIDiator 4.1.7 dlna 1.0.18.2) has no problems to scan.
The NV+ streams perfect (as the Ultra before the upgrade to 4.2.17).
Ultra6 RAIDiator 4.2.17 dlna 1.0.20 and NV+ RAIDiator 4.1.7 dlna 1.0.18.2
Aspirant
Posts: 24
Registered: ‎2010-04-23

Re: missing files and folders when streaming

dang0404 wrote:
Hi All, i have the same issue, dont believe any update has happened. I run a WDTV live and a ReadyNAS NV+, but the WD only see's like 2 or 3 folders and not 5 or 6 like it should.

I have been working on this for a while and cant seem to come up with a solution. Had a look through these forums and couldn't see anyone else have a definite solution either.

Is there someone to contact about this issue as it was working fine for months then just started doing this.

Any advice would be appreciated.

Cheers
Dan


Same issue for me on WDTV Live and PS3... only shows top 4 folders on both devices. Netgear support haven't been able to resolve.
Aspirant
Posts: 6
Registered: ‎2010-03-24

Re: missing files and folders when streaming

dang0404 wrote:
Hi All, i have the same issue, dont believe any update has happened. I run a WDTV live and a ReadyNAS NV+, but the WD only see's like 2 or 3 folders and not 5 or 6 like it should.

I have been working on this for a while and cant seem to come up with a solution. Had a look through these forums and couldn't see anyone else have a definite solution either.

Is there someone to contact about this issue as it was working fine for months then just started doing this.

Any advice would be appreciated.

Cheers
Dan


Same issue here. I run PS3, TVIX 7000 and ReadyNAS Duo...Only a brink of the folders are shown and also...When I try to rescan for new mediafiles, the button is greyed out.

Anyone got a clue here?

Jeppe
Aspirant
Posts: 14
Registered: ‎2011-09-03

Re: missing files and folders when streaming

I seem to be experiencing something similar with an NV+. I have whole swaths of files and folders missing. For example, I have a folder that contains 85 files, but only the top 54 show - an 8GB mkv file is missing as are all the files after it. Some folders missing altogether. This is with uPnP/DLNA. All files and folders visible and accessible via CIFS. I'm chocking it up to a buggy uPnP/DLNA implementaiton until I hear or see otherwise.

Edit - I've done a little more experimenting. I attempted to stop the ReadyDLNA service, and it came up with an "error stopping ReadyDLNA service". The "rescan media files" button was greyed out. So I started the service. In WM, the movies showed up, up to but not including to what appeared to be an offending 8GB mkv file. So, I removed that file and again tried to stop the ReadyDLNA service, and again it came up with "error stopping ReadyDLNA service". I started it. The media scan has now gone beyond the apparently offending file and is picking up stuff it hadn't seen before. It appears as though the scanner is choking on the offending file and either giving up or restarting then choking on the same file again. Humbly, this appears to be a pretty nasty bug in the media scanner.

Edit - Swapped out the ReadyDNLA with the debug version. Now I can watch this happen. The scanner is totally wonky. When it comes across a file it doesn't like, it chokes and dies, along with any watches it previously set. According to the bug database for minidnla, upon which this add-on is based, this appears to be a known issue. This needs to be bloody well fixed, tell you what. Using CIFS to access files via shares is the only workaround. Pretty sad if you ask me. The Netgear folks need to get on this, pronto. Normally I would say "with all due respect", but I'm out $350, $700 counting the 4X2TB disks. I'll be calling support in the morning to register my displeasure. I suggest anyone else experiencing this problem do the same.

For the time being, I've disabled ReadyDNLA. It's totally busted.

Mike
Aspirant
Posts: 14
Registered: ‎2011-09-03

Re: missing files and folders when streaming

Upon further investigation, I got to this:

http://sourceforge.net/projects/minidlna/

That is the project upon which ReadyDLNA is based. Note that the project is being done by a Netgear employee.

If you have a look at the bug database, you'll see a few items in there that report issues very similar to what we're seeing. This appears to be a known issue. FWIW, as I have always felt, this seems to be a problem with the scanner itself.
Aspirant
Posts: 14
Registered: ‎2011-09-03

Re: missing files and folders when streaming

I've reinstalled TwonkyServer and purchased a license - about $21CAD. It's a bit of a bugger setting it up, but once that's done it does not have the folder problem live ReadyDLNA does - everything scans up just fine and it's pretty damn quick about it too.

Some notes for those who care to go this route, as a fix for the scanner issue doesn't seem imminent.

You'll need to install the enable-root-ssh add-on and ssh into your device. I have a share called "videos" with a folder called "videos" in it where all my stuff is stored. I was unable to get Twonky to scan that folder as it auto-prepends /c/media to any entry in the shares you add to the config interface. What I did was add a symlink in /c/media to /videos/videos and away it went.

Also, if you have very large files you may want to edit the Twonky config file. There's a setting there for the maximum scan time per file, which is defaulted to 30 (seconds). I've upped that to 120 and it seemed to have smoothed over the scans of my larger mkv files.

The config file is located at /var/twonkymedia/twonkymedia/twonkymedia-server.ini. You'll have to use vi, google for a vi cheat sheet if you're not familiar with it. A little painful, this whole process.

I've left ReadyDNLA disabled because it's useless.

Shame I had to spend $20+ to correct this, but what the heck. I needed a solution.

There you have it.

Mike
Aspirant
Posts: 4
Registered: ‎2011-11-03

Re: missing files and folders when streaming

Thank you dillyhammer ! Smiley Happy
I have been having the very same problems with my 4000NV+. I am tring to view my movies on my ipad using "ACEPlayer" (A good little ipad app that uses DLNA to stream and play all video formats direct from the NAS).

It takes sooo long to scan (though I do have 7500 music, 350 movies and 1000 tv shows) and it seems to stop and hang during its scan half way through my movies folder (in alphabetical order) and doesn't scan in any further movies or folders.

Using your very helpful post (a lot more helpful than Netgear tech support), I found that it was stopping on a MKV file (7 GB), though NOT the biggest file I have, 10 and 11 GB movies scanned in just fine.

My simple way of finding what file it got stuck on was by using the free "8player lite" iPhone app, which allow you to quickly view the DLNA library, find the last movie scanned in, and then finding the next movie from the network share on the PC (in alphabetical order).
Delete the offending MKV off the NAS. And then stopped and restarted DLNA.

Yes, it had to rescan the entire NAS again, :evil: took about 2 hours, but found all the rest of the movies and continued to find ALL my TV Show folders and episodes! Smiley Very Happy

After it was completed, in my readyNAS frontview, under DLNA, I now have the "Rescan meda files" button available (always used to be grayed out while DLNA was running).

The very sad thing is because this is technically a currupted MKV file problem, Netgear may not bother fixing it. But it really can't be a difficult fix to simply have their scanner just skip over files it finds that it cant scan, instead of hanging indefinatly.
Aspirant
Posts: 6
Registered: ‎2011-11-08

Re: missing files and folders when streaming

+1 come on Netgear, please fix this!!!
Aspirant
Posts: 20
Registered: ‎2011-08-19

Re: missing files and folders when streaming

I have the same issue with Sony Bravia TV and ReadyNAS Duo (missing folders/files on streaming, but not missing via PC or on ReadyNAS). Anyone come up with a solution?
Aspirant
Posts: 35
Registered: ‎2009-04-29

Re: missing files and folders when streaming

I just picked up a WDTV Live that I am streaming to and I am experiencing this same issue.
Guru
Posts: 29,274
Registered: ‎2015-07-16

Re: missing files and folders when streaming

rlyon wrote:
I just picked up a WDTV Live that I am streaming to and I am experiencing this same issue.
The WDTV Live can also access the shares directly, avoiding any issues with DLNA
Aspirant
Posts: 35
Registered: ‎2009-04-29

Re: missing files and folders when streaming

StephenB wrote:
rlyon wrote:
I just picked up a WDTV Live that I am streaming to and I am experiencing this same issue.
The WDTV Live can also access the shares directly, avoiding any issues with DLNA


I'd love to know how. I saw the 'media share' option and it sees my 'media' folder but when I click on it, the Live freezes. My media share options were samba/NFS I think, (new firmware they are windows/linux) but I can't get it to not freeze.

Are there steps to make this happen?
Aspirant
Posts: 65
Registered: ‎2010-06-30

Re: missing files and folders when streaming

same problem here on a variety of devices (Sony Bravia, Samsung Galaxy SII phone, HP touchpad). All seems to be since f/ware update. It seems ok with several folders full of thousands of photos but I only get a few music folders.

As it currently stands the ReadyNAS Duo I have is not fit for purpose and does not function as advertised. Can we have a fix ASAP please.

I have tried rescanning and stopping/starting the service with reboots to no avail.

Thanks

R.
NETGEAR Moderator
Posts: 44,958
Registered: ‎2011-06-07

Re: missing files and folders when streaming

Discussion Stats
Top Contributors