Reply
Occasional Contributor
Posts: 5
Registered: ‎2013-10-26

ssh

ReadyNAS ultra4

I am tried of flaky behavior, and I want to look at real logs. I toggled SSH and installed EnableRootSSH. I can establish a connection by SSH, but it does not take the admin password. I am SURE I am not mis-typing it. Smiley Happy

Any clues where to look next?
NETGEAR Moderator
Posts: 38,953
Registered: ‎2011-06-07

Re: ssh

You have to login as the 'root' user with the 'admin' password. The 'root' user's passwords initially set to be the same as the 'admin' password. Remember the add-on is EnableRootSSH
Occasional Contributor
Posts: 5
Registered: ‎2013-10-26

Re: ssh

I am attempting to log in as root.

$ ssh root@10.5.69.250
root@10.5.69.250's password:
Permission denied, please try again.
NETGEAR Moderator
Posts: 38,953
Registered: ‎2011-06-07

Re: ssh

Try installing EnableRootSSH again
Occasional Contributor
Posts: 5
Registered: ‎2013-10-26

Re: ssh

Did that. No love.
Contributor
Posts: 38
Registered: ‎2009-07-10

Re: ssh

Did you find a solution?

I have the same problem with a NVX (RAIDiator 4.2.25).
I'm sure I could ssh as root before. Now I get a permission denied error. I tried to install EnableRootSSH several times, and to reboot too. Strangely, I can't "'shutdown and reboot" nor "shutdown and turn off device" from Frontview anymore (I need to press the power button 3 times). It worked the first time I installed EnableRootSSH today, but not anymore.

ssh as admin with the admin password does work, but the connection is closed:


[PAt:~] pdelges% ssh admin@192.168.0.7
admin@192.168.0.7's password:
Last login: Wed Dec 4 11:10:39 2013 from 192.168.0.15 on pts/0
Linux BU-2TbRaid 2.6.37.6.RNx86_32.1.4 #1 Wed Oct 23 11:00:31 PDT 2013 i686 GNU/Linux
Last login: Wed Dec 4 11:20:05 2013 from 192.168.0.15
Connection to 192.168.0.7 closed.
[PAt:~] pdelges% ssh root@192.168.0.7
root@192.168.0.7's password:
Permission denied, please try again.
1x NVX, 1x Ultra2+, 1x RN312
NETGEAR Moderator
Posts: 38,953
Registered: ‎2011-06-07

Re: ssh

As I suspected your root line in your /etc/shadow file was messed up.

Should be working now.
Discussion Stats
  • 6 replies
  • 72 views
  • 0 kudos
  • 3 in conversation
Top Contributors
User Kudos Count
41
28
16
10
2