Reply
Initial Contributor
Posts: 1
Registered: ‎2011-11-07

"Error reading setup initialization file" error when trying to uninstall WNDA3100?

Hi there. The wireless adapter I use on my primary computer (my desktop) is a Netgear WNDA3100. It has worked beautifully since I bought it in April. A couple days ago the internet connection became extremely slow (1-2 minutes to load google.com, for example, with a 1 bar connection) and after doing the standard things like unplugging my gateway, calling my isp, unplugging my adapter, troubleshooting/diagnosing, etc. I decided to uninstall the drivers and reinstall.

The problem is, when I try to uninstall using the control panel (same thing happened with CCleaner's uninstall module and Glary Utility's uninstall module) it goes through the first step and then an error message pops up that says "Error reading setup initialization file." I googled and almost everything that came up had to do with people getting that error after trying to install from an exe file, not after trying to uninstall. All of the solutions I have found involve downloading a new file for the same driver which won't help because I am trying to uninstall. So, I restarted a couple times, rebooted in safe mode, used system restore to restore to an earlier point in time, and the same thing keeps happening. I backed up my files and deleted every netgear file on my computer and it still didn't work. So, I tried to reinstall the driver without uninstalling first and I get the same error message. I also tried uninstalling with the driver's official uninstall.exe and the same thing happened.

Anyone have any ideas or suggestions? I also posted this on a Windows 7 forum website as well. Thank you so much in advance!
Discussion Stats
  • 0 replies
  • 8080 views
  • 0 kudos
  • 1 in conversation
Top Contributors