Reply

Re: Adapter A6210 not detected

RV11
Tutor

Adapter A6210 not detected

Was not having any issues at all with my A6210 using Windows 10 until Thursday evening, 10/20, when I updated my software version to number 35.  Now, the genie on installation will not detect the adapter.  The message keeps instructing me to insert the wireless USB adapter into my computer and click yes.  I tried this numerous times, but the genie never detects the adapter, and this message continues to pop up.  What am I doing incorrectly?  This is becoming very frustrating.  Any suggestions???  Thanks. 

Model: A6210|AC1200 High Gain Antenna WiFi USB Adapter
Message 1 of 71
Jay7900
Aspirant

Re: Adapter A6210 not detected

Same issue here: device not detected by the Genie installer, in multiple USB ports. Windows 10 automatically reverts to Mediatek drivers during the installation process. Manually uninstalling these Mediatek drivers doesn't solve the issue: as soon as Netgear's installer asks me to insert the device, Windows goes with the Mediatek drivers and Genie cannot detect the device. °sigh°

 

I've also tried to roll back to v34: the issue persists.

 

I just hope I won't have to start believing all the "never again" posts about Netgear's reputation. So far the A6210 has been working fine, but for now this feels a bit like a botched update.

 

JJN

 

Message 2 of 71
steveath
Guide

Re: Adapter A6210 not detected

Same issue here. A6210 not detected since software update 35. Even reinstalling the original driver from cd does not help.

Message 3 of 71
TorrendotTaxes
Aspirant

Re: Adapter A6210 not detected

Having the exact same issue since trying to install the .35 update; my a6210 adapter is failing detection. I've uninstalled the netgear genie to try a reinstall but no luck so far. 

Message 4 of 71
Angus66
Aspirant

Re: Adapter A6210 not detected

I'm having the same problem as everyone else - my A6210 adapter isn't recognized by the latest Netgear software. Uninstall/reinstall/etc doesn't fix the problem.

 

Only (temporary) solution is to just uninstall everything, restart and let Windows 10 install the driver from 04/21/15.

 

Is Netgear addressing this problem???

Model: A6210|AC1200 High Gain Antenna WiFi USB Adapter
Message 5 of 71
RV11
Tutor

Re: Adapter A6210 not detected

Netgear has not chimed in at all regarding this issue.

Message 6 of 71
RV11
Tutor

Re: Adapter A6210 not detected

I am hoping Netgear will offer a rememdy to the matter. 

Message 7 of 71
steveath
Guide

Re: Adapter A6210 not detected

Just bumping. Before the 35 update I was getting between 90 and 200 mps (I have 300 mps fibre optic). I am now getting between 5 mps and 21 mps!

 

Come on Netgear - lets have it sorted please.

Message 8 of 71
Angus66
Aspirant

Re: Adapter A6210 not detected

I'm losing hope that a fix will ever be provided by Netgear + I'm having more frequent disconnects as of late.

 

I'm thinking that buying a different adapter is the only remedy at this point.

 

Can anyone recommend a AC1900 adapter to replace the A6210???

Message 9 of 71
TorrendotTaxes
Aspirant

Re: Adapter A6210 not detected

Still no help here? I'll try getting in touch with Netgear support in the morning. I've tried everything I can to get this USB stick to work.

Message 10 of 71
eyalglobal
Tutor

Re: Adapter A6210 not detected

Wake up NETGEAR your latest update ruined it for all A6210 Windows 10 owners!!!!

Message 11 of 71
Gr8tful
Initiate

Re: Adapter A6210 not detected

My Windows 10 OS did not like the .35 update either.  Tried to uninstall and reinstall.  Now I have no Genie program...appears to install, asks me to plug-in the A6210 but never recognizes it.  Just asks over and over. Frustrating there has been no assistance to this thread in 2 weeks?

Model: A6210|AC1200 High Gain Antenna WiFi USB Adapter
Message 12 of 71
bjwierda
Aspirant

Re: Adapter A6210 not detected

Same problem with latest release.

 

The adapter is detected as a wireless ac adapter and not a netgear adapter, this is probable why the tool dont find it.

 

Why did i update Smiley Sad

=========================
Im no Expert, Im often wrong 🙂
=========================
Message 13 of 71
Catt62
Tutor

Re: Adapter A6210 not detected

My adapter stopped working and support told me it was the adapter so yesterday I went and bought a new one, went through the processes over and over and they couldn't fix it they said engineering is aware of the problem but have no eta for a fix, so I bout a new adapter on their reccomendation and threw away one that was probably still good

Model: A6200|AC1200 WiFi USB Adapter
Message 14 of 71
RV11
Tutor

Re: Adapter A6210 not detected

This is ridiculous.  Netgear is turning a blind eye to this issue.  Not one response from the company. 

Message 15 of 71
Dunks
Tutor

Re: Adapter A6210 not detected

Exactly the same problem. Netgear, what's the answer please? This is urgent.

Message 16 of 71
eyalglobal
Tutor

Re: Adapter A6210 not detected

As I've been having the same problem with slow connection since latest driver update. I did some research, tested it on another computer and reached the following conclusions:

 

1. The problem is probably with a recent Windows 10 update, as it ocurres now with any new install even with previous driver releases.

2. The D-Link AC1900 Wi-Fi USB adapter (DWA-192) is much more stable and much faster than the A6210. period!!! from the same distance (22ft+walls) and position (desk). I was able to reach 1.9Mbs with the Dlink while Netgear gave me no more than ~800Mbs.

 

Enjoy... I moved on.

Message 17 of 71
Dunks
Tutor

Re: Adapter A6210 not detected

Thanks for your advice eyalglobal. Having looked through reams of comments like yours and miune, on Netgear's own forum, they continue to push out an upgrade that renders their adaptors useless. The sheer inconvenience, time and cost this throws on their customers is immense, and in bad faith. And as far as I can see, their last update on this on their site was in May. MAY. 

 

Netgear: a challenge. First, how about a good old fashioned apology to us all? Second, a full explanation about why you continue to send out upgrades that you know don't work? And third, how do I apply for my refund?  

 

Over to you.      

Message 18 of 71
steveath
Guide

Re: Adapter A6210 not detected

Thanks for the advice. I only purchased my A6210 in April so it is still under warranty. As it clearly is not working correctly is it a case of returning for repair (Postage at my expense) or a refund?

 

Some response from Netgear on this thread is way overdue!

Message 19 of 71
Johnap
Aspirant

Re: Adapter A6210 not detected

Having the same issue, was wondering if you were going to offer a solution??

Message 20 of 71
DaveinNE
Aspirant

Re: Adapter A6210 not detected

I had the same issue and posted in a different sting.  SShikles told me to go to downloads and run the one that says standalone.  I did that, got a message that says the driver was installed.  I think went to settings and connected that way, found my network, logged in and it works!   Thank you SSHhikles.   No thank you to Negear.  I run a business and this caused me to lose 4 hours of my time.  

Message 21 of 71
Retired_Member
Not applicable

Re: Adapter A6210 not detected

Same exact issue here also.  Upon updating to " version 35 ", Genie willnot recognize or detect the adapter.  Message window directs you to insert the adapter, & click yes.  Upon doing so, it responds with " USB A6210 adapter cannot be detected ".  I'm "livid", especially since any & all attempts to contact support have been for naught !!!!!!!!

Any help with this issue would be most appreciated.

Message 22 of 71
Dunks
Tutor

Re: Adapter A6210 not detected

Very impressed by Currys/PC World who have agreed to refund the purchase price of my A6210 adapter. Despite the problem being entirely down to Netgear, they have taken ownership and are doing the decent thing. Apparently their (Curry's) tech team spent several days trying to find a workaround, but couldn't.

 

Netgear's deafening silence over this will come home to roost, not just with little guys like us, but with one of the UK's biggest retailers of PC equipment and accessories. An own goal indeed.    

 

FYI, I've since moved on to an Edimax AC 600 adapter. Beginner's luck maybe, but it works perfectly with Windows 10.  

Message 23 of 71
Retired_Member
Not applicable

Re: Adapter A6210 not detected

Thanks for the tip on the Edimax Dunks, I'm done with Netgear, besides, a miniscuile 90 day "complimentary" tech support upon purchase, then a minimum $50 purchase required after 90 days !! Had I realized that when I bought the darn thing, I would've never purchased it. Besides, it looks like Netgear is headed towards the same fate as the "Pandigital Tablets ( E-readers)" from 2 years ago. The Sony spinoff company went belly up & never offered any refunds, recourse, or replacements. lol -- They just "disappeared" into the world of technology Twilight Zone !!!!

Message 24 of 71
jeffmiles
Tutor

Re: Adapter A6210 not detected

I too bought an A6210, for my wife's Dell desk top running Windows 10 with all current updates.

 

There is no way that I can get the device properly installed - same problem as everybody else - adapter not recognised. I have tried all the fixes and work arounds without success.

Why should I have to do this? Netgear is not some fly-by-night operation.; it is an established company with a reputation to maintain.  I expect hardware and software that I pay good money for to work properly first time, every time, out of the box.

 

Got so fed-up I went and bought an Edimax AC600 - a tiny but perfectly formed bit of kit that works perfectly first time out of the box with W10 - no fuss no trouble, dead easy installation and excellent clear instructions.

 

I recommend it!

 

I think Netgear needs to take a serious grip and update its software to the current version of W10, or its reputaion and customers will evapourate like the morning dew in July.

Message 25 of 71
Top Contributors
Discussion stats
Announcements

Orbi WiFi 6E