× NETGEAR would like to hear from you about specific features so we can improve your experience. To participate in this survey please click HERE.
Reply

AC750 - No internet

wrootrhino
Aspirant

AC750 - No internet

Hello,

 

I have had this set up for about 3 years with no problems. However I now cannot connect to the internet using the extended network. The lights on the extender indicate it is connected to the router. I am a complete novice and have no idea what to do. I have carried out a factory reset and tried setting it up again from scratch without success. Any advice, in laymans terms, much appreciated.

 

Thanks

Model: EX3700|AC750 WiFi Range Extender Essentials Edition
Message 1 of 4
plemans
Guru

Re: AC750 - No internet

Are you setting it up using the WPS button or using the installation assistant? 

What router is it connected to?

Current setup: CM2000-> RBKE963B-> Trendnet TEG-S380-> GS716T-> pi-hole
also in AP setup: RAXE500->EAX80
1.4gig download/50mbps upload from Xfinity
We’re members of the public helping out on our own time.
Message 2 of 4
wrootrhino
Aspirant

Re: AC750 - No internet

Hello, Thanks for your reply

I have tried both Installation assistant and WPS. I can connect to the extended network but I  am at a loss to understand why it should prevent internet access when, if I connect to the hub using wi-fi I have no problem. The hub is a Plusnet Hub1 manufactured by Sagemcom but I can't identify a model number.

Message 3 of 4
plemans
Guru

Re: AC750 - No internet

I've never been a fan of ISP supplied routers. Seem to run into constant issues. 

have you tried setting up the extender with a static ip address in the router? 

Current setup: CM2000-> RBKE963B-> Trendnet TEG-S380-> GS716T-> pi-hole
also in AP setup: RAXE500->EAX80
1.4gig download/50mbps upload from Xfinity
We’re members of the public helping out on our own time.
Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 316 views
  • 0 kudos
  • 2 in conversation
Announcements

Orbi WiFi 6E