Reply
Highlighted
Follower

EX7500 Internet Access keeps dropping for connected devices

Hi,

Sorry, have seen similar posts but no public solutions?
Last week I bought and setup the EX7500 extender . The setup was easy, and all devices where working fine. However every few hours/minutes the devices lose internet access but still have conection the extender. I have updated firmware, factory reset, and tried the setup again and the same thing happened. The extender has no problem connecting to the router (all lights blue) when the EX7500 is unplugged and my devices are connected to the main router they all have internet access.

Any help appreciated.
Many Thanks
P
Model: EX7500|AC2200 Nighthawk X4S Tri Band Wall Plug WiFi Range Extender
Message 1 of 7
Highlighted
Initiate

Re: EX7500 Internet Access keeps dropping for connected devices

I’m having what sounds like exactly the same problem. It was working fine for a week, then today no traffic/bandwidth over extender. My phone thinks it’s connected, the ex7500 has all blue lights, but yet no internet and no access to other things on network like Philips Hue. Unplug the ex7500 and everything works again.
Message 2 of 7
Highlighted
Aspirant

Re: EX7500 Internet Access keeps dropping for connected devices

I have experienced the same loss of Internet connectivity for any device connected to my EX7500 Nighthawk X4S Tri Band WiFi Mesh Extender. A couple of times this month the WiFi connection has stayed up, but the Internet has been unavailable.  Meanwhile, devices connected to my Nighthawk R7000 router via Ethernet cables maintained their Internet connections. The Nighthawk R7000 is connected directly to a Verizon FIOS box for Internet connectivity. Shutting down the EX7500 Nighthawk X4S and connecting only to the R7000 was the only way to restore Internet connectivity.

 

Model: EX7500|AC2200 Nighthawk X4S Tri Band WiFi Mesh Extender
Message 3 of 7
Highlighted
Aspirant

Re: EX7500 Internet Access keeps dropping for connected devices

I have exactly the same problem. The extender will work for several hours, then all the devices connected via 2.4GHz will lose their internet connection. 5GHz devices stay connected to the internet. Unplugging the extender allow the devices to reconnect. I can plug it back in and everything will be fine again.  These devices include several smart switches working at 2.4GHz, along with phones and laptops. 

 

What should I do? Its suprising that no answers have been posted here. 

Model: EX7500|AC2200 Nighthawk X4S Tri Band WiFi Mesh Extender
Message 4 of 7
Highlighted
Tutor

Re: EX7500 Internet Access keeps dropping for connected devices

I am having the exact same issue of the internet connection dropping constantly. Can netgear please action this defect? 

Message 5 of 7
Highlighted
Aspirant

Re: EX7500 Internet Access keeps dropping for connected devices

I am having the exact same issues. Purchased ex7500 in June 2019. 5ghz network is dropping constantly and is causing other devices to not even connect to WiFi or get stuck in no mans land. Need help..I want give up and throw in trash!!!!
Message 6 of 7
Highlighted
Aspirant

Re: EX7500 Internet Access keeps dropping for connected devices

Same issue, drops internet connection, unplug, plug back in and works again for a short time. Using it with a Nighthawk R7000. Looks like I’ll be returning it.

Message 7 of 7
Top Contributors
Discussion stats
  • 6 replies
  • 1341 views
  • 1 kudo
  • 7 in conversation
Announcements