Extender wont connect to 5G (but does connect to 2G)


Extender wont connect to 5G (but does connect to 2G)

Can anyone help I'm having ongoign issues. My extender will connect to the 2G network on my home router (Virgin Business Broadband) but it wont connect to the 5G despite going through the set up and connecting to it. I've tried everything I can think of. Virgin Media suggest it's becuase I need a static IP address, but I have to pay extra for this. 


I'm using a mac, when I try and connect to the 5G network my system preferences tell me:


"Wi-Fi has the self-assigned IP address and will not be able to connect to the internet."


I've tried manually entering the IP address and that doesnt work


I've tried connecting to the extender using the IP address but this never works, the page just hangs loading and never connects - I dont have a cable.


I've tried using these instructions but I dont have a Netgear router (it's Hitron) so that doesnt work either


Any ideas??





Model: EX6120|AC1200 Dual Band WiFi Range Extender
Message 1 of 1
Top Contributors
Discussion stats
  • 0 replies
  • 0 kudos
  • 1 in conversation

Orbi WiFi 6E