× Introducing the Orbi 970 Series Mesh System with WiFi 7 technology. For more information visit the NETGEAR Press Room.
Orbi WiFi 7 RBE973
Reply

N300 WiFi Range Extender

mohdrizk
Aspirant

N300 WiFi Range Extender

My Netgear wifi extender N300 keeps dropping the connection for seconds all the time. And I am not able to update the firmware automatically neither manually, the latest firmware is out there on the official website but whenever I try to do the update it I receive the following message: The firmware you are trying to upload is the same as the current firmware that is on the extender. Do you still want to continue? Current Version: 1.0.2.50 New Version: 1.0.2.50 The downloaded file is: WN3000RPv3-V1.0.2.52
Message 1 of 5
BrianTX
Aspirant

Re: N300 WiFi Range Extender

i had the same problem.  I downloaded the older version of the firmware and installed it.  Seems to have fixed my packet dropping issue.

Message 2 of 5
mohdrizk
Aspirant

Re: N300 WiFi Range Extender

Thanks BrainTX, I'll give it a try
Message 3 of 5
BrianTX
Aspirant

Re: N300 WiFi Range Extender

Also, make sure that both WPA options for TKIP and AES are on.  When I turned on only AES, I would drop packets pretty bad.  The wifi connection LED would blink red alot.  This was fixed when I enabled TKIP and AES

Message 4 of 5
CDAPete
Aspirant

Re: N300 WiFi Range Extender

 

My Netgear EX2700/N300 works great, sets up easily and has a strong signal... but only for a brief time. It constantly disconnects and I must reestablish the connection after just 30-60 minutes or so. I have a new Samsung Galaxy Note 8 phone and also a Samsung Tab A. This issue exists when using either device. I set my Arris router's wireless settings for both WPA and WPA2 (for TKIP & AES as suggested) and have also installed the latest firmware for the Range Extender and have confirmed that it is in fact up to date. I reset the unit and did a fresh setup and all seems to go very smoothly but still it just continues to disconnect all the time and I cannot figure out why.  When I connect any device to my Arris router's wifi directly I have no issues. The issues are only when using the extender. I am ready to trash this and start over elsewhere but hope springs eternal. Any thoughts on this? 

Model: EX2700|N300 WiFi Range Extender
Message 5 of 5
Discussion stats
  • 4 replies
  • 1082 views
  • 0 kudos
  • 3 in conversation
Announcements

Orbi WiFi 7