× Introducing the Orbi 970 Series Mesh System with WiFi 7 technology. For more information visit the NETGEAR Press Room.
Orbi WiFi 7 RBE973
Reply

Router has WPA2 but Extender detecting it as WEP

Brzam
Follower

Router has WPA2 but Extender detecting it as WEP

Hello,

 

So I've just bought this Wifi Extender and got it all setup perfectly fine, both our 2G and 5G connections from the router are WPA2. However, I then opened the mywifiext.net and it said there was a firmware update (Latest), I completed the update. But now it is recognising my 5G network from the router as a WEP and thus wont allow me to enter my WPA2 Key so cannot connect, The 2G connection is absolutely fine and still being recognised as a WPA2.

 

I have tried manually typing the SSID and then selecting WPA2 as the security key, but it just returns that the password is incorrect. Everything was working absolutely fine prior to the Firmware update so have attempted to revert back, and tried the two previous updates. Both of which still give the same results.

 

I am 100% sure that the network is a WPA2 as can be seen here http://prntscr.com/h44koc

 

Please help!

Thanks,

Sam

Model: EX6120|AC1200 Dual Band WiFi Range Extender
Message 1 of 2
ElaineM
NETGEAR Employee Retired

Re: Router has WPA2 but Extender detecting it as WEP

Welcome to the community, @Brzam

 

Did you try resetting the unit after uploading the firmware? 

It might just be a glitch.

 

 

ElaineM
NETGEAR Community Team
Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 838 views
  • 0 kudos
  • 2 in conversation
Announcements

Orbi WiFi 7