× Introducing the Orbi 970 Series Mesh System with WiFi 7 technology. For more information visit the NETGEAR Press Room.
Orbi WiFi 7 RBE973

Unable to manage


Unable to manage

Hello all,


I have had an (EX6120) AC1200 range extender for a wee while now, and for said while it has worked fine - so never gave it another thought (as you do). Recently I've noticed it connects devices, but doesn't provide internet traffic. Before shifting closer to the main router, I tried to manage the device via mywifiext but no joy. Tried the current leased IP address whilst physically connected - nope same error.


The error 'This site can't provide a secure connection'

<ip address> uses an unsupported protocol ERR_SSL_VERSION_OR_CIPHER_MISMATCH


Meanwhile, I've shifted the location closer to the main router and once more the unit functions as intended but I still can't manage it. 

I've decided to switch modes to AP but before factory resetting (and risking loosing the use of this in its current mode),

I'd prefer to be able to manage it again - has anyone any clue what's going on here?



I can't say for sure what firmware is currently loaded 

I've attempted to manage via;

Android 13 (Brave, and Firefox)

Wired from Windows 10 (21H2) PC using Brave & Firefox, and Wirelessly from Windows10 (21H2) laptop again using both Brave v1.51.114 & Firefox v111.01





Message 1 of 2

Re: Unable to manage

Did you set it up using the push button WPS option? 

If so, factory reset the extender  and set it up using the installation assistant.

To factory reset, push and hold the reset button for 7-15 seconds while powered on. 

Here's a video of how to use the assistant. 


Current setup: CM2000-> RBKE963B-> Trendnet TEG-S380-> GS716T-> pi-hole
also in AP setup: RAXE500->EAX80
1.4gig download/50mbps upload from Xfinity
We’re members of the public helping out on our own time.
Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 0 kudos
  • 2 in conversation

Orbi WiFi 7