Who Me Too'd this topic


R8000p can't update firmware

Router = Netgear R8000P

Router Firmware = V1.4.1.50_1.3.10


The firmware on my router after a factory reset is V1.4.1.50_1.3.10. I have used the Advanced>Administration>Router Update page to "Check" for any new version of firmware, but always receive a message that states "No new firmware version available."


Upon reviewing the Negear support page for the R8000p, I found that there is a newer version that was posted earlier this month V1.4.1.62_1.3.22. So, I downloaded the zip file containing the firmware, unzipped it and attempted to update the firmware on the router via the Advanced>Administration>Router Update page. The upload begins and I'm shown a progress bar. I can see the router reboot and when it comes back online, the firmware on the router still says "V1.4.1.50_1.3.10" in the top right corner of the page. 


I have tried a factory reset from the router's UI, followed by another attempt to upload the new firmware, which also does not succeed. I have tried a factory resent from the router's "reset" button on the back pannel, which is not successful either. 


After reading a few other posts I saw some people mention to log into the router via http://www.routerlogin.net/ instead of , which I have also tried, but no luck updating the firmware successfully. 


I would really appreciate any advice. Thank you!

Model: R8000P|Nighthawk X6S AC4000 Tri Band WiFi Router
Who Me Too'd this topic