Who Me Too'd this topic


X6 R7850 Can't Update Firmware

.I have a Netgear Nighthawk X^ R7850 ... Bought it last year. It is currently running firmware Rev For weeks/months now, it has been telling me that there's a firmware upgrade for the device ... Rev I have told the device repeatedly to "Auto" the update, but it never does. I've tried this both through the Nighthawk app on my phone, and by logging into the router directly through a web browser, It doesn't matter what web browser, either ... I've used them all to try to do this (Edge, Internet Explorer, Chrome, Firefox and Opera). When I try the "Auto" route, I never get an error message, I just don't get the update loaded and operational.


I've ALSO tried to download the update manually, and there I *DO* get  an error message ... "This firmware file is incorrect! Please get this firmware file again and make sure it is the correct firmware for this product." This is what happens when I try to manually install file "R7850-V1.0.5.68_10.1.75.chk". Screenshot of the error attached.


What IS the effing problem here?


Thanks In Advance!

Brad Harrington,

Liberty Computer Service

Who Me Too'd this topic