Who Me Too'd this topic

pumpichank
Luminary

Cannot update firmware on one Orbi sattelite

I just bought an Orbi RBK753 (RBR750 + two RBS750 satellites), along with a separate third RBS750.  It took several tries but I finally was able to connect the third satellite to the router.  At least, the Orbi app's network map says so.  The problem is that this third satellite cannot upgrade it's firmware.   Automatic online updates say "Downloading firmware" and then just "Update failed".  So then I click on Manual Update, select the appropriate satellite and Update.  But it always asks me to log in and it does not accept the router login.  So it is impossible to update the satellite.  I've tried to sync this third satellite several times, but the lights just blink white and never turn blue.  Yet the Orbi app still says they are connected.

 

I actually had this same problem with one of the satellites that came with the RBK753, but eventually I was able to manually update without it requiring me to log in.  I have no idea why this one started working, and no idea why the third satellite won't work.

 

The router and working satellites are all on firmware V4.6.5.14 while the non-working satellite is on V3.2.16.22.

 

How can I fix this?  The one time I tried to call Netgear support, it took about 20 minutes to talk to somebody and then they ended up hanging up on me after 5 minutes.

Who Me Too'd this topic