Who Me Too'd this topic

Can't login to RAX43v2 to change settings

Any time I try to login to my router, a RAX43v2, I get prompted for a username and password as expected.  However, as soon as I enter my username and password I get redirected to this stupid, unhelpful, indescript error page. 

StupidInsanity_0-1707443771213.png

The URL it keeps directing me to is: https://accounts-qa.netgear.com/error?redirectUrl=http:%2F%2F192.168.1.1%2Fgenie_redirect_SSO.htm&se... and I am very confused about what is going on with it.  I was trying to get my new TV on the wifi and no matter what I tried I was unable to get it to connect to the main SSID.  It was only connecting on the Guest SSID.

 

I have tried on 2 different computers, on my phone, it makes no difference. I've even tried the www.routerlogin.com page.  

 

As it stands I am unable to get in to manage my router.  What gives?  Why does my local admin login have to reach out to the internet for verification? Just let me in to the local administration interface! 

Who Me Too'd this topic