× NETGEAR would like to hear from you about specific features so we can improve your experience. To participate in this survey please click HERE.
Reply

Slow Wifi on 1 device..other devices working fine

Sandyuser
Aspirant

Slow Wifi on 1 device..other devices working fine

I recently bought Netgear N300 Wifi cable modem router (C3000-100NAS) and i see that the Wifi speed on one of my devices is very slow (<3 Mbps-Lenovo desktop). On all the other devices I am getting approx 20 Mbps. I tried putting all my devices in the same place to test the signal.Still Lenovo desktop gives very slow speed.

I tried changing the wireless channel but that didnt help.

I also tried updating the wireless drivers and that didnt help either.

Is there some other settings that need to be changed.

Any help on this would be highly appreciated

Message 1 of 4
Babylon5
NETGEAR Employee Retired

Re: Slow Wifi on 1 device..other devices working fine

Can you tell us what model of WiFi adaptor the Lenovo is fitted with please (from the Device Manager screen)? Also the device fitted to the other computers if you don’t mind.

____________________________
Working on behalf of Netgear
My name is Andy
Message 2 of 4
Sandyuser
Aspirant

Re: Slow Wifi on 1 device..other devices working fine

Lenovo has "1X1 11 b/g/n Wireless LAN PCI Express Half Mini Card Adapter" by Realtek.

The other device has "802.11n Wireless Lan Adapter" by Ralink

Message 3 of 4
Sandyuser
Aspirant

Re: Slow Wifi on 1 device..other devices working fine

The problem isn't solved. probably will have to replace the netgear router with a diff one
Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 3030 views
  • 0 kudos
  • 2 in conversation
Announcements

Orbi WiFi 6E