R8000P - Firmware won't upgrade


R8000P - Firmware won't upgrade

As the title says, the firmware won't update. The other day I came home and found both the 5G networks had "lost" their names and gone back to the defaults (WTF?). As I was renaming them, I noticed there was a firmware update.

Current Firmware Version
New Firmware Version


I chose to update. No change in firmware. I went to the Netgear site and manually downloaded the update (R8000P-V1.4.1.68_1.3.28.chk).  NOTHING. I tried using the app on my mobile phone - nothing.

I've tried updating the firmware now at least 5 times. NO luck. I am stuck on The router still works, but I've always had issues with the "readyshare" drive becoming disconnected. How long can I get by without a firmware update? Any assistance is appreciated.

Model: R8000P|Nighthawk X6S AC4000 Tri Band WiFi Router
Message 1 of 4

Re: R8000P - Firmware won't upgrade

You may be unlucky. This happened to me when my router was :-

Hardware Version R8000P
Firmware Version V1.4.1.50_1.3.10
GUI Language Version V1.4.1.64_2.1.46.1


I tried all the 'fixes' for firmware upgrade failures on the Netgear site - trying to downgrade the firmware, using TFTP firmware upgrade method etc


but none of them worked. An internet (ibcluding Netgear site) search revealed a lot of people with the same issue. It seems as though a glitch in V1.4.1.50 caused this - my router had either been upgraded manually via the web client or auto upgraded as this option was checked (I'm not sure which).


I don't know if they subsequently released a fixed version of the same update as is still available on the website or whether it was caused by the web/auto update method?


My router was still under guarantee so I contacted support and after getting me to try all their standard fixes they eventually arranged an RMA.


The new router was on  a later firmware version and since then I have unchecked the 'upgrade automatically' option and download the file from the Netgear site and manually upgrade. I occasionally try the 'Check' option on the router 'Router update' page to see if anything is available but for the latest hot-fix update "V1.4.1.82_1.3.40" it said there was no fix available but it was available on the Netgear support  page.


(The firmware pages also warn Note: Do not upgrade the firmware using a wireless connection. Please perform firmware upgrade with “wired” or Ethernet connection only.



Model: R8000P|Nighthawk X6S AC4000 Tri Band WiFi Router
Message 2 of 4

Re: R8000P - Firmware won't upgrade

Yeah, I saw that this seems to be experienced by others as well. Based on your post, I did try connecting to the router via ethernet wire. Fortunately I still have a long one. No change. I even tried updating via two different router login paths: and the address. Still nothing. It seems like I'm stuck and will need a new router when this firmware gets too old. Honestly, I've never been happy with the fact that the USB storage add-on ability doesn't work well anyway. 

Model: R8000P|Nighthawk X6S AC4000 Tri Band WiFi Router
Message 3 of 4

Re: R8000P - Firmware won't upgrade

Did you try the TFTP method (requires enabling of TFTP client in Windows 10)?


Also supposedly works for



  • Failed firmware update
  • Device bricked after performing a FW update



It sound a bit fiddly to time it just right


  • Turn router OFF for 10 seconds and then turn it back ON.
  • Watch the Power LED. It will start with an orange color and then start flashing.
  • Press PUT button on the Tftpd64 utility to perform the firmware upload.

This should bypass the web interface and FTP direct to the router software.


However, in my case I was never able to get it to work.



Model: R8000P|Nighthawk X6S AC4000 Tri Band WiFi Router
Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 7 kudos
  • 2 in conversation

Orbi WiFi 6E