× NETGEAR would like to hear from you about specific features so we can improve your experience. To participate in this survey please click HERE.
Reply

Re: Orbi Firmware v2.5.0.38

abonko
Star

Re: Orbi Firmware v2.5.0.38


@FURRYe38 wrote:

I see you didn't mention doing any factory resets after downgrading or updating. Something you might give a try next time you update FW or if you have current version loaded, something to try and compare tests. Normally this isn't needed, however as a last resort, for those seeing differences after FW update should reset and setup from scratch before downgrading FW. 

 

Some of us don't see issues like this, however I for one manually update my systems factory reset and setup from scratch. System works as expected. 

https://community.netgear.com/t5/Orbi/Orbi-Firmware-Update-2-5-0-40/m-p/1825421/highlight/true#M7605...



Ummm, are you just trying to troll me now?  You and I had an entire conversation about my Factory Reset not working.  Look earlier in this same thread.

Message 76 of 82
FURRYe38
Guru

Re: Orbi Firmware v2.5.0.38

Sorry no not trolling. Thead is getting long. Sorry. 

 

Use what works for you, if downgrading is working, go with it. 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router MK83+ (Router Mode) | and RBK853 (Router Mode) | Switches NG GS105/8, GS308v3, GS110MX and XS505M | Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MR6150, R7000, R7800, R7960P, R8000, R8500, R9000, RAXE500, RAX50, XR450, XR700, XR1000, EX7500/EX7700

Message 77 of 82
abonko
Star

Re: Orbi Firmware v2.5.0.38


@FURRYe38 wrote:

Sorry no not trolling. Thead is getting long. Sorry. 

 

Use what works for you, if downgrading is working, go with it. 


LOL!  All good.  Just seemed odd.  🙂

Message 78 of 82
FURRYe38
Guru

Re: Orbi Firmware v2.5.0.38

Orbi can odd or have odd behaviors thats for sure. Smiley Frustrated

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router MK83+ (Router Mode) | and RBK853 (Router Mode) | Switches NG GS105/8, GS308v3, GS110MX and XS505M | Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MR6150, R7000, R7800, R7960P, R8000, R8500, R9000, RAXE500, RAX50, XR450, XR700, XR1000, EX7500/EX7700

Message 79 of 82
jinnyleaf
Guide

Re: Orbi Firmware v2.5.0.38


@abonko wrote:

@jinnyleaf wrote:

@abonko 

 

Have you tried the .40 firmware?

 

I was also having lots of issues with .38 (slowdown especially on iPads), but the .40 hot-fix seems to have resolved many of the issues.

 

I'm tempted to go back to .30,  because I remeber that everything was really good prior to .38

 

Thanks!

 


I looked into it, but the release notes state that the only fix is an SSL certificate issue.  There's no way that would have adressed all the issues I was having, so I didn't both trying it out.


Thanks.

 

I downgraded to .30 and life is good again. 🙂

 

Message 80 of 82
migsta
Apprentice

Re: Orbi Firmware v2.5.0.38

Downgrade or reset to factory defaults is the usual stupidity by which Netgear has us ensurning that their stuff works.  And, 99.9% of the time resetting to factory defaults does nothing.  This thread is also about devices being broken and not some certificate issue.  For me, the devices issue is even present in .30 - so sorry this is not fixed whatsoever.

Model: RBK53|Orbi AC3000 Tri-band WiFi System
Message 81 of 82
FURRYe38
Guru

Re: Orbi Firmware v2.5.0.38

Maybe you can ask others what they did that got theres working:

https://community.netgear.com/t5/Orbi/Orbi-RBR50-2-5-0-38-firmare-bug/m-p/1826207/highlight/true#M76...

 

or contact NG support. 


@migsta wrote:

Downgrade or reset to factory defaults is the usual stupidity by which Netgear has us ensurning that their stuff works.  And, 99.9% of the time resetting to factory defaults does nothing.  This thread is also about devices being broken and not some certificate issue.  For me, the devices issue is even present in .30 - so sorry this is not fixed whatsoever.


 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router MK83+ (Router Mode) | and RBK853 (Router Mode) | Switches NG GS105/8, GS308v3, GS110MX and XS505M | Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MR6150, R7000, R7800, R7960P, R8000, R8500, R9000, RAXE500, RAX50, XR450, XR700, XR1000, EX7500/EX7700

Message 82 of 82
Top Contributors
Discussion stats
  • 81 replies
  • 8203 views
  • 32 kudos
  • 13 in conversation
Announcements

Orbi WiFi 6E