× NETGEAR would like to hear from you about specific features so we can improve your experience. To participate in this survey please click HERE.
Reply

Orbi RBR-50 internal speed check with modem half the ISP speed

Tbreneau
Aspirant

Orbi RBR-50 internal speed check with modem half the ISP speed

I have a 1Gig service from Xfinity and at their modem I verified speed of 999, however when checking speed of same connection between my Orbi Router and the Xfinity modem via o Netgear internal Orbi Router app Speedtest I only get 400-430 Mbs speed no matter the configuration. What is going on with the netgear device’s speed check? Due to the internal QOS doors check it also trottle’s back my wireless to about 380 Mbs. I am very frustrated, I have checked for this problem on Netgear sites and cannot find where it has been solved. I am running an Orbi router with 2 Satellites. Just so I din’t Get patented routine responses to this issue:
1. Yes rebooted
2. Yes restored to factor settings
3. Yes checked setting 20/40. Daisy chain, channels etc, not taking to wireless speed issue but the speed between router to modem.
4. Yes ISP provider called came out verified speeds at modem and I even had them change out the modem
5. Yes set modem to bridge tested
6. Yes set and tested with wireless turned off and DMZ set no change
7. Yes checked every conceivable setting no change
So bottleneck is definitely the Orbi RBR50 Tri-band router. Does Netgear have a workaround, patch, or fix to resolve this problem? I am ready to through the orbi out the window.
Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 1 of 44
FURRYe38
Guru

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

What Firmware is currently loaded?
What is the Mfr and model# of the ISP modem the NG router is connected too?

 

Can you try AP mode with the Orbi connected to your ISP modem if it has a built in router? 

 

FYI:

https://community.netgear.com/t5/Orbi/Orbi-RBR50-is-not-supporting-900Mb-on-the-WAN-to-LAN-test/m-p/...

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router MK83+ (Router Mode) | and RBK853 (Router Mode) | Switches NG GS105/8, GS308v3, GS110MX and XS505M | Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MR6150, R7000, R7800, R7960P, R8000, R8500, R9000, RAXE500, RAX50, XR450, XR700, XR1000, EX7500/EX7700

Message 2 of 44
Tbreneau
Aspirant

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

As Stated in original post I did and in bridge AP mode as well no effect as well in DMZ with wireless turned off. Still the same low link speed between the Otni RBR50 router and the Xfinity CGM4149COM cable modem. Again if I direct connect a pc to the modem I get full speed, when I plug orbi into same port the router to modem the orbi internal speed test shows less than half the speed being supplied. Latest Firmware update 2.3.1.60.
Message 3 of 44
Tbreneau
Aspirant

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

Typo “Orbi RBR50” router. My iPhone voice to text translation not perfect.
Message 4 of 44
FURRYe38
Guru

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

While the modem is in bridged mode, factory reset the RBR and it up from scratch. Be sure to not enabled the QoS speedtest, traffic meter or access controls. With a wired PC, test the speed. 

 

My testing with v60 on RBR50 is not seeing much over 300Mbps and think there is a problem with the WAN to LAN speeds. 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router MK83+ (Router Mode) | and RBK853 (Router Mode) | Switches NG GS105/8, GS308v3, GS110MX and XS505M | Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MR6150, R7000, R7800, R7960P, R8000, R8500, R9000, RAXE500, RAX50, XR450, XR700, XR1000, EX7500/EX7700

Message 5 of 44
Tbreneau
Aspirant

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

Same here there is a problem
Message 6 of 44
FURRYe38
Guru

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

Please file a support ticket here.

https://www.netgear.com/mynetgear/registration/login.aspx

Can reference this forum thread please. 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router MK83+ (Router Mode) | and RBK853 (Router Mode) | Switches NG GS105/8, GS308v3, GS110MX and XS505M | Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MR6150, R7000, R7800, R7960P, R8000, R8500, R9000, RAXE500, RAX50, XR450, XR700, XR1000, EX7500/EX7700

Message 7 of 44
tuna_ertemalp
Luminary

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

Just as an added voice to the thread: I am on 1G/40M service from Xfinity, too, with an RBR50v2, running 2.3.1.60, initially set up having been connected for the first time to the cable modem AFTER that NEW Docsis 3.1 Xfinity modem was un-shrinkwrapped and set to bridge mode with all radios/SSIDs turned off by the Xfinity folk. And, the internal Speedtest of the router is consistently at about 510/40.

 

Now, here is the kicker: The wired LAN output from that RBR50v2 goes into a gig switch, which goes into another gig switch, and that goes into my PC running Win10. And, using the Speedtest Windows app (not the website), against Comcast or Speedtest servers around Seattle. When running against Speedtest server, I get 900/50. When running against Comcast server, I get 480/40. Wut?


So, I would be very interested in hearing what the OP hears from NG. I am wondering if these results depend on the test server, or if there is a math error in the way the router's numbers are dislayed. Consistently "half" the max speed seems a bit too... ...coincidental.

 

Tuna

 

Message 8 of 44
tuna_ertemalp
Luminary

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

And, using the latest 2.3.5.30 firmware, I am still getting a reported 515/42 on my 1000/40 service fro Xfinity, per the internal Speedtest.

Message 9 of 44
FURRYe38
Guru

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

https://community.netgear.com/t5/Orbi/Orbi-RBR50-is-not-supporting-900Mb-on-the-WAN-to-LAN-test/m-p/...


@tuna_ertemalp wrote:

And, using the latest 2.3.5.30 firmware, I am still getting a reported 515/42 on my 1000/40 service fro Xfinity, per the internal Speedtest.


 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router MK83+ (Router Mode) | and RBK853 (Router Mode) | Switches NG GS105/8, GS308v3, GS110MX and XS505M | Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MR6150, R7000, R7800, R7960P, R8000, R8500, R9000, RAXE500, RAX50, XR450, XR700, XR1000, EX7500/EX7700

Message 10 of 44
jdmoto
Aspirant

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

I just updated to the latest firmware 2.3.5.30. I was on the same boat as everyone here when i upgraded to xfinity 1gb (Feb 2019).  What i realized is that some of the speedtest servers cant handle a 1gb upload direct. Which is why xfinity ask to hit thier speedtest.xfinity site because they can deliver the 1gb speed.  I currently just tested the speed with the new firmware and it seems to be much faster and more consistant too. (screen shots below might have right click to open)

 

My setup: PC >wired connection to a 5 port swtich > RBK50 router > NG CM1100 modem. 

I can pull 1gb down and about 37 up using chrome web browser. 

 

fast.com

speedtest xfinity

speedtest comcast

 

I currently have my satellies in a wireless backhaul (I just feel bad wasting the 3rd band). I max 400-500 down on any of the 3 units (direct line of sight). Location of my satellies are in seperate rooms opposite of each other (2nd floor) and my router is next to my staircase (1st floor) stronger connection. 

 

 

As for settings on the orbi, nothing crazy i did have to do a full reset when i upgraded to 1gb speed. No QOS, traffic meter, speed test on the router app. As for the wifi setting, i have beamforming, mu-mimo, daisy-chain enabled. 

 

 

 

 

 

Message 11 of 44
FURRYe38
Guru

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

When you testing speeds are you testing with a wired PC connected directly to the RBR? 

Sounds like your experiencing what I'm finding on Orbi:

https://community.netgear.com/t5/Orbi/Orbi-RBR50-is-not-supporting-900Mb-on-the-WAN-to-LAN-test/m-p/...

 

@Blanca_O 


@jdmoto wrote:

I just updated to the latest firmware 2.3.5.30. I was on the same boat as everyone here when i upgraded to xfinity 1gb (Feb 2019).  What i realized is that some of the speedtest servers cant handle a 1gb upload direct. Which is why xfinity ask to hit thier speedtest.xfinity site because they can deliver the 1gb speed.  I currently just tested the speed with the new firmware and it seems to be much faster and more consistant too. (screen shots below might have right click to open)

 

My setup: PC >wired connection to a 5 port swtich > RBK50 router > NG CM1100 modem. 

I can pull 1gb down and about 37 up using chrome web browser. 

 

fast.com

speedtest xfinity

speedtest comcast

 

I currently have my satellies in a wireless backhaul (I just feel bad wasting the 3rd band). I max 400-500 down on any of the 3 units (direct line of sight). Location of my satellies are in seperate rooms opposite of each other (2nd floor) and my router is next to my staircase (1st floor) stronger connection. 

 

 

As for settings on the orbi, nothing crazy i did have to do a full reset when i upgraded to 1gb speed. No QOS, traffic meter, speed test on the router app. As for the wifi setting, i have beamforming, mu-mimo, daisy-chain enabled. 

 

 

 

 

 


 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router MK83+ (Router Mode) | and RBK853 (Router Mode) | Switches NG GS105/8, GS308v3, GS110MX and XS505M | Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MR6150, R7000, R7800, R7960P, R8000, R8500, R9000, RAXE500, RAX50, XR450, XR700, XR1000, EX7500/EX7700

Message 12 of 44
jdmoto
Aspirant

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

Im wired PC > 1gb switch > RBR > CM1100 Modem. So essentially, I am wired to the RBR when I do speed test. This setup I can hit 1gb limit. 

 

The wifi protocol from that ive read will only maxs out at 500 down/up so that will not give me the max throughput during testing.

 

 

Message 13 of 44
FURRYe38
Guru

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

What is the Mfr and model# of the ethernet switch if one is in the configuration.

 

Yes wireless speeds max out well under 900Mbps. 

 

Any chance you could do the following to collect debug logs?

Steps to capture logs: 
1. Go the debug page http://orbilogin.com/debug.htm
2. Check “Enable LAN/WAN Packet Capture"
3. Click “START CAPTURE”
5. Perform speedtest. 
6. Go to the debug page again and save the debug log. 

*** Please provide the debug logs and the test result. 


@jdmoto wrote:

Im wired PC > 1gb switch > RBR > CM1100 Modem. So essentially, I am wired to the RBR when I do speed test. This setup I can hit 1gb limit. 

 

The wifi protocol from that ive read will only maxs out at 500 down/up so that will not give me the max throughput during testing.

 

 


 

 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router MK83+ (Router Mode) | and RBK853 (Router Mode) | Switches NG GS105/8, GS308v3, GS110MX and XS505M | Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MR6150, R7000, R7800, R7960P, R8000, R8500, R9000, RAXE500, RAX50, XR450, XR700, XR1000, EX7500/EX7700

Message 14 of 44
jdmoto
Aspirant

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

Its a D-Link 5-port Unmanged gigabit swtich (GO-SW-5G). 

 

I'll try the debug when i get home today. Can i visit any speedtest site or is it the Netgear speedtest? 

Message 15 of 44
FURRYe38
Guru

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

Go with ISP first, then speedtest.net. Also remove the switch and direct connect to the RBR with a PC, if possible. 

 

Thank you for your time.

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router MK83+ (Router Mode) | and RBK853 (Router Mode) | Switches NG GS105/8, GS308v3, GS110MX and XS505M | Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MR6150, R7000, R7800, R7960P, R8000, R8500, R9000, RAXE500, RAX50, XR450, XR700, XR1000, EX7500/EX7700

Message 16 of 44
Siege7817
Tutor

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

I have the same issue with my RBR40 and have tried everything.  If I plug a laptop directly into the ports on my Orbi router and test it I get full speed, I think the speedtest app built in to the Orbi is bugged.  My new RAX120 displays speeds correctly with the built in app so maybe they can put that version into the next firmware for the Orbi.

Message 17 of 44
FURRYe38
Guru

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

What Firmware is currently loaded?
What is the Mfr and model# of the ISP modem the NG router is connected too?

 

What browser or app are you using on the wired PC? 

So your getting 900Mbps with a wired PC connected to your RBR40? 

 


@Siege7817 wrote:

I have the same issue with my RBR40 and have tried everything.  If I plug a laptop directly into the ports on my Orbi router and test it I get full speed, I think the speedtest app built in to the Orbi is bugged.  My new RAX120 displays speeds correctly with the built in app so maybe they can put that version into the next firmware for the Orbi.


 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router MK83+ (Router Mode) | and RBK853 (Router Mode) | Switches NG GS105/8, GS308v3, GS110MX and XS505M | Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MR6150, R7000, R7800, R7960P, R8000, R8500, R9000, RAXE500, RAX50, XR450, XR700, XR1000, EX7500/EX7700

Message 18 of 44
tuna_ertemalp
Luminary

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

I'll point to my post above: https://community.netgear.com/t5/Orbi/Orbi-RBR-50-internal-speed-check-with-modem-half-the-ISP-speed...

 

In short, with everything running the latest firmware:

 

  • Incoming Xfinity Service: 1000/40
  • Speedtest internal on RBR50v2: roughly 500/40
  • Speedtest on PC wired to RBR50v2, against Comcast server: roughly 500/40
  • Speedtest on PC wired to RBR50v2, against Speedtest server: roughly 900/40

So, I am guessing, either the Speedtest internal on the router has a bug in detecting or reporting, or is hardwired to run the test against the ISP server.

 

Tuna

Message 19 of 44
FURRYe38
Guru

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

Any chance you could do the following to collect debug logs?

Steps to capture logs: 
1. Go the debug page http://orbilogin.com/debug.htm
2. Check “Enable LAN/WAN Packet Capture"
3. Click “START CAPTURE”
5. Perform speedtest. 
6. Go to the debug page again and save the debug log. 

*** Please provide the debug logs and the test result. 


@tuna_ertemalp wrote:

I'll point to my post above: https://community.netgear.com/t5/Orbi/Orbi-RBR-50-internal-speed-check-with-modem-half-the-ISP-speed...

 

In short, with everything running the latest firmware:

 

  • Incoming Xfinity Service: 1000/40
  • Speedtest internal on RBR50v2: roughly 500/40
  • Speedtest on PC wired to RBR50v2, against Comcast server: roughly 500/40
  • Speedtest on PC wired to RBR50v2, against Speedtest server: roughly 900/40

So, I am guessing, either the Speedtest internal on the router has a bug in detecting or reporting, or is hardwired to run the test against the ISP server.

 

Tuna


 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router MK83+ (Router Mode) | and RBK853 (Router Mode) | Switches NG GS105/8, GS308v3, GS110MX and XS505M | Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MR6150, R7000, R7800, R7960P, R8000, R8500, R9000, RAXE500, RAX50, XR450, XR700, XR1000, EX7500/EX7700

Message 20 of 44
jdmoto
Aspirant

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

Which file do i read in the zip file to see the debug speed? 

Message 21 of 44
tuna_ertemalp
Luminary

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

My result right now (at this moment it fluctuated between 400Mbps and 520Mbps):

DOWNLOAD 409.13Mbps

UPLOAD 42.46Mbps

 

The debug log ZIP is about 11MB and I am not sure I want to publicly post everything that happened on my router during that the time of the test that had nothing to do with the test. The "ookla_speedtest_result" file in the TMP folder might be the one @FURRYe38 asked about. I tried attaching mine as a TXT file at about 133KB. But TXT is not a valid attachment format. So, I have instead printed it to a PDF and attached that 211KB file. Hopefully it'll make it to the Netgear servers...

 

Tuna

 

Message 22 of 44
FURRYe38
Guru

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

Please send a PM to @Blanca_O and send her your ENTIRE debug-log.zip file. Let us know when she gets it. 


@tuna_ertemalp wrote:

My result right now (at this moment it fluctuated between 400Mbps and 520Mbps):

DOWNLOAD 409.13Mbps

UPLOAD 42.46Mbps

 

The debug log ZIP is about 11MB and I am not sure I want to publicly post everything that happened on my router during that the time of the test that had nothing to do with the test. The "ookla_speedtest_result" file in the TMP folder might be the one @FURRYe38 asked about. I tried attaching mine as a TXT file at about 133KB. But TXT is not a valid attachment format. So, I have instead printed it to a PDF and attached that 211KB file. Hopefully it'll make it to the Netgear servers...

 

Tuna

 


 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router MK83+ (Router Mode) | and RBK853 (Router Mode) | Switches NG GS105/8, GS308v3, GS110MX and XS505M | Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MR6150, R7000, R7800, R7960P, R8000, R8500, R9000, RAXE500, RAX50, XR450, XR700, XR1000, EX7500/EX7700

Message 23 of 44
Siege7817
Tutor

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

I have the latest firmware and my modem is Actiontec T3200M.  If I use wired from my laptop directly into either my modem or the Orbi router I get full speed which is 940down/940up.  If I use the in app speedtest I only get about 540down/940 up, I have tried every firmware I have had access to and nothing has changed, I think the in app speedtest is borked because as I said my RAX120 in app speedtest works fine.  As well, I have used multiple different browsers and the actual Windows speedtest app as well as fast.com on all available browsers, so that reinforces my theory that the Orbi app speedtest is bugged.

Message 24 of 44
FURRYe38
Guru

Re: Orbi RBR-50 internal speed check with modem half the ISP speed

So after doing a factory reset on the RBR and setup from scratch, then don't use the speedtest app on the RBR, you do get 900Mbps on a wired PC with a speed test app or speedtest thru a web browser? 

 

I see you have a RBR40 and not a RBR50. Interesting to see that the 40 series seems to be working while the 50 series is not. 


My testing is done with out using the speedtest app on the RBR50. 

 

 

 


@Siege7817 wrote:

I have the latest firmware and my modem is Actiontec T3200M.  If I use wired from my laptop directly into either my modem or the Orbi router I get full speed which is 940down/940up.  If I use the in app speedtest I only get about 540down/940 up, I have tried every firmware I have had access to and nothing has changed, I think the in app speedtest is borked because as I said my RAX120 in app speedtest works fine.


 

My Setup ISP SparkLight | Internet Cable 1000↓/50↑ CAX80 Modem Mode |  Wifi Router MK83+ (Router Mode) | and RBK853 (Router Mode) | Switches NG GS105/8, GS308v3, GS110MX and XS505M | Additional NG HW: C7800/CAX80/CM1100/CM1200/CM2000, Orbi: CBK40, CBK752, RBK50, RBK853, RBK752, RBK953, SXK30 | NightHawk: MK63, MR6150, R7000, R7800, R7960P, R8000, R8500, R9000, RAXE500, RAX50, XR450, XR700, XR1000, EX7500/EX7700

Message 25 of 44
Top Contributors
Discussion stats
  • 43 replies
  • 7758 views
  • 1 kudo
  • 8 in conversation
Announcements

Orbi WiFi 6E