× NETGEAR would like to hear from you about specific features so we can improve your experience. To participate in this survey please click HERE.

Orbi RBR50 - connection and won't recognize passwords


Orbi RBR50 - connection and won't recognize passwords

I have an Orbi RBR50 and satellite that I bought in April of this year. The set-up was easy and everything went fine. I moved and set the router up first and it was fine until yesterday when I went to add the satellite. The router would not recognize the satellite, so I rebooted the router and now it won't connect to the internet (even though its still connected by ethernet cord) and when I try to log on to the router it doesn't recognize the UN or PW I set up. I then tried the original UN and PW and they didnt work, so I tried a hard reset and rebooted and same thing happened. I then tried to reset the PW on the router and ti didn't recognize the challenge questions I set up (why not?) I'm connected to the same Netgear CM700 modem that I have used since I bought the orbi and none of the cables or settings were changed when I tried to add the satellite. Any ideas or thoughts? I don't think I can return this to Amazon this far out, but I'm not sure if this is something that can be fixed or I'm stuck going and getting something else? This is just bizarre. TIA!!!

Message 1 of 2
Sr. NETGEAR Moderator

Re: Orbi RBR50 - connection and won't recognize passwords

Hello FIrepups

You may need to factory reset the unit by holding the reset button for 10+ seconds then you should be able to use the default login admin/password.



Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 1 kudo
  • 2 in conversation

Orbi WiFi 6E