× NETGEAR would like to hear from you about specific features so we can improve your experience. To participate in this survey please click HERE.
Reply

Orbi - iPhone 7 Plus can't connect

IFlyNavy
Aspirant

Orbi - iPhone 7 Plus can't connect

I can't for the life of me get my iPhone 7 Plus to connect.  I intially was getting "incorrect password".  I changed the SSID, and then it accepted the password but would never connect.  Other devices, i.e. Surface Pro 4 connects just fine, albeit seems a bit slow but it connects.

 

I tried resetting my iphone's network settings and that is what caused it to change from "incorrect password" to just a few attempts at connecting but never does.

 

Does anyone else have this issue with IOS devices, or iPhones?

 

I can't even evalutate it because it's so horrific.

Model: Orbi High-Performance AC3000 Tri-Band WiFi System (RBK50)
Message 1 of 4

Accepted Solutions
IFlyNavy
Aspirant

Re: Orbi - iPhone 7 Plus can't connect

I'm an idiot and just figured it out. My current network is a Meraki Network. I had AirMarshall enabled. That was killing any connections to rogue APs, in this case the Orbi. I whitelisted it and I'm good to go. Can't believe I forgot about that security measure. Good news, it works. 😀

View solution in original post

Message 4 of 4

All Replies
TheEther
Guru

Re: Orbi - iPhone 7 Plus can't connect

Do you have any funky characters in your SSID or password?  While technically any printable ASCII character is permitted, it's possible that the Orbi may not accept all of them.  Start with something simple to get things working, like an 8 character alphanumeric password.  If that works, experiment with more complex.

Message 2 of 4
NandoFL
Star

Re: Orbi - iPhone 7 Plus can't connect

Hello. I have an iPhone 7 Plus.  I have no problem at all connecting to Orbi.

Message 3 of 4
IFlyNavy
Aspirant

Re: Orbi - iPhone 7 Plus can't connect

I'm an idiot and just figured it out. My current network is a Meraki Network. I had AirMarshall enabled. That was killing any connections to rogue APs, in this case the Orbi. I whitelisted it and I'm good to go. Can't believe I forgot about that security measure. Good news, it works. 😀
Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 4017 views
  • 0 kudos
  • 3 in conversation
Announcements

Orbi WiFi 6E