Reply

Re: RBR850 frequently issuing DNS REFUSED responses

Mstrbig
Master

Re: RBR850 frequently issuing DNS REFUSED responses


@wwxxyyzz wrote:

I'm also seeing this on a RBK752/RBR750. Wired connection to PC and wireless to other devices. Webpass is my ISP. IPv6 disabled on the router. Latest firmware. Factory reset of the router. Still fails. All of my devices fail to make connections on a daily basis.

How is this not fixed after several months?


I believe this is an IPv6 issue, since most ISPs do not support IPv6 yet. The fix is as follows:

login to orbilogin.com / Advanced / Advanced / IPv6. I setup the following:

I chose 6to4 Tunnel on top right pull down,  Remote 6to4 relay Router set to "Auto", IPv6 Domain Name Server (DNS) Address set to "Use These DNS Servers". I chose Google's public IPv6 DNS Servers (2001:4860:4860::8888 and 2001:4860:4860::8844, you can choose other public IPv6 DNS servers). IP Address Assignment set to "Auto". Tested using test-ipv6.com

As soon as I correctly setup IPv6, and passed the tests, I no longer see any DNS issues.

 

If you choose not to do this setup, and want to keep IPv6 disabled in your Orbi, you can go into your PC or laptop network settings and enter public IPv6 DNS servers. This also stops the errors on each individual PC or laptop. 

Orbi RBK53 System/RBR50/RBS50/RBS50. + Orbi Voice RBS40V
RBK753 system/RBR750/RBS750/RBS750 + RBK853 System/RBR850/RBS850/RBS850
SXK80 — Orbi Pro AX6000 WiFi 6 Tri-Band WiFi System
There's always a logical answer, if you have all the facts!
Message 51 of 106
FURRYe38
Guru

Re: RBR850 frequently issuing DNS REFUSED responses

https://community.netgear.com/t5/Orbi-AX/Intermittent-DNS-Errors-and-WiFi-Issues/m-p/2018127/highlig...


@wwxxyyzz wrote:

I'm also seeing this on a RBK752/RBR750. Wired connection to PC and wireless to other devices. Webpass is my ISP. IPv6 disabled on the router. Latest firmware. Factory reset of the router. Still fails. All of my devices fail to make connections on a daily basis.

How is this not fixed after several months?


 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 52 of 106
Capt_Hellcat
Initiate

Re: RBR850 frequently issuing DNS REFUSED responses

i fixed this by returning it to best buy and going with the asus zenWiFi AX. not only was it cheaper but it doesnt have this DNS issue. i was having way too many of these DNS hiccups across many devices. 

Message 53 of 106
FURRYe38
Guru

Re: RBR850 frequently issuing DNS REFUSED responses

Let us know if MstrBigs suggestion helps. 

 


@wwxxyyzz wrote:

I'm also seeing this on a RBK752/RBR750. Wired connection to PC and wireless to other devices. Webpass is my ISP. IPv6 disabled on the router. Latest firmware. Factory reset of the router. Still fails. All of my devices fail to make connections on a daily basis.

How is this not fixed after several months?


 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 54 of 106
pinchweasel
Initiate

Re: RBR850 frequently issuing DNS REFUSED responses

Yeah, I'm fixing mine by returning to Costco as soon as the new Unifi 6 APs I ordered arrive.

Message 55 of 106
amenic
Apprentice

Re: RBR850 frequently issuing DNS REFUSED responses


@pinchweasel wrote:

Yeah, I'm fixing mine by returning to Costco as soon as the new Unifi 6 APs I ordered arrive.


I wish I ordered from Costco so I had that option I ordered from Bestbuy.    Really disappointed in Netgear and I haven't recommended this Product to anyone who has asked me.   What exactly did I pay a premimum for?  Never again.

Message 56 of 106
FURRYe38
Guru

Re: RBR850 frequently issuing DNS REFUSED responses

Good Luck then. 

 

Mines working, with out the IPv6 configuration. 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 57 of 106
Mstrbig
Master

Re: RBR850 frequently issuing DNS REFUSED responses


@pinchweasel wrote:

Yeah, I'm fixing mine by returning to Costco as soon as the new Unifi 6 APs I ordered arrive.


We won't use Ubiquiti model in our installs. Coverage and speed are limited. I hope your results differ.

Orbi RBK53 System/RBR50/RBS50/RBS50. + Orbi Voice RBS40V
RBK753 system/RBR750/RBS750/RBS750 + RBK853 System/RBR850/RBS850/RBS850
SXK80 — Orbi Pro AX6000 WiFi 6 Tri-Band WiFi System
There's always a logical answer, if you have all the facts!
Message 58 of 106
rgautier
Apprentice

Re: RBR850 frequently issuing DNS REFUSED responses

How can I telnet into my router? The option is not on my debug.htm screen.
Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 59 of 106
arildj
Apprentice

Re: RBR850 frequently issuing DNS REFUSED responses

Message 60 of 106
rgautier
Apprentice

Re: RBR850 frequently issuing DNS REFUSED responses

python telenetable.py 10.0.0.1 [MACHERE] admin [mypassword]
Sent telnet enable payload to '10.0.0.1:23'
rgautier@kali2020:~$ telnet 10.0.0.1
Trying 10.0.0.1...
telnet: Unable to connect to remote host: Connection refused

 

Any advice - sorely welcom

Message 61 of 106
FURRYe38
Guru

Re: RBR850 frequently issuing DNS REFUSED responses

https://community.netgear.com/t5/Orbi-AX/How-to-enable-telnet-on-RBK752/td-p/1985543/jump-to/first-u...

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 62 of 106
rgautier
Apprentice

Re: RBR850 frequently issuing DNS REFUSED responses

The link you provided appears to link to others identifying the same problem, and that thread is both shorter and less helpful than this one, as well as doesn't provide any suggestions or solutions.  It provided only false hope, to be dashed after spending time going to read the thread.

 

Does anyone have any good or helpful suggestions, rather?  This thread appears to be the solution to my (and many other's problems).  However, without the ability to telnet or ssh into the router, the solution cannot be applied.

Message 63 of 106
FURRYe38
Guru

Re: RBR850 frequently issuing DNS REFUSED responses

The solution is there for using telnet enabler for prior versions of FW, however it no longer working with v12 FW. I confirmed this last nite on my system. 

 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 64 of 106
arildj
Apprentice

Re: RBR850 frequently issuing DNS REFUSED responses

I enabled telnet many releases ago, so maybe this possiblilty is removed. You could try different versions (windows,linux) from this thread https://oldwiki.archive.openwrt.org/toh/netgear/telnet.console

Message 65 of 106
FURRYe38
Guru

Re: RBR850 frequently issuing DNS REFUSED responses

I believe v16 worked...

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 66 of 106
GWild
Tutor

Re: RBR850 frequently issuing DNS REFUSED responses

Orbi kit CBK752 (CBR750 and RBS750) is showing the same issue - missing/dropped/lost DNS requests.  I have not ferreted out the low level side, and setting DNS manually in adapter IP4 table seems to resolve it, for now. But I do wonder about other clients like all the android devices running around the home.

 

Seriously: IP protocol stacks have been around for a very long time: this should be no brainer code work and testing for a semi-competent crew to get right the first try.

CBK40 = CBR40 & RBS20
Message 67 of 106
rgautier
Apprentice

Re: RBR850 frequently issuing DNS REFUSED responses

There's a thread on here that explains exactly what the problem is...dnsmasq is trying to monitor for changes to the resolver configuration, rather than the changes to the resolver merely restarting dnsmasq.  Since the filesystem is slow/busy, this constant polling can hang.  The busier the router (more devices, more reliant on IPv4), the worse it gets.  Using -n for running dnsmasq would fix it (and telling the WebGUI to restart dnsmasq when changing resolvers to account for it).

 

dnsmasq on the Orbi is SLOWER to resolve addresses than remote resolvers out on the Internet, which it shouldn't be since latency is so minimal.  The DNS resolver on your cable modem/router is usually super fast (AND MAY EVEN CACHE!!!!).  But dnsmasq isn't caching, hangs when it can't monitor the resolver file, and refuses to look up IP addresses (causing applications to hang, since DNS lookups are a BLOCKING network call!)

 

Now, the solution is EASY, IF you can get into the telnet mode.  And there's two solutions..one, set DNS to something else in the DHCP OPTIONS passed to your devices...best bet, a pi-hole, or just your cable modem itself or a DNS service on the Internet.  The other, is to tell dnsmasq to stop polling (-n flag), which should make it faster (although bind w/cache would still be a much better option).

Message 68 of 106
rgautier
Apprentice

Re: RBR850 frequently issuing DNS REFUSED responses

From the debug run:

dnsmasq -h -n -c 0 -N -i br* -r /tmp/resolv.conf -u root

 

Problems with this:

So, it looks like they're specifying BOTH the -r and -n flags, but this is NOT permitted.  Since -r comes after -n, it's possibly overriding the -n selection, since -r is ONLY ALLOWED WHEN POLLING (see below).

-c is given a parameter of 0 ??

-u (It runs as root...so any RCE in dnsmasq is going to give full access to the device) -u is usually used to DOWNGRADE permission.

 

From the dnsmasq man page:

-h, --no-hosts Don't read the hostnames in /etc/hosts.

-n, --no-poll Don't poll /etc/resolv.conf for changes.

-c --clear-on-reload Whenever /etc/resolv.conf is re-read or the upstream servers are set via DBus, clear the DNS cache. This is useful when new nameservers may have different data than that held in cache.

-N, --no-negcache Disable negative caching. Negative caching allows dnsmasq to remember "no such domain" answers from upstream nameservers and answer identical queries without forwarding them again.

-i, --interface=<interface name>

-r, --resolv-file=<file>Read the IP addresses of the upstream nameservers from <file>, instead of /etc/resolv.conf. For the format of this file see resolv.conf(5). The only lines relevant to dnsmasq are nameserver ones. Dnsmasq can be told to poll more than one resolv.conf file, the first file name specified overrides the default, subsequent ones add to the list. This is only allowed when polling; the file with the currently latest modification time is the one used.

-u, --user=<username> Specify the userid to which dnsmasq will change after startup. Dnsmasq must normally be started as root, but it will drop root privileges after startup by changing id to another user. Normally this user is "nobody" but that can be over-ridden with this switch.

 

Rich

Message 69 of 106
pv_omaha
Initiate

Re: RBR850 frequently issuing DNS REFUSED responses

I have the RBR850 setup and have been dealing with support for a few days now.

My firware is now current at V3.2.17.12_1.4.14

 

Their solution options which took my 4 people to talk to today to get are:

1. RMA for a refurbished replacement which will not reset the support clock.  It will still go off of original purchase date.

2. If the reatiler you purchased from with exchange it, do that.

 

I really wish I was making this up.  I just update my case with a number of community forum links that all state the same issue.

 

Is anyone haing the issue on my firmware still.  I haven't seen it today, but that doesn't mean its fixed.

Message 70 of 106
FURRYe38
Guru

Re: RBR850 frequently issuing DNS REFUSED responses

You can try this:

https://community.netgear.com/t5/Orbi-AX/Intermittent-DNS-Errors-and-WiFi-Issues/m-p/2079188/highlig...

 

Been using it and though I have seen a couple of DNS errors here and there, not frequent and seems to help some with this issue. I had not seen this until the time change this past month. Some of this maybe time related as well. 

 

So try it and let us know. 


@pv_omaha wrote:

I have the RBR850 setup and have been dealing with support for a few days now.

My firware is now current at V3.2.17.12_1.4.14

 

Their solution options which took my 4 people to talk to today to get are:

1. RMA for a refurbished replacement which will not reset the support clock.  It will still go off of original purchase date.

2. If the reatiler you purchased from with exchange it, do that.

 

I really wish I was making this up.  I just update my case with a number of community forum links that all state the same issue.

 

Is anyone haing the issue on my firmware still.  I haven't seen it today, but that doesn't mean its fixed.


 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 71 of 106
KasemO
Star

Re: RBR850 frequently issuing DNS REFUSED responses

It's not IPV6. It's DNS.

Message 72 of 106
KasemO
Star

Re: RBR850 frequently issuing DNS REFUSED responses


@pv_omaha wrote:

I have the RBR850 setup and have been dealing with support for a few days now.

My firware is now current at V3.2.17.12_1.4.14

 

Their solution options which took my 4 people to talk to today to get are:

1. RMA for a refurbished replacement which will not reset the support clock.  It will still go off of original purchase date.

2. If the reatiler you purchased from with exchange it, do that.

 

I really wish I was making this up.  I just update my case with a number of community forum links that all state the same issue.

 

Is anyone haing the issue on my firmware still.  I haven't seen it today, but that doesn't mean its fixed.


Issue isn't fixed. You just won your first few coin tosses.

 

What really gets me is this is a $1000 router - when there are ones out there that cost half as much ... and actually work.

Message 73 of 106
bullm00n
Apprentice

Re: RBR850 frequently issuing DNS REFUSED responses

Just curious...

 

If I were getting the DNS errors, how would they manifest?  And the reason I ask is, as pervasive as this topic / thread would make them seem to be, I'd be having these issues.  And maybe I am and just don't realize it.  Are there particular conditions / settings that create the problem?  If I wanted to recreate the problem and recognize it, how would I go about it?

 

I have the RBK852 setup with both the router and client computers using IPv4 and IPv6.  I am using both Armor and the Traffic Metering and the default Netgear NTP.  I have specified the Xfinity DNS as well as my local DNS in the Orbi Internet Setup page for IPv4.  My IPv6 DNS are "Get automatically from ISP" in the IPv6 settings. I have briefly tried disabling IPv6 in the router and a client computer to see what difference that makes - didn't seem to make any difference, but I'm not sure how I would know or how long it would take for issues to occur.  I usually use Chrome and Edge browsers.  We have several computers and dozens of IOT devices connected - 60 or more wired and wireless devices typically.  What else?  I'm East Coast and my ISP is Xfinity, if that's relevant.

 

So, my question: if I want to force this issue and observe it, what settings are required to make it happen and how will I know when I see it?

 

Thanks for indulging me.

bullmoon
Xfinity / CM1150V / RBR850 / RBS850
Message 74 of 106
FURRYe38
Guru

Re: RBR850 frequently issuing DNS REFUSED responses

The few times I finally saw this after the time change last month was something like whats described here:

https://geeksadvice.com/how-to-fix-dns_probe_finished_nxdomain-error/

 

I had a capture of mine but I forgot to save it off or I would have posted it here. Sorry about that. Even with custom DNS and 6to4 DNS enabled, my browser saw a few of these DNS errors. Not all the time though. Even on this forum after changing tabs and refreshing the page. Opera GX saw a few of these and either the browser was cable to auto fresh the page after the error appeared, then quickly went away and the page loaded correctly or it was a hard stop error in which the browser stopped and I have to manually refresh the page and then it loaded correctly. 

 

I believe most of the problems were seen when the RBR was using Auto DNS, and no 6to4 DNS configurations. 

 

I believe others have tried both configurations and it has appeared still throughout. I had not seen this whatsoever last year while using same Auto DNS and no 6to4 DNS. I Then graduated to 6to4 DNS last last year and still saw no DNS errors. Only when the time changed last month did they start to appear for me. I'm Pacific Northwest and Spartlight. CM1200 cable modem.

 

 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 75 of 106
Top Contributors
Discussion stats
Announcements

Orbi WiFi 6E