Reply

Re: RBR850 frequently issuing DNS REFUSED responses

amenic
Apprentice

Re: RBR850 frequently issuing DNS REFUSED responses


@bullm00n wrote:

Just curious...

 

If I were getting the DNS errors, how would they manifest?  And the reason I ask is, as pervasive as this topic / thread would make them seem to be, I'd be having these issues.  And maybe I am and just don't realize it.  Are there particular conditions / settings that create the problem?  If I wanted to recreate the problem and recognize it, how would I go about it?

 

I have the RBK852 setup with both the router and client computers using IPv4 and IPv6.  I am using both Armor and the Traffic Metering and the default Netgear NTP.  I have specified the Xfinity DNS as well as my local DNS in the Orbi Internet Setup page for IPv4.  My IPv6 DNS are "Get automatically from ISP" in the IPv6 settings. I have briefly tried disabling IPv6 in the router and a client computer to see what difference that makes - didn't seem to make any difference, but I'm not sure how I would know or how long it would take for issues to occur.  I usually use Chrome and Edge browsers.  We have several computers and dozens of IOT devices connected - 60 or more wired and wireless devices typically.  What else?  I'm East Coast and my ISP is Xfinity, if that's relevant.

 

So, my question: if I want to force this issue and observe it, what settings are required to make it happen and how will I know when I see it?

 

Thanks for indulging me.


 

1.)  Quick update for me.  Manually updating the firmware, then factory resetting seems to allow a stable upgrade.  The problem is that restoring my backed up settings didn't work.    So, great to know everytime I upgrade this thing I have to reconfigure my entire network...  Did I mention there's no QOS too?    This thing is trash.

 

 

2.)  I couldn't tell you how to reproduce, I'm not doing ANYTHING earth shattering here....   What I can tell you is that it's almost 100% nothing to do with the user config and 100% to do with vendor config of the router.   I'm very confident the issue is on the implementation of dnsmasq on the router itself.  Even if you are using third party or local DNS, you're still hitting the dnsmasq service hardcoded into the router config.   The only way to circumvent it is to override it at a PER CLIENT level on your entire network.....  

 

 

How you'll see the issue is either with computers thinking they are "not connected to the internet" because they fail basic DNS checks intermittently through the Orbi router OR you'll see web request fail then succeed on re-try.

 

If you are overriding DNS lookup on your client devices, you'll never see this problem.

 

The laziest effort NG could put forth to fix this, is to allow the user to disable dnsmasq on the router (other than what they are doing now which is nothing) but they could look at what stupid config option is being invoked to make it fail so easily and fix it that way too.

 

I'd rather have no caching or manage my own than deal with this garbage implementation. 

 

I will also say that running Pi-hole on my network seems to have helped.  It hasnt' fixed the issue entirely but likely because so many types of DNS queries are being dropped, it's making less failures overall through dnsmasq on the Orbi.  Maybe anecdotal evidence that the dnsmasq config limits are set low or something along those lines.

Message 76 of 106
amenic
Apprentice

Re: RBR850 frequently issuing DNS REFUSED responses

Disregard my previous comment about pi-hole now that I think about it, the queries are still going to hit the router first and then pi-hole so it makes no sense that would in any way help with this issue.

Message 77 of 106
rculpepper
Tutor

Re: RBR850 frequently issuing DNS REFUSED responses

Problem still happening for me in V3.2.18.1_1.4.14. Traffic meter turned off, auto DST settings turned off, and to me this appears to be separate from the other issue where dnsmasq completely gives up every so often.

Current setup is pretty simple: CenturyLink gigabit fiber -> RBR850 + 2x RBS850 with a pi-hole box set as the DNS server (problem occurs when using auto dns or other DNS servers, too).

Any chance of NetGear support working with us to track this down and get a real fix in? I get that not everyone is seeing this issue (or noticing it), and that NetGear likely wants to keep dnsmasq set up a particular way for their security product... but there's got to be something they can do to fix this, or at least give owners access to fix this (would love to have ssh/telnet back!).

I'm outside of my refund window and guessing I'll end up having to put together a firewall/router (pfsense or something) and just punt the orbi to AP mode. That's a bummer, since I'd really like to keep things simple.

Message 78 of 106
pv_omaha
Initiate

Re: RBR850 frequently issuing DNS REFUSED responses

Sadly Netgear support could care less.  I have opened two seperate tickets on this issue and just like you was about to be outside of my return window.

 

They gave two options:

(1) return the "defective hardware" to them and have it replaced with a refrubished one.  With zero reguard of the fact you purchased their extremely expensive product and absolutely no guarantee that this would even fix the issue.  Which we all know it would not...

 

(2) retuen it to the retailer and get a different product.  This I thought was hilarious, a company telling you to return their product and buy some other company's product.

 

This is after I sent them numerous links to threads just like this one.  They still deny there ia anything wrong.  They also absolutely do not monitor this forum in anyway, it is just another way to get customers to "self sooth" so they do not have to actually support their products.  Honestly after interacting with their support, not that they could!

Message 79 of 106
rculpepper
Tutor

Re: RBR850 frequently issuing DNS REFUSED responses

Well, ugh. Guess I'm putting pfsense back into the mix!

Message 80 of 106
energie
Luminary

Re: RBR850 frequently issuing DNS REFUSED responses

This issue is well documented. Here is the main thread: 

Issue is with the firmware. There is an issue with DNS resolving that Netgear doesn't fix for the Orbi AX (consumer line). It has been fixed in their business Orbi Pro a year ago. Don't expect Netgear to fix this issue.

 

Only solution is to use the Orbi AX in access point mode with a third party router in front of it. This basically means that the third party router will perform all 'routing' capabilities. While the Orbi AX becomes a dumb node. This is the most economical solution if you cannot return the Orbi AX anymore to the shops. There are no other solutions. The problem is with the firmware (= not a user or configuration issue).

 

Netgear needs to fix the firmware / DNS issue.

Message 81 of 106
FURRYe38
Guru

Re: RBR850 frequently issuing DNS REFUSED responses

@tantrum 

Ok for ALL you 8 series Orbi users, please make contact with @Christian_R 

Ask for access to Firmware v3.2.18.223. Beta is ready and being made available for those who want to try this version. 

"Unknown/Phantom Satellite is showing up in the Orbi App
Netgear logs of Satellite are not collected in GUI debug logs
DNS issues"

 

Once you get the files, update the RBS first then RBR lastly. I would power OFF all units for 30 seconds then back ON. Same with your ISP MODEM/ONT. 

 

If any issues are still seen, you'll need to do a factory reset and clean setup from scratch. 

 

I would encourage for those having DNS issue to give this a try. Seems to be fixed for 7 series users. Smiley Wink

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 82 of 106
kristianreesen
Aspirant

Re: RBR850 frequently issuing DNS REFUSED responses

Could anybody please help me with getting download access to the 

firmware v3.2.18.223

for the rbr850 and rbs850 ? 

Message 83 of 106
FURRYe38
Guru

Re: RBR850 frequently issuing DNS REFUSED responses

 Please make contact with @Christian_R 


@kristianreesen wrote:

Could anybody please help me with getting download access to the 

firmware v3.2.18.223

for the rbr850 and rbs850 ? 


 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 84 of 106
KickassCaptain
Aspirant

Re: RBR850 frequently issuing DNS REFUSED responses

I have the same issue on my AX router RBR 850
Message 85 of 106
FURRYe38
Guru

Re: RBR850 frequently issuing DNS REFUSED responses

 Please make contact with @Christian_R


@KickassCaptain wrote:
I have the same issue on my AX router RBR 850

 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 86 of 106
amenic
Apprentice

Re: RBR850 frequently issuing DNS REFUSED responses

I finally gave up. Sold the unit so it will be someone else's problem as Netgear could obviously care less.

Bought a new Ubiquity mesh router and it's already way better at the same price point.

I'll never buy another NG router....
Message 87 of 106
FURRYe38
Guru

Re: RBR850 frequently issuing DNS REFUSED responses

Good Luck. This issue is resolved by the beta thats available. 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111

View solution in original post

Message 88 of 106
amenic
Apprentice

Re: RBR850 frequently issuing DNS REFUSED responses

I couldn't help but laugh.  One of the first things I notice on the new router (non-Netgear) I notice when browsing options (see screenshot)Screenshot 2021-08-02 152315.png

 

This obviously is a problem for others and just a crazy simple solution.... (just turn it off!)

 

 

Message 89 of 106
FURRYe38
Guru

Re: RBR850 frequently issuing DNS REFUSED responses

Can't see the picture though I presume it's a DNS problem as seen on Orbi AX? 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 90 of 106
amenic
Apprentice

Re: RBR850 frequently issuing DNS REFUSED responses


@FURRYe38 wrote:

Can't see the picture though I presume it's a DNS problem as seen on Orbi AX? 


Nice joke! lol 

 

Not sure why the image didn't load but I'll try again, it's just a screenshot of the setting "Bypass DNS cache (use upstream DNS for DHCP clients)"

 

Screenshot 2021-08-02 152315.png

Message 91 of 106
FURRYe38
Guru

Re: RBR850 frequently issuing DNS REFUSED responses

Try using the Choose File button to attache the screen capture file. We have to wait for inline pictures to be approved. 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 92 of 106
Slara
Aspirant

Re: RBR850 frequently issuing DNS REFUSED responses

I’ve been dealing with this DNS issue for weeks now! It’s so frustrating I am taking online classes. Netgear please fix this issue ASAP. It’s affecting my grades at school.
Message 93 of 106
Slara
Aspirant

Re: RBR850 frequently issuing DNS REFUSED responses

I have to reset my router several times a day in order for the DNS to work. It’s been hell.
Message 94 of 106
FURRYe38
Guru

Re: RBR850 frequently issuing DNS REFUSED responses

This was fixed already. 

 

What Firmware version is currently loaded?
What is the Mfr and model# of the Internet Service Providers modem/ONT the NG router is connected too?

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 95 of 106
Slara
Aspirant

Re: RBR850 frequently issuing DNS REFUSED responses

I have the RBK853. AX6000.
Firmware 4.6.3.16_2.0.51
Message 96 of 106
FURRYe38
Guru

Re: RBR850 frequently issuing DNS REFUSED responses

What is the Mfr and model# of the Internet Service Providers modem/ONT the Orbi router is connected too?

 

Has a power off for 5 minutes then back ON with the ISP modem and Orbi system been performed since last update?


@Slara wrote:
I have the RBK853. AX6000.
Firmware 4.6.3.16_2.0.51

 

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 97 of 106
Slara
Aspirant

Re: RBR850 frequently issuing DNS REFUSED responses

I have new modem that was provided by Charter Spectrum. ES2251. I’m constantly resetting the modem and router to get my WiFi to work. I’m considering returning my Orbi and switching to a different router. I’ve called several times and all they keep telling me is that Netgear is working on firmware update to fix the issue.
Message 98 of 106
FURRYe38
Guru

Re: RBR850 frequently issuing DNS REFUSED responses

How are you resetting the modem and Orbi system? What are you doing for this? 

 

Has a factory reset and setup from scratch been performed since last update? This means pressing the reset button in back of the RBS and RBR for 15 seconds then release. Power OFF the ISP modem for 1 minute then back ON. Then with a wired connected PC to the RBR, walk thru the setup wizard on the RBR at 192.168.1.1 with a web browser.

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.2.1(LAG Disabled)>RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, XR450(v120) and WNHDE111
Message 99 of 106
Slara
Aspirant

Re: RBR850 frequently issuing DNS REFUSED responses

Yes, I have done every possible type of reset you can do on this Orbi router with a technician and I am still having issues with the DNS.
Message 100 of 106
Top Contributors
Discussion stats
Announcements

Orbi WiFi 6E