× NETGEAR is aware of a growing number of phone and online scams. To learn how to stay safe click here.
Orbi WiFi 7 RBE973
Reply

Disabling automatic subnet reconfig

djaesthetic
Tutor

Disabling automatic subnet reconfig

I was wondering if there was a way (yet) to disable Orbi’s automatic IP reconfig if it detects a “conflicting” subnet? I understand the spirit of what it’s for, but frankly it’s a bugged feature (yes, see example #2).

1) I began using an AT&T Fiber gateway (BGW320-505) in front of my Orbi. Both devices were configured for the same subnet (192.168.1.0/24), however there were zero IP conflicts or overlapping DHCP scopes.

• Orbi: 192.168.1.1 & DHCP Range .150-.190
• GW: 192.168.1.254 & DHCP Reservation for a single IP (Orbi’s WAN, for IP Passthrough).

...but Orbi kept frequently reconfiguring itself for 10.0.0.0/24. I would receive:

“To avoid conflict with your Internet Service Provider, your router's IP address has been update to 10.0.0.1.”

I assumed perhaps it didn’t like the existence of multiple DHCP servers. Fine. So I reconfigure GW for 172.16.0.0/24. Problem goes away for a bit...

2) Last night I introduced two Netgear GS108Ev3 (managed, layer 2) switches to the network with IPs of 192.168.1.2 & 192.168.1.3. Everything is working properly. The very last thing I do is update their firmware. Click ‘Update Firmware’, it says it’s dropping itself in to loader mode. I perform the firmware update without issue but notice the rest of my network has disappeared. I check Orbi and it has reconfigured itself. Again. I perform the update on the second switch? Same thing happens. There are no DHCP services on these switches. They just exist on the same network. I can at least understand the potential why with the first example (to avoid double NATing and/or routing conflicts), but this...?

At best, I’d really like a way to disable this feature. At worst, I’d like to understand specifically what is tripping the behavior as the L2 switches don’t make any sense.
Model: RBR50|Orbi AC3000 Tri-band WiFi Router
Message 1 of 29

Accepted Solutions
djaesthetic
Tutor

Re: Disabling automatic subnet reconfig

@CrimpOn : Did some final testing and now confident in the conclusion.


What triggers the "reconfiguration" behavior appears to be whenever Orbi detects any other network device on the other side of it's Internet (WAN) port sharing the same subnet. It doesn't matter if there's an actual conflict or not -- simply it's existence. From a consumer support standpoint this is actually a pretty clever mechanism (though I wish they'd give us the option to disable it for various use cases).

 

In my *personal* case - the issue was that I'd put the ports in their respective VLANs (10 for WAN, 20 for LAN) but left VLAN 1 in place. Regular (untagged) traffic was working just fine. My guess is that during a firmware update on those GS108Ev3 switches, it was sending out a broadcast across all configured VLANs, Orbi was seeing that broadcast on the Internet port, hence reconfiguration is triggered. I removed VLAN 1 from all ports and haven't been able to replicate the problem since.

 

As for your question about the use case for the two switches? This as a method to extend out multiple networks over a single cable. My current configuration looks like this:


VLAN 10 = WAN Traffic
VLAN 20 = LAN Traffic

-----

BASEMENT

GS108Ev3 - Port 1: VLAN 10 Tagged, VLAN 20 Tagged

GS108Ev3 - Port 2: VLAN 10 Untagged
GS108Ev3 - Port 3-8: VLAN 20 Untagged

AT&T Gateway LAN plugged in to GS108Ev3 Port 2

 

UPSTAIRS OFFICE

GS108Ev3 - Port 1: VLAN 10 Tagged, VLAN 20 Tagged

GS108Ev3 - Port 2: VLAN 10 Untagged
GS108Ev3 - Port 3-8: VLAN 20 Untagged
Orbi Internet Port plugged in to GS108Ev3 Port 2
-----

Port 1 is the single physical cable running between the two switches. It will pass all traffic for either VLAN (LAN or WAN side) without either seeing one another as the traffic is "encapsulated" (isolated from each other). Port 2 on each side is where you plug in the WAN side of things. In the basement I have several runs from around the house plugged in to ports 3-8 (LAN). In the Office, I also have a bunch of devices plugged in to 3-8 (LAN). Two separate floors but they'll all end up in the LAN side.

 

The notion that someone shouldn't be using managed switches in a network topology is a silly one, assuming the configuration is correct. In my particular case (and the fix to the original problem I posted about) turns out to simply be "don't let Orbi's Internet port see any traffic with a subnet that matches it's LAN side". Simple enough, makes a lot of sense. Once I understood what was triggering the reconfigurating, finding the root cause was simple.

(Extra thanks to @schumaku for the sentence that led to the conclusion -- "Somehow the Orbi system does see any 192.168.x.x network on it's WAN/Internet port.")

View solution in original post

Message 29 of 29

All Replies
FURRYe38
Guru

Re: Disabling automatic subnet reconfig

You need to either change the RBRs IP address string to something different than 192.168.1.1 or try the following:

This would be a double NAT (two router) condition which isn't recommended. https://kb.netgear.com/30186/What-is-Double-NAT
https://kb.netgear.com/30187/How-to-fix-issues-with-Double-NAT
Couple of options,
1. Configure the modem for transparent bridge or modem only mode. Then use the Orbi router in router mode. You'll need to contact the ISP for help and information in regards to the modem being bridged correctly.
2. If you can't bridge the modem, disable ALL wifi radios on the modem, configure the modems DMZ/ExposedHost or IP Pass-Through for the IP address the Orbi router gets from the modem. Then you can use the Orbi router in Router mode.
3. Or disable all wifi radios on the modem and connect the Orbi router to the modem, configure AP mode on the Orbi router. https://kb.netgear.com/31218/How-do-I-configure-my-Orbi-router-to-act-as-an-access-point and https://www.youtube.com/watch?v=H7LOcJ8GdDo&app=desktop

 

Message 2 of 29
djaesthetic
Tutor

Re: Disabling automatic subnet reconfig

@FURRYe38 : While I (genuinely) appreciate the reply, you didn’t actually read the post.

1) I already changed the RBR to sit on a different subnet than the other router (GW is now 172.16.0.0/24. I’m *already* passing back the WAN IP directly to the WAN interface of the Orbi, hence there is no double NAT.

2) All WiFi radios are already disabled on the modem as well.

3) The real mystery here is surrounding the Netgear switches (GS108Ev3), not routers, that cause the same behavior upon initiating a firmware update.
Message 3 of 29
FURRYe38
Guru

Re: Disabling automatic subnet reconfig

What happens if you change the Orbi to 192.168.0.1? 

 

Also your switche are Smart managed switches, something that can cause problems with Orbi systems. Try to disable all IGMP protocols AND Green Ethernet featues on these switches. 

 

NG GS-105/108v4, D-Link DGS-105/108 and HP ProCurve 1400/1800 series switches work for Orbi systems.

Message 4 of 29
djaesthetic
Tutor

Re: Disabling automatic subnet reconfig

@FURRYe38 : Thanks again for the reply.

I've been avoiding changing the subnet of the Orbi itself as I've got lots of devices and automations built internally that are specific to IPs in that range. I figured as long as there aren't any conflicts, it shouldn't matter which device is configured for which subnet.

 

I took a thorough look through the switches and every feature is already disabled (mostly by default) with the exception of "IGMP Snooping Status" for Multicast. I can't think of why IGMP Snooping would cause this behavior on an Orbi Router (wouldn't that simply prevent unwanted multicast traffic?), but I went ahead and disabled the feature anyway. There aren't any 'Green Ethernet' (or 'energy efficient') features I am aware of on this model.

 

Every switch model you listed is an unmanaged switch and would not support the trunking of multiple VLANs over a single link between switches, hence none of them would be viable for my needs.

 

would like to understand what specifically causes this behavior on Orbi, i.e. what type of traffic, protocol, broadcast, etc. is it seeing that causes it to make that decision.

Message 5 of 29
FURRYe38
Guru

Re: Disabling automatic subnet reconfig

"So I reconfigure GW for 172.16.0.0/24. Problem goes away for a bit..." what do you mean for a bit? Is 172 still configured on the GW? 

 

I would remove the switches and the try the Orbi with using 192.168.1.1. 

Any IGMP protocols should be disabled...

 

What FW version are you using? 

Has a factory reset and setup from scratch been performed since last update?

Message 6 of 29
djaesthetic
Tutor

Re: Disabling automatic subnet reconfig

@FURRYe38 : Rephrased. Yes, the ATT GW is still configured for 172.16.0.0/24. After changing the ATT GW to that subnet, I hadn’t experienced the issue again in a few days. Granted, it’s been less than a week and other threads on this topic suggest the potential of this happening at DHCP lease renewal - but for now it’s been a few days *until* I added the switches last night.

A recommendation of “remove the switches” doesn’t solve the problem nor explain specifically what triggers the behavior (such as why this happened when performing a firmware update on the switches, which are layer 2 devices and don’t even have routing capability).

IGMP Snooping was disabled on the switches this morning as per your advice.

As of last night I am running FW 2.7.2.102. I forget which version I was previously on (though the issue persists with the latest).

No, I have not performed a factory reset since performing the firmware update. Why would this be recommended as it pertains to the issue at hand?
Message 7 of 29
FURRYe38
Guru

Re: Disabling automatic subnet reconfig

Sometimes lingering code or misconfigurations of the system after newer FW updates are applied can cause problems. Reset is a necessary and normal step to try to see if anything changes. I have seen many issues with updating FW and problems seen. Resets are a step to check this. 

 

I've had my RBR behind other routers before and haven't seen this issue. Though my main host router uses 192.168.0.1, so leaving the .1.1 default on any other router behind the host router, doesn't produce this issue.

 

Hoping that a reset would be the step that fixes this. Unless someting about 172 used on the GW is somehow causing orbi to use 10.something. I've never used 172. You could try 192.168.0.1 on the GW and see. 

Message 8 of 29
djaesthetic
Tutor

Re: Disabling automatic subnet reconfig

@FURRYe38 : *WHICH* subnet is used should be irrelevant as long as there is no conflict. I also confirmed the issue existed both pre and post FW upgrade, so the upgrade wasn’t the cause.

I keep trying to drag the conversation back to the layer 2 switches as that’s the behavior that makes the least sense. They have zero L3 routing capability. A “conflict” with them is impossible unless one tried configuring their IP for the same as the router. The behavior is repeatable when kicking off a firmware update (on the switches). Their factory default IPs are 192.168.0.239 so even if during their upgrades they somehow momentarily defaulted back to that network, it wouldn’t overlap with any existing network. If I don’t understand the specific mechanism that’s causing the behavior, I can’t confidently prevent it from happening again at an arbitrary time.

(I’m a network architect so if you *do* understand what’s happening under the hood, please don’t hold back in explaining!)
Message 9 of 29
FURRYe38
Guru

Re: Disabling automatic subnet reconfig

Ok. Speaking from a troubleshooting perspective, I would remove the switches completely. 

I would change the IP address of the GW to either 192.168.0.1 or even try a 10.something address ON the GW. 

 

Factory reset the RBR and setup from scratch. Get the system up and running using the default IP address string. WIth out the switches. I would also change the IP address pool size on the RBR as well, I use .100 to .200. This leaves room for some static IP addressed devices on either side of this pool. Will come back to this and switches later. 

 

Check the system out for any continued changes. I'd be curioius to know if the Orbi still doesn't something after this. 

 

 

Message 10 of 29
djaesthetic
Tutor

Re: Disabling automatic subnet reconfig

@FURRYe38 : It’s repeatable that a firmware update on the switches triggers the issue. That already proves they’re one of the causes. I don’t need to remove them to prove what we’ve already established. That doesn’t answer the “why”.

I need the Orbi network to remain 192.168.1.0/24. There are no other layer 3 devices on the network between that and the ATT GW (currently on 172.16.0.0/24).

My DHCP pool is already reduced to .150 - .190 with all static addresses outside of those.
Message 11 of 29
FURRYe38
Guru

Re: Disabling automatic subnet reconfig

I would ask you to start a post thread here and post about this in this switch forum:

https://community.netgear.com/t5/Smart-Plus-and-Smart-Pro-Managed/bd-p/business-smart-plus-click-swi...

 

If this is being triggered by switches, then there maybe something on the switches that needs to be looked at and would not be a Orbi problem. Seems like someting with these managed switchs is causing Orbi to trigger the subnet config incorrectly. The one managed switch I have and use doesn't do this, however it's a D-Link DGS-1100 and it's set for a static IP address of 192.168.0.11 which is out side of the DHCP IP address pool on my router. 

 

Good Luck.

 

 

Message 12 of 29
djaesthetic
Tutor

Re: Disabling automatic subnet reconfig

@FURRYe38 : Not a bad idea! Perhaps someone over there may be familiar with what happens under the hood when a firmware update is initiated.

Irony be damned, I almost bought a pair of DGS-1100 instead but opted for the GS108Ev3 simply because “both were Netgear”.

I *did* want to reiterate the IPs in play:

Orbi: 192.168.1.1
SW1: 192.168.1.2
SW2: 192.168.1.3
Orbi DHCP: 192.168.1.150 - 192.168.1.190
Static Devices: All .200 and above

The *default* IP of the switches out of the box is 192.168.0.239.

There is no overlap anywhere.
Message 13 of 29
FURRYe38
Guru

Re: Disabling automatic subnet reconfig

Ya, seems odd that switches are causing this. Even when out of the box, .0.### shouldn't trigger Orbi to change subnets if Orbi is on 1.1. Like I said, I haven't seen this before so seems like something on the switch side does something that Orbi sees falsely. Seen odd things with Orbi and managed switches. Would be one test to try a non managed switch in place to see if the same thing happens. I presume you shouldn't see this. 

 

Hopefully someone on the switch side can point you in the right direction. 

Message 14 of 29
djaesthetic
Tutor

Re: Disabling automatic subnet reconfig

@FURRYe38 : Wish I could use unmanaged switches. Actually swapped *OUT* a pair in place for these managed ones.

I have a single Cat6 run between two floors of my house. My internet comes in to the basement. About 6 other physical runs terminate in the same location. My router is in my office one floor up. I needed a way to connect all of those physical LAN connections *AND* the internet WAN connection over a single cable. The solution was to put in two managed switches. The single Cat6 run between floors is a trunk passing *ALL* VLANs on Int1. Int2 (on both sides) is the WAN VLAN (where the ATT GW plugs in on one side and the Orbi “Internet” port plugs in on the other). Int3-8 on both sides are dedicated to LAN. It’d work beautifully if it weren’t for this Orbi “feature”.

(...I also have 3 floors to my house, so moving the router on the basement would be too detrimental to Wi-Fi on the top floor, so that’s out...)
Message 15 of 29
FURRYe38
Guru

Re: Disabling automatic subnet reconfig

Mine just about opposite of your house. Two story with basement. ISP modem and router on 2nd floor upstairs. All in electronic closet. Then I have patch panel for CAT6A to wall outlets on 2nd and some on 1st floor. I have 1 non mananged switch segment connected to the back of the RBR, NG GS-108 that connects my DISH Hopper system, ATT microcell in the living room and 1 line that goes down to the living room on 1st floor where 1 non managed switch and microcell is, then this continued line that goes to the back far office room down the hallway where the original office and networking was a few years back. Here there is a wall jack we put in the runs from this room down to the basement area where a tennant lives and 1 non managed switch and last RBS is connected on this line. The living room and basement switches use NG GS-105s. Basement has two xbox consoles, power switch and a PC. All this works with no VLANs or managed switches. 

Message 16 of 29
djaesthetic
Tutor

Re: Disabling automatic subnet reconfig

@FURRYe38 : “ All this works with no VLANs or managed switches.”

...well, YEAH. Only a bunch of other hardware and cable runs instead. Heh That’s exactly what I’m avoiding here. I manage enterprise networks for a living. A couple of managed switches to pass a pair of VLANs should not be problematic in the slightest. This is basic Networking 102 stuff...
Message 17 of 29
FURRYe38
Guru

Re: Disabling automatic subnet reconfig

Hopefully you can figure out whats going on with the switches. Possible just a configuration issue. 

 

Good Luck. 

Message 18 of 29
CrimpOn
Guru

Re: Disabling automatic subnet reconfig


@djaesthetic wrote:
@FURRYe38: Wish I could use unmanaged switches. Actually swapped *OUT* a pair in place for these managed ones.

I have a single Cat6 run between two floors of my house. My internet comes in to the basement. About 6 other physical runs terminate in the same location. My router is in my office one floor up. I needed a way to connect all of those physical LAN connections *AND* the internet WAN connection over a single cable. The solution was to put in two managed switches. The single Cat6 run between floors is a trunk passing *ALL* VLANs on Int1. Int2 (on both sides) is the WAN VLAN (where the ATT GW plugs in on one side and the Orbi “Internet” port plugs in on the other). Int3-8 on both sides are dedicated to LAN. It’d work beautifully if it weren’t for this Orbi “feature”.

What a puzzle.  Sorry to have no inside scoop on how Orbi functions with regard to IP address conflicts.  There are questions all the time from people who have only a single ethernet cable to the Orbi location and buying a couple of switches would be vastly less costly than tearing open the walls to install more cable.

 

I do wonder, however, if part of the first problem was the Orbi DHCP subnet mask. The Orbi subnet mask was changed from 255.255.255.0, correct? Having "no conflict" in the actual DHCP ranges may be less significant than an "implied conflict".

 

On the switch issue, can the problem be repeated by power cycling the switch?  Both the GW and Orbi are responding to DHCP, correct requests, correct? Which one will the switch get an IP from?  I can imagine the Orbi observing, "My internet gateway is 172.x.x.x, and 'oh, my' there's a device on my LAN which is in the same subnet.  How about hard coding static IP's in the two switches?

 

Or... sorry I don't understand.

Message 19 of 29
schumaku
Guru

Re: Disabling automatic subnet reconfig

"Disabling automatic subnet reconfig" - you can't disable this wonderful commodity ***. Just ensure no 192.x.x.x network ever shows up on the Orbi WAN port - and nothing strange will happen. 

 

For anything else - follow my reply on you other thread -> GS108Ev3 firmware update triggering Orbi subnet reconfiguration - with your qualification a snap 8-). Up front: It's not a switch issue. 

Message 20 of 29
djaesthetic
Tutor

Re: Disabling automatic subnet reconfig

@CrimpOn : Appreciate the response!

I'd considered the DHCP idea, except Orbi doesn't allow you to define a proper subnet for DHCP. Instead they just ask for a range (i.e. there's no subnet mask defined re: DHCP).

 

Oddly enough, the issue is NOT repeated by power cycling the switch. After seeing the firmware update issue, I'd assumed a power cycle would cause the same behavior -- but it doesn't.

 

The GW has a DHCP range set for two IPs (172.16.0.60-61) solely for performing a WAN IP passthrough back to Orbi's WAN interface (public WAN IP). Orbi has a DHCP range set for 192.168.1.150 - 192.168.1.190.

 

Both switches have hardcoded IP addresses of 192.168.1.2 and 192.168.1.3 respectively.

 

I think another poster may have dropped a clue in the other thread regarding specifically would be triggering this (i.e. Orbi's *WAN* port seeing an IP address that matches the subnet of it's LAN configuration), so going to focus the conversation there. I'm seriously thinking VLAN 1 is my likely culprit. Just trying to figure out how to validate it before sharing the final cause in these threads for the next poor !@#$!%^! who stumbles across the issue.

Message 21 of 29
CrimpOn
Guru

Re: Disabling automatic subnet reconfig

So this is totally stable now, every after power cycling of all components?  Two switches for about $120 beats the heck out of installing another ethernet cable.

Message 22 of 29
djaesthetic
Tutor

Re: Disabling automatic subnet reconfig

@CrimpOn : Seems it. I’ve bounced both switches, the AT&T gateway, and the Orbi - **ALL** at least twice and no issues. I wish I could test a firmware update on those switches (as that reliably triggered the problem before) just to be sure — though I really do feel the removal of VLAN 1 from all ports was the likely culprit (once I understood what specifically was causing Orbi to do this in the first place).
Message 23 of 29
FURRYe38
Guru

Re: Disabling automatic subnet reconfig

Just curious, can you downgrade one of the switches, then re-upgrade to see if this triggers anything? Just an idea...

Message 24 of 29
CrimpOn
Guru

Re: Disabling automatic subnet reconfig


@djaesthetic wrote:
@CrimpOn: Seems it. I’ve bounced both switches, the AT&T gateway, and the Orbi - **ALL** at least twice and no issues. I wish I could test a firmware update on those switches (as that reliably triggered the problem before) just to be sure — though I really do feel the removal of VLAN 1 from all ports was the likely culprit (once I understood what specifically was causing Orbi to do this in the first place).

On a scale of 1 to 10, how difficult would you describe the process of setting up these switches?

There have been many posts from people who discover that their ISP connection feeds to a wiring hub in the basement with ethernet cables running all over the house, but only one to each location.  Baements are a horrible location for WiFi routers, especially if the only thing "down there" is the wire center. If not too difficult to implement, this would be of help to such people.

Message 25 of 29
Top Contributors
Discussion stats
  • 28 replies
  • 6501 views
  • 1 kudo
  • 4 in conversation
Announcements