Reply

WAX214 - Only U-NII-1 5Ghz channels available

ASPC
Aspirant

WAX214 - Only U-NII-1 5Ghz channels available

Hi,

 

since first firmware I saw erratic behaviour when trying to choose the 5GHz channels. Sometimes it only shows first channels (as picture attached) and sometimes after a reboot the whole list of 5GHz channels is populated (but then sometimes the 2.4 GHz band is gone). After upgrading to the latest firmware 1.0.2.3 I cannot see more than 36, 40, 44 or 48 channels under 5GHz band. 

 

Under logs, I can see the following: 

 

WAX214 kern.warn kernel: [835827.454688] [5G AC] countryID=724 ,ic->ic_disable_band=1,[0,0,0,1]
WAX214 kern.warn kernel: [835827.454688]
WAX214 kern.err kernel: [835827.476477] wlan: [1015:I:ANY] ol_acfg_handle_wifi_ioctl: 417: ol_acfg_handle_wifi_ioctl: req->cmd=75 not valid for radio interface, it's for VAP

I've tried to change the country to France, Germany and Spain and in all cases the problem is the same, only the first 4 5GHz channels are available.

 

Regards,

 

Message 1 of 9
JohnC_V
NETGEAR Moderator

Re: WAX214 - Only U-NII-1 5Ghz channels available

@ASPC,

 

Welcome to our community! Smiley Happy

 

We haven't seen any kind of this issue with your device. I would suggest you open a ticket on NETGEAR support and please let them know the status of your WAX214. Just in case that this was some kind of an issue with the firmware, we can just fix this on the next firmware release once we got a ticket opened and reported to the engineering team. Have you tried to roll it back to the previous firmware?

 

Regards,

 

John

NETGEAR Community Team

Message 2 of 9
annoyedLL
Tutor

Re: WAX214 - Only U-NII-1 5Ghz channels available

I had the same issue, went through the support ticket route and was told it's intentional.

 

I am going through the process of returning the unit as defective by design and unfit for purpose. I will also be reporting Netgear to the WiFi Alliance as I very much doubt this is compliant with the spec.

 

I am looking for another vendor for this project and will never consider Netgear for any future projects. They have wasted nearly a week of my time with this piece of junk.

Message 3 of 9
ASPC
Aspirant

Re: WAX214 - Only U-NII-1 5Ghz channels available

I’ve reverted to the first firmware and I can select now power and channels. As you said, this is not compliant with WiFi Alliance.

I’m not going to return the unit, just waiting for OpwnWRT to release a working version to this device to 100% exploit all its capabilities. Now it’s half useful.
Message 4 of 9
annoyedLL
Tutor

Re: WAX214 - Only U-NII-1 5Ghz channels available

I'm on the first firmware and only have 4 channels available

Message 5 of 9
ASPC
Aspirant

Re: WAX214 - Only U-NII-1 5Ghz channels available

In my case I’ve to reboot up to 3 or 4 times to get all the channels populated. All channels doesn’t appears on the first power up. You need to reboot several times. Also I’ve full power configured and 2.4GHz channel 1 selected. Don’t ask me why but if I select channel 1 I never get the full list of 5GHz channels
Message 6 of 9
jeremyshaw
Tutor

Re: WAX214 - Only U-NII-1 5Ghz channels available

@ASPC 

No GPL source released by Engenius or Negear for the WAX214/218 (or the Engenius EWS357/377 - the WAX214/218's OEM source). Not likely to ever get OpenWRT working right on these, IMO. This is inspite of the WiFi AP being seemingly run on OpenWRT (if I had to guess, probably an older version with lots of qualcomm binaries that don't work with newer kernels). The main open source wifi developers seem to have moved on (IMO) from Qualcomm/Atheros chipsets and onto Mediatek. The WAX214 uses a Qualcomm IPQ 6010.

Message 7 of 9
annoyedLL
Tutor

Re: WAX214 - Only U-NII-1 5Ghz channels available

I dont think the 'qualcomm binaries' work properly on the existing kernel if the device logs are anything to go by.

 

Message 8 of 9
ASPC
Aspirant

Re: WAX214 - Only U-NII-1 5Ghz channels available

Tried to flash EWS357APv3 firmware v3.8.4 into my WAX214 just for fun but it detects that firmware is not from the same vendor and gives and error. I don't have the knowledge to use binwalk to dump the firmware and modify the headers but if someone want to try... maybe the OEM firmware is more fine tuned.

 

Regards

Message 9 of 9
Top Contributors
Discussion stats
  • 8 replies
  • 614 views
  • 4 kudos
  • 4 in conversation
Announcements