Orbi WiFi 7 RBE973
Reply

Netgear AC1900 c7000v2 Downstream LED keeps blinking and no internet connection

bajayamani
Follower

Netgear AC1900 c7000v2 Downstream LED keeps blinking and no internet connection

Hi,

I use Netgear AC1900 Wifi cable modem router. Model: C7000v2. I bought this in July 2019 and it works good so far.

But, the modem/router is suddenly stopped working from last evening (25 May 2021) . Meaning no internet connection. My ISP is Xifinity. I called up them and they asked everything is fine from their end. In my modem/router the downstream light is keep blinking. The xifinity customer support representative asked me to unplug the power and wait for few mins and power again. I did this for several times but no use. Finally they asked to check with Netgear.

I tried with checking lot of community blogs but not much useful. Due to pandemic all my family members are very much dependent on internet for work and online school. So without choice i bought a new modem/router (Arris brand) and connected. It is working fine. It shows that there is no problem with comcast. Any help to fix my Netgear modem/router will be appreciated,

Model: C7000|Nighthawk - AC1900 WiFi Cable Modem Router
Message 1 of 2
FURRYe38
Guru

Re: Netgear AC1900 c7000v2 Downstream LED keeps blinking and no internet connection

Please post a copy and paste of the modems connection status page.
Have the ISP check the signal and line quality UP to the modem. Be sure the ISP provisions the modem correctly.
Be sure there are no coax cable line splitters in the between the modem and ISP service box. 
Be sure your using good quality RG6 coax cable up to the modem. 
Be sure to power OFF the modem for 1 minute them back ON.
https://community.netgear.com/t5/Cable-Modems-Routers/General-info-and-Troubleshooting-for-Cable-Mod...

Message 2 of 2
Top Contributors
Discussion stats
  • 1 reply
  • 2865 views
  • 0 kudos
  • 2 in conversation
Announcements

Orbi 770 Series