Orbi WiFi 7 RBE973
Reply

Horrible customer service, tech support has no clue, left me high and dry!

Whistler73
Initiate

Horrible customer service, tech support has no clue, left me high and dry!

I had written a very articulate summary of my experience but apparently that was not meant to be so, this time I will be more concise (you're welcome 😉 

 

1) New R6700AX router.

2) Installed no problem and got Armor (BitDefender) loaded and licensed on all devices.

3) Tried manually setting DNS entries to secure DNS provider

4) Router will not allow this if you get dynamically assigned IP from the ISP (which all residential, non-business class customers do).

5) Called tech support.  FIVE hours later they still didn't understand what I was saying even after multiple reconfigs, testing on multiple PCs/OSs and browsers, screen shots provided, etc.

6) Tech support is sending me a replacement router.  Which will NOT fix the problem as I tried to tell them.

7) NOTE: All I want is for Netgear to consider "fixing" this behavior in future code updates to the router.

😎 New router is en route.

9) ALL Armor (BitDefender) clients are now showing no license and are dysfunctional.

10) Called tech support.  I was told the license is tied to the router and the new router is already activated so I will just have to wait till it comes in.  In the meantime, NO protection for my endpoints.

 

I am beyond disappointed.  Tech support was abysmal, had little to NO tech knowledge whatsoever, had little to NO understanding of how the router worked, and shut down my AV without telling me and refused to re-enable it on the existing router till the new one arrives.

Message 1 of 4
FURRYe38
Guru

Re: Horrible customer service, tech support has no clue, left me high and dry!

DNS is not user configurable if Armor is enabled. Armor uses it's own DNS serivces. 

Message 2 of 4
Whistler73
Initiate

Re: Horrible customer service, tech support has no clue, left me high and dry!

Well now...that makes sense!!!  Thank you sir for a quick and technically feasible answer!  In other words, the replacement router they sent me will not do anything differently (which I told them on the tech support call) and the disablement of my AV subscription pending receipt of the new router is therefore completely unnecessary.

 

Again...thank you for the meaningful response!  Do you by chance know what DNS is being used with Armor activated?

Message 3 of 4
FURRYe38
Guru

Re: Horrible customer service, tech support has no clue, left me high and dry!

I don't. I don't use Armor much.

Might do a search on line to see if there is any information regarding this. 

Message 4 of 4
Discussion stats
  • 3 replies
  • 1040 views
  • 2 kudos
  • 2 in conversation
Announcements

Orbi WiFi 7