Orbi WiFi 7 RBE973
Reply

Netgear Armor not activating for 2 weeks now, it says code: ARM-PYMT-EXP

Ironmansnap
Tutor

Netgear Armor not activating for 2 weeks now, it says code: ARM-PYMT-EXP

I subscribed to the Netgear Armor about 2 weeks ago and it keeps giving me the error code: ARM-PYMT-EXP.

I have contacted Netgear and Bitdefender support over the phone and also have chatted online with them and they created multiple tickets but so far nothing. I have fully reset the router from the back multiple times, I deleted Nighthawk app on my iPhone and installed it again multiple times and nothing has fixed the problem. When I contacted Bitdefender customer service at first they said they will look into it but after a few days, they sent an email saying you purchased it from Netgear and you have to contract them directly and there is nothing they can do about it. It's very disappointing from 2 big companies, nobody can fix this annoying glitche. I have the latest router firmware update installed. version V1.0.4.76. Hopefully they will fix this problem soon.

Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 1 of 9
plemans
Guru

Re: Netgear Armor not activating for 2 weeks now, it says code: ARM-PYMT-EXP

Message 2 of 9
DarrenM
Sr. NETGEAR Moderator

Re: Netgear Armor not activating for 2 weeks now, it says code: ARM-PYMT-EXP

Hello Ironmansnap 

 

Can you PM me your ticket numbers I will escalate the issue.

 

DarrenM

Message 3 of 9
RickML
Initiate

Re: Netgear Armor not activating for 2 weeks now, it says code: ARM-PYMT-EXP

I subscribed to Netgear Armor on 9-26-21, and waited patiently for both my R7000 and the Android app to indicate that Armor had been activated. After a few days and more than a little frustrated Armor still didn't show that it had been activated.

 

I contacted Netgear (not Bitdefender) support through chat, and they had me do these steps:
- Provide the serial number of the router; they confirmed my purchase.
- Send them a copy of the Netgear purchase confirmation email through chat upload; seemed redundant, but I did.
- Provide the router firmware version; the latest (at this time) - V1.0.11.128_10.2.112

 

The agent had me uninstall & reinstall the Nighthawk app; no change.

 

The agent then had me backup my router settings and do a factory reset; seemd pretty extreme but it ended up solving the problem. After that, the app and the router now both display "activated".

 

I know you've done one or more factory resets. And I have an Android where you have an iPhone.  Your error code looks like ARM(or)-P(a)YM(en)T-EXP(ired). My original problem seemed to be a disconnect with my payment through Paypal and then Netgear being able to update the app and router. Although I didn't get an explicit error on the Android app like your iPhone without any add'l info it seems there's a communication issue with the Netgear Armor service updating the apps and router.

 

Maybe there's a clue here that will help you or someone else. Wondering if anyone has been successful geting Armor to activate without going through these gyrations. 

Model: R7000|AC1900 Smart WIFI Router
Message 4 of 9
Ironmansnap
Tutor

Re: Netgear Armor not activating for 2 weeks now, it says code: ARM-PYMT-EXP

Thank you for your reply Rick, My latest update is to just keep waiting and someone will take a look at it soon. I will update here when something happens so others that have similar issues can see it.

I appreciate it, have a great day.

Model: R8000|Nighthawk X6 AC3200 Smart WIFI Router
Message 5 of 9
Meh-402
Aspirant

Re: Netgear Armor not activating for 2 weeks now, it says code: ARM-PYMT-EXP

I did a factory reset then subscribed and have had the same error. Have not had time to call 😩
Message 6 of 9
DarrenM
Sr. NETGEAR Moderator

Re: Netgear Armor not activating for 2 weeks now, it says code: ARM-PYMT-EXP

Please send an email to our customer care team they will be able to help with subscription issues.  customer.service@netgear.com

 

DarrenM

Message 7 of 9
Erom_Sbad
Aspirant

Re: Netgear Armor not activating for 2 weeks now, it says code: ARM-PYMT-EXP

My Armor program won't run and has the cod that everyone else is getting. Re-set it, re installed it and still nothing. Just paid it add it's good till next year.
Model: R7000P|Nighthawk AC2300 Smart WiFi Dual Band Gigabit Router
Message 8 of 9
plemans
Guru

Re: Netgear Armor not activating for 2 weeks now, it says code: ARM-PYMT-EXP

@Erom_Sbad To get a hold of support for subscriptions services like Armor/Circle, click on "MyNetgear" at the top.
Register an account (or login) and then the device.
From there you can start the support process.
Click on: My Support---->Contact Support---->Get help with my subscription service

Message 9 of 9
Top Contributors
Discussion stats
  • 8 replies
  • 3700 views
  • 5 kudos
  • 6 in conversation
Announcements

Orbi WiFi 7