× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973

Re: Support for SMB2


Support for SMB2

Hello Chirpa & Co.

I asked about this some years ago. I hope maybe it's becoming more interesting as more and more OS:es support SMB2. When will this come for ReadyNAS?
Will help improve performance over LAN/WAN for sure!
"If life gives you lemons make lemonade"
Message 1 of 5

Re: Support for SMB2

Hello DEV team!!! SAMBA is supporting SMB2 since quite some time now. Anything you can say about the timing of support for SMB2 on ReadyNas?
"If life gives you lemons make lemonade"
Message 2 of 5

Re: Support for SMB2

Since it appears the ReadyNAS is based on Debian etch (4.0, obsolete) and Samba 3.6 hasn't even made it to squeeze yet (6.0, current stable), I suspect it will be some time before it makes it onto the ReadyNAS.
Message 3 of 5

Re: Support for SMB2

In case the request for SMB2 support on the ReadyNAS x86 devices running Radiator 4.x is still relevant...


After upgrading to OS X El Capitan I began encountering OS X errorcode -43 when using Finder to copy files between my iMac and NAS (and between folders on the NAS) with the NAS share mounted using AFP.  I did some research, but could not resolve this error.  Since I've read that Apple has moved from AFP to SMB (specifically SMB2 as its preferred file sharing protocol), I decided to mount the share using SMB.  This resolved the file copy issues, but copy performance was very slow compared to AFP.


In an effort to improve performance, I decided to see if I could enable SMB2 on my NAS (an NVX running Radiator 4.2.28).  This version of Radiator runs Samba version 3.6.25 (confirmed by running the smbstatus command on the NAS), which includes SMB2 support.  So I was able to force the use of SMB2 by adding the following lines to the [global] section of the /etc/samba/smb.conf file and rebooting the NAS:

min protocol = SMB2

max protocol = SMB2


I then ran the following command in the OS X terminal:  smbutil statshares -a and confirmed that the smb_version running is SMB_2.002.


Couple of things:

- I initially tried adding just the max protocol line to the smb.conf file, but this resulted in the share being mounted SMB1; maybe someone with better knowledge of linux/SMB can provide additional information on how to configure smb to provide flexbility to use either SMB1 or 2.

- This change in protocol DID NOT improve file copy performance.  I tried some additional tuning but gave up on SMB in favor of NFS, which has significantly improved performance.


 Hopefully this is helpful.

Message 4 of 5
NETGEAR Employee Retired

Re: Support for SMB2

Hello absmes,


We appreciate your contribution to the community. Feel free to post any suggestions, questions, recommendations or anything about your NAS that you think needs attention or will help others.
NETGEAR Community Team
Message 5 of 5
Top Contributors
Discussion stats
  • 4 replies
  • 2 kudos
  • 4 in conversation