Reply

XR500 - HomeKit issues

mtthw
Aspirant

XR500 - HomeKit issues

Hello,

I have recently installed a XR500 Nighthawk Pro Gaming Router and I have had issues with Apple HomeKit, specifically with my Lutron Caseta Smart Hub. I have serveral other HomeKit devices that have continued to work wonderfully, but they are either connect over Bluetooth or WiFi; the Smart Hub is the only one that connects over ethernet. I have CenturyLink fiber internet, so I have the XR500 configured to use PPPoE and a VLAN tag of 201 on the WAN (there is an issue with configuring the VLAN where it throws a 400 error when you go to apply it, but you can configure it using the telnet debug interface, but this is beside the point) and things have worked beautifully for everything but the Smart Hub when I use HomeKit. Speeds are great, gaming is great, but this has thrown a wrench in things. I can use the Lutron Caseta app and access and control the lights, my Google Home Mini can also access and control the lights. If I turn off WiFi on my iPhone and restart the Home app (the one built into iOS) I can also access and control my Smart Hub over HomeKit. I am assuiming this has something to do with that my iPhone would be communicating through my AppleTV, which also is connected over ethernet. This happens with my wife's iPhone, and both of our iPads. It seems that if the iOS device trys to access the device directly over WiFi it doesn't work, but if it goes through the AppleTV it works just fine.

I have explored all of the many settings that are included with the router, but I haven't found any that make a difference. I have tried reconfiguring the Smart Hub (both the hub and HomeKit) as well as the XR500. With the XR500, I have tried to restore it using a saving configuration file as well as resetting it up from scratch multiple times. I have updated the firmware to the most recent release as of 02/27/2018, which is V2.1.0.6.

Any help or insight any of you may have would be greatly appricated! I really, really like this router and don't want to return it.

Thanks! 

Model: XR500| Nighthawk Pro Gaming Router
Message 1 of 19
Netduma-Fraser
NetDuma Partner

Re: XR500 - HomeKit issues

Hi mtthw, I haven't used any devices in that nature so I'll advise as best I can.

It sounds like you have the Smart Hub & the Apple TV both configured as Hubs to control everything, is that the case? If so they could be conflicting which makes sense why it works sometimes on one or the other. If you only make the Smart Hub the hub for Smart Kit does that resolve the issue? Apologies if I completely missed the point.

Also have you contacted Netgear Support via their phone line regarding this issue?
Message 2 of 19
JasonN
NETGEAR Employee Retired

Re: XR500 - HomeKit issues

Hi mtthw,

I am going to PM you to collect more information on this and also collect your contact information.

 

 

- Jason N

Message 3 of 19
mtthw
Aspirant

Re: XR500 - HomeKit issues

Hi Fraser,

So, I need both to make it all work. The Lutron Caseta Smart Hub is the only smart hub that talks to the lights that I have in my home. The way HomeKit works is on a local level, unless you have an AppleTV or a iPad configured to be a hub for remote access. This means, that when I am connected to the WiFi on my home network, my iPhone is trying to communicate directly with the Lutron Caseta Smart Hub to control the lights from the Apple Home app. When I turn off the WiFi in my iPhone and I use the same Apple Home app, my phone communicates through the AppleTV to the Lutron Caseta Smart Hub and it all works just fine.

Since the AppleTV is connected through ethernet and not WiFi on the network when everything works, I think that there is something going on with the connection from the WiFi to the ethernet ports in the XR500. Maybe not all of the packets are being transferred between interfaces? I’m unsure.

I have not contacted the phone support yet. This is a extremely technical problem that I didn’t want to try to explain over the phone to someone. Jason N from Netgear PMed me and I have provided contact info to him to help get to the bottom of this. Please let me know if there is anything I can provide you to help you out if you want to look into it further. Thanks for your help!

Message 4 of 19
Netduma-Fraser
NetDuma Partner

Re: XR500 - HomeKit issues

Hi Matthew, thanks for the clarification. So it is a WiFi issue essentially?

What I would start by doing is giving your Apple TV a static IP address in Settings > Setup > LAN Setup. It may be that because it will class it as a different device when wired compared to on WiFi that it is getting confused. If you set a static IP this may prevent that. Also are you using Smart Connect so there is only one SSID?

If Jason has further suggestions do let me know!
Message 5 of 19
JasonN
NETGEAR Employee Retired

Re: XR500 - HomeKit issues

Hi Mtthw,

I have brought this issue up to my internal team and they will be looking into this. I will update you when I have further information. :]

 

 

- Jason N

Message 6 of 19
mtthw
Aspirant

Re: XR500 - HomeKit issues

I’m sorry it has taken me a little bit to respond, my in-laws have been in town.

 

I will have to see if assigning static IP addresses will work. I will try that tonight. I am using smart connect for the WiFi with one SSID.

Message 7 of 19
mtthw
Aspirant

Re: XR500 - HomeKit issues

Hi Case850,

I actually have a ecobee4 and it seems to work with HomeKit most of the time using the XR500, but sometimes it just says “Updating” but won’t update. I can always get it to respond through the ecobee app. The Lurton Caseta app most definitely does work when using this router, but it is a little slower to respond than my experience with other routers. I have recently tried Google WiFi, Netgear Orbi and the Linksys Velop routers, but all of them went back to the store for one reason or another, but all of them worked flawlessly with HomeKit though.

Message 8 of 19
mtthw
Aspirant

Re: XR500 - HomeKit issues

Thank you JasonN. I hope it gets resolved sooner than later, as I might try a different router if it is not resolved soon.

Message 9 of 19
mtthw
Aspirant

Re: XR500 - HomeKit issues

‘@Case850 I’ve considered doing that, but it’s a little more than I want to manage. I used a wired backhaul with all of those systems, but they each had flaws. Google WiFi didn’t support VLAN tagging and when I used PPPoE, speeds were serverly effected, Netgear Orbi had speed issues and the wired backhaul didn’t want to work half the time, and the Linksys Velop worked great except when I tired to play a video game, it would reset about 40 minutes in and would never really recover. If I can’t get this to work right, I probably will go with what you suggested. 

 

‘@Netduma-Fraser I set the static IPs for all HomeKit devices and the AppleTV. There isn’t a difference in what I am experiencing; HomeKit still doesn’t work with the Lutron Caseta lights when I am connected to the WiFi. 

Message 10 of 19
Netduma-Fraser
NetDuma Partner

Re: XR500 - HomeKit issues

Does the Apple TV/Lutron Smart Hub give out it's own IP addresses behind it or do they all have IP addresses from the XR500?
Message 11 of 19
Netduma-Fraser
NetDuma Partner

Re: XR500 - HomeKit issues

Thanks for the info Case!

I spoke with Netgear Support today who said they are going to or have reached out to mtthw in order to determine whether the router is causing the issue or not.
Message 12 of 19
Netduma-Fraser
NetDuma Partner

Re: XR500 - HomeKit issues

Thanks Case!
Message 13 of 19
mtthw
Aspirant

Re: XR500 - HomeKit issues

Sorry Case850, but I don’t think that this is the same issue that you linked to the Apple forum. That is that the HomeKit items DON’T show when using remote access, but DO when on WiFi. The issue I am experiencing is the opposite. Remote access works fine, but when I am connected to my home network through WiFi, they do not. I’ll try swapping out the XR500 with an old router again to see if the issue follows it again, but that’s the only change that I have made with my setup recently.
Message 14 of 19
mtthw
Aspirant

Re: XR500 - HomeKit issues

Well, I just switched out the XR500 with my old router and lo and behold, my issue with HomeKit went away as soon as my old router booted up. Now everything is running as it should, just not quite as fast or with the cool gaming features that the XR500 promises, but everything works, which I’d say is more important. 

This is a issue with the XR500 and HomeKit, not a exclusively a HomeKit issue as it has been suggested. It could be because I have a uncommon configuration (I am using PPPoE and VLAN tagging on the WAN), but right now, I just need something that works. I’m afraid that the XR500 is going back to the store. I don’t have time right now to work through these bugs with no promise of it working in the end. Thank you for all of your suggestions and help.

Message 15 of 19
Netduma-Fraser
NetDuma Partner

Re: XR500 - HomeKit issues

Hi mtthw, before you return it please can you do a 1 on 1 with me to see if I can diagnose it further. If we can identify the issue we can then work on a fix so that no one else has the same issue.

Download & install TeamViewer: https://www.teamviewer.com/en/download/windows/

Then PM me with the ID & password as soon as you can.
Message 16 of 19
mtthw
Aspirant

Re: XR500 - HomeKit issues

Netduma-Fraser: I wish I could help more on this, but I have run out of time before my return window closes at the retailer that I purchased the XR500 from. It is going back tomorrow. 

 

Case850: I am running iOS 11.2.6 on my iPhone and iOS 11.3 beta 5 or 6 on my iPad, I can’t remember which one it is right now, but it’s the most recent beta. Both of them, as well as my wife’s iDevices, all had issues with HomeKit when using the XR500.

Surprisingly, the XR500 recognized the name of both of the AppleTVs that I have.

Message 17 of 19
Netduma-Fraser
NetDuma Partner

Re: XR500 - HomeKit issues

If you have time before then I'd really appreciate if you'd give me 10 minutes. I know exactly what I want to try to do to see if we can pinpoint the cause.
Message 18 of 19
jakes678
Tutor

Re: XR500 - HomeKit issues

 
Message 19 of 19
Discussion stats
  • 18 replies
  • 4010 views
  • 0 kudos
  • 4 in conversation
Announcements