Reply
Highlighted
Apprentice

Xfinity 1GB speed but only get about 150-200 on my XR700

Hello,

 

I've had the XR700 for a few months now. When I first got it, we had Xfinity's 200MB service and I remember I tried the 1GB for about a month. On the Nighthawk app, I remember my speeds were about 960MB and I thought that was great (so from my understanding that was the actual speed the router was getting from the modem, my modem is the CM1100). We ended up downgrading to 500MB speed and I would normally get about 590MB. A few days ago, we made some changes with Xfinity and got some deal with 1GB speeds. I now only get about 150-250 via the Nighthawk app. Speedtest app shows about 600 on my iPhone (which I know it won't go much more than that but the Nighthawk app should show 900+). I did the test many times and a few times I got to about 890+ but pretty much it is hovering around 200. I've done a full factory reset on the router and basically same results. I've done a lot of tips from this thread

 

https://community.netgear.com/t5/Nighthawk-Pro-Gaming-Routers/Nighthawk-XR700-not-getting-full-gigab...

 

As far as QoS off etc...but same. I've also tried ethernet to my MacBook Pro but same thing (besides, I thought the Nighthawk app speeds are speeds that the router is getting anyway). Not sure "iamsotorious" ended up sending his back but figured I'd try. 

 

One thing that was different the last time we had that 1GB is I think I was on the previous FM version..I'm on the current one now. 

 

BTW my upload has always been a great 42.5 MB (Xfinity gives us 40). It has never dropped or had any issues. 

 

Any ideas?

Model: XR700|Nighthawk Pro Gaming Router
Message 1 of 10
Highlighted
Apprentice

Re: Xfinity 1GB speed but only get about 150-200 on my XR700

Another thing I should add...

 

When I connect direclty to my CM1100 modem, I'm getting around 950MB download and the 42.5ish up

Message 2 of 10
Highlighted
Guru

Re: Xfinity 1GB speed but only get about 150-200 on my XR700

The nighthawk app speeds aren't reliable testing in my opinion. They do base if off the router but you can't choose the server and some of the servers, struggle to saturate gigabit. 

I've taken to testing using: dslreports.org, speedtest.xfinity.com, speedtest.googlefiber.net 

These can usually saturate gigabit. the key is making sure your device can saturate a gigabit line. having a gigabit port doesn't mean the device has the processing to hit gigabit speeds. 

When you updated firmware, did you try a factory reset? I'm not 100% on the DumaOs devices but some of netgear's other routers have had issues with QoS settings being retained 

CM2000-> Arris W31-> GS716v2-> TP-Link M9Plus
Message 3 of 10
Highlighted
Apprentice

Re: Xfinity 1GB speed but only get about 150-200 on my XR700

I haven't tried those other testing websites but I'll give it a try. I figured the app would show me the speed that the router is actually getting from the modem...so if I use my Macbook Pro and go to one of those other websites...it'll tell me what the speed it via WiFi or ethernet if I have it plugged in.

 

I've done a full reset today but still the same issue. Out of 10-15 tests, I'll get maybe one that has 850mb speed but mostly between 100-150ish. Just weird. Even when I keep getting around 100, as soon as I do the speedtest.net speed on my phone via WiFi, I get 600+ (again, I know it won't get much higher than that...just odd that the router shows 100ish but phone via WiFi 600+). And if I do Eithernet directly to the modem (CM1100) it is 950ish almost each time. 

Message 4 of 10
Highlighted
NetDuma Partner

Re: Xfinity 1GB speed but only get about 150-200 on my XR700

Are you using the same test when you test the speed of the modem and the router?

Message 5 of 10
Highlighted
Guru

Re: Xfinity 1GB speed but only get about 150-200 on my XR700


@GhillieK9 wrote:

I haven't tried those other testing websites but I'll give it a try. I figured the app would show me the speed that the router is actually getting from the modem...so if I use my Macbook Pro and go to one of those other websites...it'll tell me what the speed it via WiFi or ethernet if I have it plugged in.

 

I've done a full reset today but still the same issue. Out of 10-15 tests, I'll get maybe one that has 850mb speed but mostly between 100-150ish. Just weird. Even when I keep getting around 100, as soon as I do the speedtest.net speed on my phone via WiFi, I get 600+ (again, I know it won't get much higher than that...just odd that the router shows 100ish but phone via WiFi 600+). And if I do Eithernet directly to the modem (CM1100) it is 950ish almost each time. 


Again, the app doesn't let you choose which server to use and potentially its choosing one that can't saturate gigabit or isn't ideal. especially when you're phone is reliably getting 600mbps+ it makes me think its the nighthawk app. 

try those sites and let us know. Test it over ethernet. 

CM2000-> Arris W31-> GS716v2-> TP-Link M9Plus
Message 6 of 10
Highlighted
Apprentice

Re: Xfinity 1GB speed but only get about 150-200 on my XR700

I see what you mean....I just did some tests not using that app and it is almost always around 800 (so via ethernet). Still a bit better going directly to the modem (it was over 900) but I am assuming that is normal that some will drop from the modem to the router? Didn't think it would be quite that much though.

Message 7 of 10
Highlighted
NetDuma Partner

Re: Xfinity 1GB speed but only get about 150-200 on my XR700

Speed tests can vary quite a lot just depending on the time of day etc. For QoS did you disable from Anti-Bufferbloat options?
Message 8 of 10
Highlighted
Guru

Re: Xfinity 1GB speed but only get about 150-200 on my XR700


@GhillieK9 wrote:

I see what you mean....I just did some tests not using that app and it is almost always around 800 (so via ethernet). Still a bit better going directly to the modem (it was over 900) but I am assuming that is normal that some will drop from the modem to the router? Didn't think it would be quite that much though.


You should be able to get close to what the modem is putting out. I'd listen to @Netduma-Fraser @Netduma_Alex recommend as they're the experts on DumaOS. I don't have a DumaOS router to play with so all my advice is based off standard router advice. 

CM2000-> Arris W31-> GS716v2-> TP-Link M9Plus
Message 9 of 10
Highlighted
Apprentice

Re: Xfinity 1GB speed but only get about 150-200 on my XR700

Thank you all for all the quick replies. My dad tried it as well in his house and looks like it is the Nighthawk app...never had issues with It before so must be something new
Message 10 of 10
Discussion stats
  • 9 replies
  • 664 views
  • 3 kudos
  • 4 in conversation
Announcements