Reply

R7000 Port Forwarding Not Working

Tedrion
Tutor

R7000 Port Forwarding Not Working

I'm trying to get a program called Fantasy Grounds working, and it requires port forwarding of port 1802. I've done this on the same ISP at other locations, and recently moved to a new place in the same city, same ISP. But now I have a R7000 Nighthawk router. 

 

I set my PC to a static IP address, and also set a reservation for it in the router interface to make sure nothing else gained that address and causes a conflict. (192.168.1.78 is the address)

 

Then in the router interface (web), under Advanced > Advanced Setup > Port Forwarding / Port Triggering I setup a rule for a new custom service for Fantasy Grounds, setting the internal/external ports to 1802 pointing to the internal IP address 192.168.1.78. PortForwarding.jpg

 

 

 

 

 

 

 

 

Then I went to canyouseeme.org to test the port forwarding, and it times out.

CanYouSeeMeeDotOrg.jpg

 

 

 

 

 

 

 

 

 

 

 

 

 

 

My firmware version is: V1.0.9.34_10.2.36

 

Is there something I'm missing?

Model: R7000|Nighthawk AC1900 Dual Band WiFi Router
Message 1 of 8

Accepted Solutions
Tedrion
Tutor

Re: R7000 Port Forwarding Not Working

I found the solution on another forum. This is definitely a bug in the firmware. 

 

There is a low threshold on the static IP address it will allow forwarding to. I was at .78 which was too high. I put my static IP to .10, and then pointed the rule to my new static IP and it worked. 

 

To test this I put my static up to .101 and adjusted the rule. It failed again. I put it back to .10, and it worked again. 

 

View solution in original post

Message 7 of 8

All Replies
microchip8
Master

Re: R7000 Port Forwarding Not Working

is the program running when you use that website to check the port status? if the program is not running, that website will report the port as closed

Routing: NETGEAR R7800 - Voxel Firmware 1.0.2.88SF & Kamoj addon
Switching: 2x NETGEAR 8-ports (GS108v4) / 1x NETGEAR 16-ports (JGS516v2)
Desktop: AMD Ryzen 7 3700X - Server: Intel Core i7-7700K - NAS: Intel Pentium G4400 - Cruncher: Intel Core i5-7400
Message 2 of 8
Tedrion
Tutor

Re: R7000 Port Forwarding Not Working

 


@microchip8 wrote:

is the program running when you use that website to check the port status? if the program is not running, that website will report the port as closed


No dice. Still not working. 

Message 3 of 8
microchip8
Master

Re: R7000 Port Forwarding Not Working

did you punch a hole in the Windows/MacOS firewall?

Routing: NETGEAR R7800 - Voxel Firmware 1.0.2.88SF & Kamoj addon
Switching: 2x NETGEAR 8-ports (GS108v4) / 1x NETGEAR 16-ports (JGS516v2)
Desktop: AMD Ryzen 7 3700X - Server: Intel Core i7-7700K - NAS: Intel Pentium G4400 - Cruncher: Intel Core i5-7400
Message 4 of 8
Tedrion
Tutor

Re: R7000 Port Forwarding Not Working

canyouseeme.org is checking if the port is open on my router, and is probing off the public IP address. However, just to be thurough, I added both a TCP and UDP entry for port 1802 in the windows firewall...still times out. 

 

I have a set of google wifi routers, and took the Nighthawk off the network. After adding a port forwarding rule for 1802, to my internal IP, the test completed successfully. 

 

So this is definitely the R7000, and something goofy going on with its port forwarding rules. 

Message 5 of 8
antinode
Guru

Re: R7000 Port Forwarding Not Working

> I have a set of google wifi routers, and took the Nighthawk off the
> network. After adding a port forwarding rule for 1802, to my internal
> IP, the test completed successfully.

   How many routers, connected how, are/were involved in this disaster?
If you're cascading multiple routers, then you can expect to have
problems with port forwarding (on an inner router).  A complete
equipment inventory with a list of what's connected to what would be
better than relying on advice from people who must guess your
configuration.

   When the R7000 is in place (and not working as expected), what is its
WAN/Internet IP address?  (The first two octets of what should be your
public IP address ("a.b" out of "a.b.c.d") will do, if you don't want to
reveal the whole thing.)  

> I set my PC to a static IP address, and also set a reservation for it
> in the router interface to make sure nothing else gained that address
> and causes a conflict. (192.168.1.78 is the address)

   It would be simpler either to reserve a dynamic address for the
server, or else give the server a static address outside the DHCP pool.
Configuring the same data in two places (which must agree) is asking for
trouble.  Shrink the DHCP pool, if needed, to create some non-pool
address space, and then use it.

> So this is definitely the R7000, and something goofy going on with its
> port forwarding rules.

   Perhaps, but evidence is still far from conclusive.

Message 6 of 8
Tedrion
Tutor

Re: R7000 Port Forwarding Not Working

I found the solution on another forum. This is definitely a bug in the firmware. 

 

There is a low threshold on the static IP address it will allow forwarding to. I was at .78 which was too high. I put my static IP to .10, and then pointed the rule to my new static IP and it worked. 

 

To test this I put my static up to .101 and adjusted the rule. It failed again. I put it back to .10, and it worked again. 

 

View solution in original post

Message 7 of 8
antinode
Guru

Re: R7000 Port Forwarding Not Working

> I found the solution on another forum. [...]

   _Where_?

> [...] There is a low threshold on the static IP address it will allow
> forwarding to. [...]

   Perhaps, but I doubt it.  What are the limits of your DHCP pool
(ADVANCED > Setup > LAN Setup : Starting IP Address, Ending IP Address)?

   Netgear firmware has been observed with many incredible firmware
defects, so I can't say that this couldn't happen, but it does sound
very unlikely.  One last resort would be a settings reset (and manual
reconfiguration), which might clear some obscure settings corruption.

Message 8 of 8
Top Contributors
Discussion stats
  • 7 replies
  • 13593 views
  • 1 kudo
  • 3 in conversation
Announcements