Orbi WiFi 7 RBE973
Reply

Re: Orbi Mini Pro SXK30 (SXR30+one SXS30) with WPA2 Enterprise setup

bouncyball
Aspirant

Orbi Mini Pro SXK30 (SXR30+one SXS30) with WPA2 Enterprise setup

Hello everyone,

 

I have successfully set up freeradius auth with SXK30 (firmware v110). But there is one annoyng thing. When wifi client tries to authenticate with router (SXR30) the process goes smoothly and client gets connected and roaming from router to satelite works as expected.

 

The problem begins when wifi client tries to authenticate with satelite (SXR30, because when satelite signal is better this is the case). The client can not connect to the wireless network. The issue, as I investigated (debug log analysing, network monitoring), is: when connecting to router, it makes connection to radius server as expected. But satelite never accesses radius server nor instructs router to access it no matter what.

 

This radius server aso works with other 2 APs without problem. Freeradius has both router and satelite IPs as clients configured with proper secret etc... (As I said router authenticates with radius correctly). Unfortunately satelite never connects to radius server itself. I've tried 3 EAP methods: PEAP, EAP-PWD and EAP-TLS with the same success(router)/failure(satelite).

 

Question: is this expected behavior and satelite auth just not implemented in this product? Or maybe there is something that can be done to address this issue?

 

Regards

bb

Message 1 of 4
RaghuHR
NETGEAR Expert

Re: Orbi Mini Pro SXK30 (SXR30+one SXS30) with WPA2 Enterprise setup

Hi @bouncyball 

 

Could you please send us the debug logs? both from router and satellite. We will investigate.

Message 2 of 4
bouncyball
Aspirant

Re: Orbi Mini Pro SXK30 (SXR30+one SXS30) with WPA2 Enterprise setup

I forgot to mention that when I came across this issue I've been experimenting with "Wireless 3" settings while main "Wireless 1" has been set to WPA3 Personal (SAE) and been working good.

 

I kept experimenting and reconfigured "Wireless 1" to "WPA2 Enterprise" as well. After this, surprisingly, it worked with satelite authentication and when I checked "Wireless 3" it worked too! (?)

 

So now on every authentication change to router/satelite, router (not satelite) connects to radius server and I can clearly see in radius logs, that "Called-Station-Id" changes to router/satelite MACs accordingly.

 

Well, in order to not waste your time I'm not attaching Orbi debug logs here any more.

 

Thank you for your attention and such a quick response.

your answer was a hint that It should be working out of the box and kept me testing further.

 

The best regards

bb

 

Message 3 of 4
bouncyball
Aspirant

Re: Orbi Mini Pro SXK30 (SXR30+one SXS30) with WPA2 Enterprise setup

You are welcome 🙂

 

Message 4 of 4
Top Contributors
Discussion stats
  • 3 replies
  • 1059 views
  • 0 kudos
  • 2 in conversation
Announcements