× NETGEAR is aware of a growing number of phone and online scams. To learn how to stay safe click here.
× Introducing the new Orbi 770 Series Mesh System. To learn more click here.
Orbi WiFi 7 RBE973
Reply

RBR50 Slow Internet speed

Coalhole
Tutor

RBR50 Slow Internet speed

I have an RBR50 in router mode connected to Virgin media hub working in modem mode, i.e. no wireless. My VM package was, until recently, 125mb. Speed tests showed download of around 92mb, upload around 19mb.

I have just upgraded package to 250mb. I have redone the speed tests, no change to the download speed, upload is now around 26mb. All tests over wireless.

 

I have run further tests connecting a laptop via ethernet as follows

Laptop to RBR50 - no change to speeds

Laptop to VM hub - download speed 278mb, upload no change.

 

Does anyone have any idea why the RBR50 would be throttling the download speed by such a huge amount?

 

Thanks

 

 

 

 

Message 1 of 10

Accepted Solutions
CrimpOn
Guru

Re: RBR50 Slow Internet speed


@Coalhole wrote:

Speed tests showed download of around 92mb, upload around 19mb.


A speed "just under 100mb" is highly suspect.  Modern systems have electronics built into the physical Ethernet hardware to auto-negotiate the highest speed that the devices on each end of the cable will support.

https://en.wikipedia.org/wiki/Autonegotiation 

 

It would be very useful to know what speed has been negotiated between the Virgin hub and the Orbi router.

Log into the Orbi web interface and open the Advanced Tab Home Page.

Click the blue box, Show Statistics.

CrimpOn_0-1701363323562.png

If this shows "100M/Full" then something is usually wrong with the cable pathway between ISP device and Orbi router.

 

p.s. The router also has a method to report internet speed that can be accessed from the web interface or from the Orbi 'app'.

View solution in original post

Message 6 of 10

All Replies
plemans
Guru

Re: RBR50 Slow Internet speed

I've seen many people disable the wifi on their VM hubs and say "its in modem only mode" when its really not. Disabling the wireless doesn't disable its routing functions. Check to see what you did with the hub. 

I'd put it in router mode and the orbi in access point mode. Then test things

Message 2 of 10
Coalhole
Tutor

Re: RBR50 Slow Internet speed

Thanks. I did log on to the hub and set it in modem mode. Does this not disable wireless? In the VM dashboard it shows wireless as disabled.
Message 3 of 10
plemans
Guru

Re: RBR50 Slow Internet speed

I haven't seen a VM hub that has a modem only mode. Most make you use passthrough mode. 

And it wouoldn't be the first time that a ISP pushed new firmware that broke something. 

Which is why its worth testing with the VM hub in router mode (wifi off) and test the speeds with the orbi in AP mode. 

Message 4 of 10
Coalhole
Tutor

Re: RBR50 Slow Internet speed

Thanks, I'll give that a try.

Message 5 of 10
CrimpOn
Guru

Re: RBR50 Slow Internet speed


@Coalhole wrote:

Speed tests showed download of around 92mb, upload around 19mb.


A speed "just under 100mb" is highly suspect.  Modern systems have electronics built into the physical Ethernet hardware to auto-negotiate the highest speed that the devices on each end of the cable will support.

https://en.wikipedia.org/wiki/Autonegotiation 

 

It would be very useful to know what speed has been negotiated between the Virgin hub and the Orbi router.

Log into the Orbi web interface and open the Advanced Tab Home Page.

Click the blue box, Show Statistics.

CrimpOn_0-1701363323562.png

If this shows "100M/Full" then something is usually wrong with the cable pathway between ISP device and Orbi router.

 

p.s. The router also has a method to report internet speed that can be accessed from the web interface or from the Orbi 'app'.

Message 6 of 10
Coalhole
Tutor

Re: RBR50 Slow Internet speed

Thanks CrimpOn. It does indeed show 100M/Full for the WAN port. I'll change the cable and see what I get.

Message 7 of 10
CrimpOn
Guru

Re: RBR50 Slow Internet speed

Please post the results of changing the cable.  All sorts of things can happen to:

  • The actual cable itself
  • The RJ45 plugs which are crimped onto each end of the cable
  • The RJ45 jacks on the devices.  If even one of those tiny gold wires is bent or doesn't make contact then the maximum connection rate falls to 100M/Full.

 

Message 8 of 10
Coalhole
Tutor

Re: RBR50 Slow Internet speed

Brilliant. Thanks CrimpOn it was a cable problem. Now getting downloads up around 270mb.

Message 9 of 10
FURRYe38
Guru

Re: RBR50 Slow Internet speed

Glad you got it working. Please mark your thread as solved so others will know. Be sure to save off a back up configuration to file for safe keeping. Saves time if a reset is needed.
https://kb.netgear.com/000062080/How-do-I-back-up-the-configuration-settings-on-my-Orbi-WiFi-System
Enjoy. 📡

Message 10 of 10
Top Contributors
Discussion stats
  • 9 replies
  • 1568 views
  • 1 kudo
  • 4 in conversation
Announcements

Orbi 770 Series