Reply
Emetw
Aspirant

New Orbi setup, cannot get RDP to work

I just received my new Orbi setup and it is configured as follows:

 

Router upstairs, one satellite downstairs.

Workstation is plugged into satellite downstairs

 

I use RDP on my Windows 10 laptop and the Microsoft RDP apps on my iPad and iPhone to access my workstation in my office downstairs.  In the Orbi admin interface I have added the port forwarding rule for port 3389 to point to the local IP of my workstation, but none of my devices can connect to my workstation and the RDP attempt times out.  Doesn't matter if I attempt to RDP to the workstation's local IP or try to use my real IP.  I can ping my workstation's local IP from my laptop and all four ping attempts are received.  This worked perfectly on the TP Link Archer C9 router that was replaced by my Orbi setup.  Am I missing something to get RDP to work with Orbi?

 

Thanks in advance.

Model: Orbi High-Performance AC3000 Tri-Band WiFi System (RBK50)
Message 1 of 5

Accepted Solutions
Emetw
Aspirant

Re: New Orbi setup, cannot get RDP to work

Thanks everyoner, especially Mikey94025, you had the closest answer.  My network connection on my workstation was good (set to public), but for some reason my homegroup had to be validated again.  I did this by going to Control Panel>Network and Sharing Center>Homegroup and then rejoining there (Windows 8.1).  All works now, both via LAN IP and external IP.

 

Thank you!

View solution in original post

Message 5 of 5

All Replies
Narkhelek
Aspirant

Re: New Orbi setup, cannot get RDP to work

Just to clarify are the RDP clients on your local network or are they trying to connect from the Internet (which is what I assume you're trying to accomplish by setting up port-forwarding)?

Message 2 of 5
st_shaw
Master

Re: New Orbi setup, cannot get RDP to work

If you cannot get RDP to work on your LAN by accessing the workstation's local IP, then the problem likely with the workstation or the client, not the Orbi.  Get it working on the LAN first, then try port forwarding.

 

Check Windows Firewall on the workstation.  Turn the firewall OFF and see if RDP works.  Did you change the subnet you are using on your LAN when you switched to Orbi? If so, maybe the firewall was setup to allow the old subnet.

Message 3 of 5
Mikey94025
Prodigy

Re: New Orbi setup, cannot get RDP to work

You created a new Wireless network when you setup your Orbi.  It's likely blocking RDP.  If you right-click the wireless taskbar icon and Open Network and Sharing Center, does it say "private network" or "public network"?  I believe that public defaults to blocking RDP.  You can switch it by left-clicking the wireless taskbar icon, select your wireles network, click the Properties link of that network, then turn on Make this PC Discoverable.

 

Message 4 of 5
Emetw
Aspirant

Re: New Orbi setup, cannot get RDP to work

Thanks everyoner, especially Mikey94025, you had the closest answer.  My network connection on my workstation was good (set to public), but for some reason my homegroup had to be validated again.  I did this by going to Control Panel>Network and Sharing Center>Homegroup and then rejoining there (Windows 8.1).  All works now, both via LAN IP and external IP.

 

Thank you!

View solution in original post

Message 5 of 5
Top Contributors
Discussion stats
  • 4 replies
  • 4520 views
  • 0 kudos
  • 4 in conversation
Announcements