Rispondere
Aspirant

RBR20 pacchetti UDP Multicast

Salve, ho un Orbi RBR20 con configurazione in AP Mode collegato ad un router.

I satelliti sono collegati tra di loro in modalità ethernet e non wifi mesh.

Ho una serie di dispositivi collegati in WiFi ad Orbi che trasmettono pacchetti UDP in multicast sull'ip 224.0.1.187 porta 5683

 

Il problema è che i pacchetti UDP non vengono ritrasmessi sulla ethernet, ma sono visibili solo se mi collego alla rete WiFi di ORBI.

 

Ad esempio, abilitando la porta telnet di ORBI ed effettuando il seguente comando

tcpdump -n -i ath0 port 5683

dal dispositivo principale o da uno dei satelliti riesco a vedere correttamente i pacchetti UDP,

 

root@RBS20:/etc/config# tcpdump -n -i ath0 port 5683
tcpdump: WARNING: ath0: no IPv4 address assigned
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on ath0, link-type EN10MB (Ethernet), capture size 65535 bytes
21:45:28.743030 IP 192.168.1.228.5683 > 224.0.1.187.5683: UDP, length 100
21:45:29.215484 IP 192.168.1.227.5683 > 224.0.1.187.5683: UDP, length 241
21:45:30.116418 IP 192.168.1.207.5683 > 224.0.1.187.5683: UDP, length 196
21:45:30.251665 IP 192.168.1.219.5683 > 224.0.1.187.5683: UDP, length 241
21:45:30.341121 IP 192.168.1.201.5683 > 224.0.1.187.5683: UDP, length 242

 

ma collegandomi alla ethernet non riesco a vederli.

Sembrerebbe che il bridge br0 non riesca a gestire i pacchetti da ath0 a eth0.

 

Se provo a collegare un computer direttamente a NETGEAR Orbi tramite cavo di rete (senza passare da switch ma diretto nella porta lan) NON vedo i pacchetto UDP multicast ma se quel computer lo collego tramite rete WiFi di ORBI riesco a vedere i pacchetti.

 

Ma il sistema ORBI se è utilizzato in modalità Access Point non dovrebbe filtrare questi dati, ma lasciarli passare come tutti gli altri.

 

Chiedo se esista un workaround per poter risolvere il problema, anche se fosse necessario adoperare dei comandi telnet in OpenWRT.

 

Model: RBR20|Orbi AC2200 Tri-band WiFi Router
Messaggio 1 di 11
NETGEAR Moderator

Re: RBR20 pacchetti UDP Multicast

Salve @ellegi,

 

benvenuto nella Community!

 

Potrebbe chiarire che versione firmware è installata sul router e sui satelliti Orbi?

 

In qualità di moderatrice NETGEAR, non posso darle suggerimenti sull'uso di Telnet. E' mio dovere sottolineare che l'uso di Telnet potrebbe invalidare la garanzia del prodotto, in quanto si tratta di uno strumento che dovrebbe essere usato solamente dal Supporto tecnico a fini diagnostici o con la supervisione dei nostri tecnici.

 

Saluti,

Erika

Team NETGEAR


____
Gentilmente clicchi KUDOS
se ha trovato la risposta utile e ACCETTARE COME SOLUZIONE se opportuno.

Messaggio 2 di 11
Aspirant

Re: RBR20 pacchetti UDP Multicast

Salve, la mia versione sia sul dispositivo principale che sui satelliti è l'ultima disponibile per il mio dispositivo ovvero : V2.5.1.16

 

Messaggio 3 di 11
NETGEAR Moderator

Re: RBR20 pacchetti UDP Multicast

Salve @ellegi,

 

sto svolgendo qualche verifica sulla problematica illustrata, aggiornerò questa conversazione appena possibile.

 

Saluti,

Erika

Team NETGEAR


____
Gentilmente clicchi KUDOS
se ha trovato la risposta utile e ACCETTARE COME SOLUZIONE se opportuno.

Messaggio 4 di 11
Aspirant

Re: RBR20 pacchetti UDP Multicast

Salve @ErikaMa  mi scusi il disturbo, vorrei sapere se la problematica è ancora in fase di verifica e se ci sono novità al riguardo.

 

 

Messaggio 5 di 11
NETGEAR Moderator

Re: RBR20 pacchetti UDP Multicast

Buongiorno @ellegi,

 

purtroppo non ho ancora ricevuto una risposta dai nostri esperti. Le confermo che aggiornerò quella conversazione non appena ci saranno novità.

La ringrazio per la sua pazienza e collaborazione Smiley Felice

 

Saluti,

Erika

Team NETGEAR


____
Gentilmente clicchi KUDOS
se ha trovato la risposta utile e ACCETTARE COME SOLUZIONE se opportuno.

Messaggio 6 di 11
NETGEAR Moderator

Re: RBR20 pacchetti UDP Multicast

Salve @ellegi,

 

gli ingegneri non sono stati in grado di replicare il problema, per provare a farlo avrebbero bisogno di alcuni dati aggiuntivi.

Le invierò a breve un messaggio privato.

 

Saluti,

Erika

Team NETGEAR


____
Gentilmente clicchi KUDOS
se ha trovato la risposta utile e ACCETTARE COME SOLUZIONE se opportuno.

Messaggio 7 di 11
NETGEAR Moderator

Re: RBR20 pacchetti UDP Multicast

Buongiorno @ellegi,

 

la ringrazio per aver inviato privatamente i dettagli richiesti e la configurazione della sua rete.

 

In particolare, lo schema di configurazione della rete mostra: router principale > switch > Orbi in modalità AP.

Allo stesso switch sono poi collegati i satelliti Orbi. Questo significa che il router Orbi è collegato allo switch via WAN e che, quindi, router e satelliti Orbi prendono accesso a Internet dallo switch.

 

Questa configurazione non è del tutto corretta per la creazione dell'Ethernet backhaul. Quando si utilizza l'Ethernet backhaul con uno switch, lo switch deve prendere l'accesso a Internet dal router Orbi via LAN (anche se questo è in AP). La configurazione corretta sarebbe: router Orbi > switch > satelliti. Lo switch dovrebbe essere collocato tra router Orbi e satelliti. 

 

Il collegamento Ethernet tra i dispositivi Orbi è mostrato nel kb What is Ethernet backhaul and how do I set it up on my Orbi WiFi System?

 

Devo quindi chiederle di fare un altro test, configurando correttamente l'Ethernet backhaul, come da istruzioni, per verificare se il problema persiste.

 

Saluti,

Erika

Team NETGEAR


____
Gentilmente clicchi KUDOS
se ha trovato la risposta utile e ACCETTARE COME SOLUZIONE se opportuno.

Messaggio 8 di 11
Aspirant

Re: RBR20 pacchetti UDP Multicast

Salve Erika, grazie per la risposta.

Ritengo il test che mi richiede poco utile e non lo eseguirò per due motivi:

 

1) Nella pagina che mi ha indicato è mostrato nella terza immagine una topologia in cui i satelliti sono interconnessi tramite uno switch, che è anche il mio caso.

2) Indipendentemente dalla WAN o dai satelliti, qui stiamo parlando di pacchetti che transitano unicamente in rete locale. Ho fatto una prova intermedia: Ho staccato i satelliti e ho collegato direttamente un computer via cavo LAN al main router ORBI (quindi senza switch e senza router WAN a monte), ed anche in quel caso i pacchetti UDP Multicast in questione non transitano. Diversamente se lo stesso computer lo connetto in WiFI al main router ORBI ricevo quei pacchetti. Quindi a mio avviso c'è qualcosa che non va nella configurazione o nel firmware che impedisce che tali pacchetti passino tramite il bridge br0.

 

 


@ErikaMa wrote:

Buongiorno @ellegi,

 

la ringrazio per aver inviato privatamente i dettagli richiesti e la configurazione della sua rete.

 

In particolare, lo schema di configurazione della rete mostra: router principale > switch > Orbi in modalità AP.

Allo stesso switch sono poi collegati i satelliti Orbi. Questo significa che il router Orbi è collegato allo switch via WAN e che, quindi, router e satelliti Orbi prendono accesso a Internet dallo switch.

 

Questa configurazione non è del tutto corretta per la creazione dell'Ethernet backhaul. Quando si utilizza l'Ethernet backhaul con uno switch, lo switch deve prendere l'accesso a Internet dal router Orbi via LAN (anche se questo è in AP). La configurazione corretta sarebbe: router Orbi > switch > satelliti. Lo switch dovrebbe essere collocato tra router Orbi e satelliti. 

 

Il collegamento Ethernet tra i dispositivi Orbi è mostrato nel kb What is Ethernet backhaul and how do I set it up on my Orbi WiFi System?

 

Devo quindi chiederle di fare un altro test, configurando correttamente l'Ethernet backhaul, come da istruzioni, per verificare se il problema persiste.

 

Saluti,

Erika

Team NETGEAR


 

Messaggio 9 di 11
NETGEAR Moderator

Re: RBR20 pacchetti UDP Multicast

Salve @ellegi,

 

la ringrazio per l'aggiornamento, le ho inviato un messaggio privato con ulteriori step per il troubleshooting.

 

Saluti,

Erika

Team NETGEAR


____
Gentilmente clicchi KUDOS
se ha trovato la risposta utile e ACCETTARE COME SOLUZIONE se opportuno.

Messaggio 10 di 11
Aspirant

Re: RBR20 pacchetti UDP Multicast

Sono alquanto basito dal comportamento del supporto Netgear.

Dopo due mesi di botta e risposta dove segnalavo una anomalia nel vostro firmware, ricevo risposta dal supporto che mi dicono che il prodotto non è più coperto da garanzia in quanto ho usato la funzione telnet (come se sulla pagina di debug ci fosse un disclaimer del genere). Chiunque con un minimo di esperienza capirebbe che se il telnet viene usato come strumento di diagnostica, non c'è alcun danno che possa avvenire, almeno non tale da non essere risolto con un ripristino.

 

Io non ho chiesto alcuna sostituzione o lamentato prodotto difettoso. Ho fatto notare che il prodotto non si comporta come dovrebbe e come fanno altri router della medesima caratura, e dopo aver perso tempo a produrre documentazione, dump della configurazione, vengo liquidato con due righe che mi dicono:

 

"Siamo spiaciuti nel informarLa che cambiando le impostazioni tramite i programmi come Telnet il dispositivo di suo posesso non è piu' coperto dalla garanzia Netgear:"

 

Beh, che dire, complimenti, ottimo supporto.

 

 

 

Messaggio 11 di 11
Migliori autori con kudos
Statistiche discussione
  • 10 risposte
  • 461 visualizzazioni
  • 0 kudos
  • 2 con conversazione attiva