Reply
Highlighted

Sonos can't connect to Orbi

Hi there,

 

I'm in stress... ;-)

I bought myself an Orbi router+satellite last week. But after succesfull installation of my mesh-network, my Sonos play:1 (2 pcs) can't connect to the wifi-network anymore. I gave them a factory-reset and still it keeps giving the same error saying: Wrong password (where i'm sure it's right) or not on a 2,4 ghz netwerk compatible wit 802.11b/802.11g. Now I can see in the Orbi-app it's on 5ghz in general. So that could be it.

Now i'm a little bit handy, but certainly no computer-expert: But I can't find a way to control if it's 2,4 ghz in the Orbi app, or to change it to 2,4ghz on particulary the sonos-device. Somebody familiar with the issue or can help me solve this?

Model: RBK50| Orbi AC3000 High-Performance Tri-Band WiFi System
Message 1 of 20

Accepted Solutions
Highlighted
Tutor

Re: Sonos can't connect to Orbi

Spent a few months figuring how to get my Sonos speakers working on a new Orbi Wifi. The changing of Wifi routers effectively bricked 2,500 bucks of Sonos products for me. It just wouldn't work on the new router. My setup is a Boost (connected by wire to Orbi router) and 5 Play Ones, a Playbar and Sub; all wifi connected. 

The boost (and probably a speaker if it's hardwired into the Orbi router) will be seen by the Sonos Controller App, but the wireless connections would not transfer over or be seen by Sonos. Factory reset or no factory reset. The issue lies in my Orbi router. When I would try to add a wifi speaker in the Sonos App, it would time out and fail. Every time. Upon some sleuthing, for whatever reason, I noticed the Orbi router would allocate an IP to the speaker, but in the Orbi device settings, it would be set up as "disabled" and therefore the add new speaker would time out and fail in the Sonos App, then the speaker's IP address would disappear in the Orbi app as well since I didn't "enable" it in the device settings. You manually have to "approve"/slide the new Wifi Sonos speaker IP address to "enable" in the Orbi App to finish assignment of an IP address, which then allows the Sonos Controller App to finish seeing and capturing the Wifi Sonos speakers. 

So my fix went like this:

  1. Connect the boost by wire to the router (i'm guessing a speaker would work also)
  2. Open Sonos Controller App (it should see whatever is hardwired to the router, my Orbi auto enabled the Boost, but if it doesn't, keep reading, you will have to "enable" in the Orbi app).
  3. Factory reset the Wifi speaker (i know Sonos is all against this, i'm just showing you how it worked for me on 7 speakers and a Sub.; i factory reset all of them; i did this process individually for all speakers and sub)
  4. After the factory reset, I restarted the speaker and selected "add new speaker or sub" in the Sonos App. Follow the directions in the app.
  5. Have your Orbi app open on the same device or another device, you will need to enable the new speaker's IP address. This is key as you will have to toggle back and forth between the Sonos Controller app and the Orbi app.
  6. During the final setup stages of Sonos Controller installation of the new speaker it will "hang" a little. During this final part of the install step is where you will have to be vigilant at seeing when Orbi sees it and gives it a "disabled" IP address in the Orbi app.
  7. Keep refreshing your Orbi app's "device settings" page by going back and forth between the home screen and device settings. After about 15-40 seconds of the final installation part of the new speaker, a new Sonos speaker will show up in the Orbi device settings, with a unique IP address but will be "disabled". My orbi required me to approve the new IP address by sliding the toggle from "diabled" to the green "enable".
  8. Once enabled in the Orbi app - device settings, the Sonos Controller finished installing the new speaker, and since it was factory reset, updated the firmware. It was now visible in the Sonos Controller App.

So the issue was my Orbi requiring a manual approval of the IP address to give the wifi Sonos speakers. There's a key 30 seconds in the process above where the Sonos app is almost finished installing, but you have to get in the Orbi app to toggle the wifi IP address to "enable". That was the issue, not my speaker but the IP allocation process of my Orbi. I thinks it's a security feature of the Orbi to prevent subnetworks leaching onto a wired connection.

View solution in original post

Model: RBR20|Orbi AC2200 Tri-band WiFi Router
Message 9 of 20

All Replies
Highlighted
Sensei

Re: Sonos can't connect to Orbi

I Googled "Sonos new WiFi" and found this:

 

Connect your Sonos player to your WiFi router via ethernet cable. Open the Sonos app and select Settings > Advanced Settings > Wireless Setup. This will guide you through the necessary steps. After entering your new password, you should then see a message saying your Sonos player is now set up on the new WiFi network.Jul 27, 2017
 
Is this what you did, and your Sonos does not connect when you remove the ethernet cord?
 
When the Sonos is connected with an ethernet cable, all of that "2.4G vs. 5G" business should not apply.  Orbi is compatible with 802.11/b/g.  One of the  things people find confusing about Orbi (at first) is that Orbi uses the same network name (SSID) for both its 2.4G and 5G radios.  Devices which can connect at both speeds choose the speed that gives them the best overall speed.  Devices which can connect to only 2.4G networks have no idea that the 5G network exists.
 
If you search the forum, there are numerous reports of Sonos requiring special handling.  It appears that Sonos products may "talk to each other" independent of the regular network.  The support page specifically mentions spanning tree issues (which are caused when there are multiple paths through the network and "infinite loops" can be created by accident.
I love my Orbi.
Message 2 of 20
Highlighted

Re: Sonos can't connect to Orbi

Yes, thats what I did. Using the ‘wizard’ for wireless setup. But after entering the password, I’m receiving the error!
Even when i use a data-cable, the same issue occurs. I’ve even tried both Sonos play:1 units. And again: I’m sure the password is correct.
Message 3 of 20
Highlighted
Sensei

Re: Sonos can't connect to Orbi

Alas, a lot of people appear to have encountered issues with the combination of Sonos and Orbi.  This community forum has over 200 posts containing the word "Sonos" and the Sonos forum (https://en.community.sonos.com/search?q=orbi) has a large number as well.  I also found many Sonos posts mentioning problems with Velop and Google mesh WiFi.

 

Not having any Sonos products, I haven't had a reason to read through these posts.  Let's hope one of the expert level community members knows the solution.

 

On the specific issue of passwords, does the Sonos app show what you have entered in "plain text?"  I went through nine kinds of hell with some WiFi devices when my pudgy fingers did not enter the characters I thought were being pressed and all I saw was a row of dots.

I love my Orbi.
Message 4 of 20
Highlighted
Master

Re: Sonos can't connect to Orbi


@PiepeltjeNL wrote:

Hi there,

 

I'm in stress... ;-)

I bought myself an Orbi router+satellite last week. But after succesfull installation of my mesh-network, my Sonos play:1 (2 pcs) can't connect to the wifi-network anymore. I gave them a factory-reset and still it keeps giving the same error saying: Wrong password (where i'm sure it's right) or not on a 2,4 ghz netwerk compatible wit 802.11b/802.11g. Now I can see in the Orbi-app it's on 5ghz in general. So that could be it.

Now i'm a little bit handy, but certainly no computer-expert: But I can't find a way to control if it's 2,4 ghz in the Orbi app, or to change it to 2,4ghz on particulary the sonos-device. Somebody familiar with the issue or can help me solve this?


It seems that your Sonos app has stored information from your previous wifi network. In the controller app you have to tell Sonos to forget the existing wireless network, then tell it what new network to connect to. 

Please follow the following steps:

  1. Please connect the first Sonos speaker temporarily to your router by Ethernet and select "Boost" setup in the app.
  2. When the speaker is working wired, in your Sonos app go to Settings > Advanced Settings > Wireless Setup, remove your existing WiFi network settings (I believe there's a button to do this),
  3. Go iback nto the app and select "Wireless setup". This will take you through steps that will enable you to disconnect the Ethernet. You will also have to enter your home network credentials (SSID and password) in that process.

My Setup Internet Fiber ONT 250↓/250↑ISP Telenor | Wifi Router Orbi RBK50 AC3000, Router Mode, Wired Backhaul / Orbi RBK852 AX6000, Router Mode, Wireless Backhaul | Switches Netgear GS208Time Zone CET (Sweden)

Message 5 of 20
Highlighted

Re: Sonos can't connect to Orbi

Tried it,but didn’t work!

Wired up, the Sonos works perfectly. But trying to connect wireless, it keeps failing.

 

I really have the feeling that there’s a problem hitting 2,4 GHz and 5 GHz. 

It’s the last thing I can think about and I see on other post there are several products than have and error failing to connect to the Orbi on 2,4 GHz. It should split automatic, but isn’t always working. Is there a simple way (again, i’m not a computer expert) to test this. So a simple way to shut down 5ghz, connect the Sonos and after that re-activate 5 GHz?

 

Message 6 of 20
Highlighted
Master

Re: Sonos can't connect to Orbi


@PiepeltjeNL wrote:

......

I really have the feeling that there’s a problem hitting 2,4 GHz and 5 GHz. 

......


... But Sonos support both 2.4 and 5 GHz bands, so it's not really the same issue that others see with devices that only support 2.4 GHz issue!!

Can this be a routing issue? Is Orbi set in AP or Router Mode? What ISP modem/router do you use?

My Setup Internet Fiber ONT 250↓/250↑ISP Telenor | Wifi Router Orbi RBK50 AC3000, Router Mode, Wired Backhaul / Orbi RBK852 AX6000, Router Mode, Wireless Backhaul | Switches Netgear GS208Time Zone CET (Sweden)

Message 7 of 20
Highlighted
Mentor

Re: Sonos can't connect to Orbi

Before poking around with Sonos and making things worse, I recommend you take the time to describe to us your setup

 

Be precise and include make/models/modes of modems, routers, etc.

 

  • What type of internet do you have?  
  • What is make and model of your cable modem and/or router
  • Is your Orbi in AP or Router Mode?
  • Do you have a sonos Boost?
  • What version of Orbi do you have and how many satellites?
  • What firmware are you running?
  • Anything else unusual about your setup?
  • Side of home and positioning of Orbis

I have had a great deal of luck with Sonos, so I am sure it works... just a matter of getting all the settings correct.

 

Your answers to the above will help and prevent from fooling with stuff that doesnt need tweaking

 

---------------
My Equipment: Cox Cable (350Mb/35Mb), Orbi AX6000 (RBR850, RBS850), w/2 x RBS50) (Wired backhaul), NG GS116PP Gigabit Smart Switch, Synology DS1019+ NAS
Message 8 of 20
Highlighted
Tutor

Re: Sonos can't connect to Orbi

Spent a few months figuring how to get my Sonos speakers working on a new Orbi Wifi. The changing of Wifi routers effectively bricked 2,500 bucks of Sonos products for me. It just wouldn't work on the new router. My setup is a Boost (connected by wire to Orbi router) and 5 Play Ones, a Playbar and Sub; all wifi connected. 

The boost (and probably a speaker if it's hardwired into the Orbi router) will be seen by the Sonos Controller App, but the wireless connections would not transfer over or be seen by Sonos. Factory reset or no factory reset. The issue lies in my Orbi router. When I would try to add a wifi speaker in the Sonos App, it would time out and fail. Every time. Upon some sleuthing, for whatever reason, I noticed the Orbi router would allocate an IP to the speaker, but in the Orbi device settings, it would be set up as "disabled" and therefore the add new speaker would time out and fail in the Sonos App, then the speaker's IP address would disappear in the Orbi app as well since I didn't "enable" it in the device settings. You manually have to "approve"/slide the new Wifi Sonos speaker IP address to "enable" in the Orbi App to finish assignment of an IP address, which then allows the Sonos Controller App to finish seeing and capturing the Wifi Sonos speakers. 

So my fix went like this:

  1. Connect the boost by wire to the router (i'm guessing a speaker would work also)
  2. Open Sonos Controller App (it should see whatever is hardwired to the router, my Orbi auto enabled the Boost, but if it doesn't, keep reading, you will have to "enable" in the Orbi app).
  3. Factory reset the Wifi speaker (i know Sonos is all against this, i'm just showing you how it worked for me on 7 speakers and a Sub.; i factory reset all of them; i did this process individually for all speakers and sub)
  4. After the factory reset, I restarted the speaker and selected "add new speaker or sub" in the Sonos App. Follow the directions in the app.
  5. Have your Orbi app open on the same device or another device, you will need to enable the new speaker's IP address. This is key as you will have to toggle back and forth between the Sonos Controller app and the Orbi app.
  6. During the final setup stages of Sonos Controller installation of the new speaker it will "hang" a little. During this final part of the install step is where you will have to be vigilant at seeing when Orbi sees it and gives it a "disabled" IP address in the Orbi app.
  7. Keep refreshing your Orbi app's "device settings" page by going back and forth between the home screen and device settings. After about 15-40 seconds of the final installation part of the new speaker, a new Sonos speaker will show up in the Orbi device settings, with a unique IP address but will be "disabled". My orbi required me to approve the new IP address by sliding the toggle from "diabled" to the green "enable".
  8. Once enabled in the Orbi app - device settings, the Sonos Controller finished installing the new speaker, and since it was factory reset, updated the firmware. It was now visible in the Sonos Controller App.

So the issue was my Orbi requiring a manual approval of the IP address to give the wifi Sonos speakers. There's a key 30 seconds in the process above where the Sonos app is almost finished installing, but you have to get in the Orbi app to toggle the wifi IP address to "enable". That was the issue, not my speaker but the IP allocation process of my Orbi. I thinks it's a security feature of the Orbi to prevent subnetworks leaching onto a wired connection.

View solution in original post

Model: RBR20|Orbi AC2200 Tri-band WiFi Router
Message 9 of 20
Highlighted
Aspirant

Re: Sonos can't connect to Orbi

Did you fix the issue? I also have the same problems. SONOS one can't works properly with ORBI wireless. Try all but no Idea. 

Message 10 of 20
Highlighted
Tutor

Re: Sonos can't connect to Orbi

Yes. My issue was cleaned up by doing what the post says.
 
My orbi is set to on DHCP mode and "enable all connections" in the access control area of the Orbi settings, but it wouldn't auto enable any of my Sonos speakers at installation.   They were given an IP address in "paused" mode in the Orbi device manager page and if i didn't slide the toggle to the green "enable", it would time out. 
 
I had to "enable" in the orbi app, or webbrowser page when you logged into the orbi concurrently with the Sonos setup of a new speaker.  
 
Some more discussions will be on the Sonos site:
Message 11 of 20
Highlighted

Re: Sonos can't connect to Orbi

It worked! Exactly as written above. Thank you very much for all the help.

It took Some time, but in the end it’s worth it.

Message 12 of 20
Highlighted
Aspirant

Re: Sonos can't connect to Orbi

Guys. I think I figured out to solve all the connection issues between these two. First go into Orbi advanced options and change the 2.4 channel from auto to channel 11. After you apply, this will reboot Orbi. The go into Sonos settings, advanced settings and choose channel 11 in the SonosNet Channel settings. This fixed it all for me. Good luck. 

Message 13 of 20
Highlighted
Master

Re: Sonos can't connect to Orbi


@kpenn wrote:

....... First go into Orbi advanced options and change the 2.4 channel from auto to channel 11. After you apply, this will reboot Orbi. The go into Sonos settings, advanced settings and choose channel 11 in the SonosNet Channel settings. This fixed it all for me. Good luck. 


Very wierd, indeed! I would use a different channel for Orbi than what is being used by SonosNet to avoid interference between the two systems.

My Setup Internet Fiber ONT 250↓/250↑ISP Telenor | Wifi Router Orbi RBK50 AC3000, Router Mode, Wired Backhaul / Orbi RBK852 AX6000, Router Mode, Wireless Backhaul | Switches Netgear GS208Time Zone CET (Sweden)

Message 14 of 20
Highlighted
Aspirant

Re: Sonos can't connect to Orbi

i had trouble with this at first.  i read all these posts and they scared me lol.  i am technical enough to really mess things up.

what i found that worked was easy. 

  1. I reset the controller on my sonos from my iphone. 
  2. i connected my iphone to the orbi wifi
  3. i have 7sonos players.  I started with a sonos 3.  i did a factory reset on it.
  4. i connected that sonos to an orbi satalite with a cord
  5. in sonos ap i added a new speaker and went through the set up
  6. i continued this process with all the speakers
  7. good bye old network, hello Orbi.  it connected to 2.4ghz like others have mentioned 

there were a couple of speakers (playbars) that failed at first.  but then i selected the alternate set up which wanted the hard wire (even through it was hard wired) and that seemed to work.

 

good luck

 

 

 

 

Message 15 of 20
Highlighted
Master

Re: Sonos can't connect to Orbi

So do you mean that you now have more than one Sonos Speaker wired to Orbi?

My Setup Internet Fiber ONT 250↓/250↑ISP Telenor | Wifi Router Orbi RBK50 AC3000, Router Mode, Wired Backhaul / Orbi RBK852 AX6000, Router Mode, Wireless Backhaul | Switches Netgear GS208Time Zone CET (Sweden)

Message 16 of 20
Highlighted
Master

Re: Sonos can't connect to Orbi

 

My Setup Internet Fiber ONT 250↓/250↑ISP Telenor | Wifi Router Orbi RBK50 AC3000, Router Mode, Wired Backhaul / Orbi RBK852 AX6000, Router Mode, Wireless Backhaul | Switches Netgear GS208Time Zone CET (Sweden)

Message 17 of 20
Highlighted
Aspirant

Re: Sonos can't connect to Orbi

 
Message 18 of 20
Highlighted
Aspirant

Re: Sonos can't connect to Orbi

No. They are all wireless. The “wire” was just used to get them set up on the orbi. Once they were accepted I took the cord away.

Message 19 of 20
Highlighted
Master

Re: Sonos can't connect to Orbi

This sounds very strange to me!
How would the Sonos get the Orbi SSID and password if all speakers were setup as wired? Have you been asked about this information during the Sonos setup?

My Setup Internet Fiber ONT 250↓/250↑ISP Telenor | Wifi Router Orbi RBK50 AC3000, Router Mode, Wired Backhaul / Orbi RBK852 AX6000, Router Mode, Wireless Backhaul | Switches Netgear GS208Time Zone CET (Sweden)

Message 20 of 20
Top Contributors
Discussion stats
  • 19 replies
  • 27585 views
  • 3 kudos
  • 8 in conversation
Announcements