× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

Re: NV+ slows after 15-20 minutes

Indexmill
Aspirant

Re: NV+ slows after 15-20 minutes

Hi,

My name is John. I am NOT trying to hijack this post so, please feel free to ask me to leave... But, I hope we can work together.

I have a ReadyNAS DUO with two 2TB WD Red drives AND I am using Acronis Tru Image to backup the partitions on my PC to the NAS once per week using a scheduled backup scheme. The total size of the backup is 300 MB. I have told Acronis to save two backups.

The backup starts and runs fine for many hours. Then, right at the end, it crashes with a " share not available" error. Perhaps it happens when it tries to delete the older backup in order to respect the " save two versions" setting. I don't know.

It is very frustrating. Any ideas? Thank you, John.
Message 26 of 31
937carrera
Aspirant

Re: NV+ slows after 15-20 minutes

John,

I know how frustrating these problems can be. It's probably better if you start your own thread, I'll happily try & contribute there
Message 27 of 31
937carrera
Aspirant

Re: NV+ slows after 15-20 minutes

Right, time for a little update.

I pulled disk 2 and did a hot swap so that the Raid would rebuild itself. The resyc took 8 hours and was uneventful, with the end result being that disk 2 still had no partition table. After a bit more reading around I still don't understand X-Raid properly, but it seems that one of the disks is the parity disk and that disk has no partition table. In other words this is normal, but it isn't always disk 2.

I tried to restore the Acronis backup this evening, still on 4.1.7. It failed as before and at the same point with poor media quality errors.

I then bit the bullet and jumped straight to 4.1.13 firmware. I'm delighted to say that the restore went through perfectly in just 23 minutes and it was clear within 10 seconds that the NV+ was much more responsive. Sometimes those firmware updates really do work 😄

I also ran NAStester again. This time the NV+ gave 33.37GB/s read speed and 13.95GB/s write speed which compares to 21.14GB/s read and 16.64GB/s write speed on the duo

Many thanks for all the help and comments posted, I'll go back and change the title of the thread to Solved.

I'm still left with a couple of questions, further comments and thoughts much appreciated

1. Is there somewhere which explains how X-Raid works
2. As my NV+ used to work perfectly with 4.1.7, what happened to make it not work correctly (and is the current good performance simply due to "fresh" firmware which may degrade over time)
Message 28 of 31
StephenB
Guru

Re: NV+ slows after 15-20 minutes [SOLVED]

I agree there is some mystery on why the performance dropped off, and why upgrading to 4.1.13 fixed it when the other reinstalls you tried did not.

XRAID uses standard raid underneath. In the specific case of the v1 (Sparc) systems, the underlying RAID uses a dedicated parity disk. That disk has no data partition. That mode of RAID is sometimes called RAID-4 (http://en.wikipedia.org/wiki/Standard_R ... els#RAID_4), though here we usually call single redundancy with more than 2 drives "RAID-5" on all platforms.

That parity disk is normally the disk in the highest slot number at the factory reset. Though if you have moved disks around, you might have accidentally put in in a different position.

The newer NAS distribute the parity blocks across all the disks (which is certainly RAID-5).
Message 29 of 31
937carrera
Aspirant

Re: NV+ slows after 15-20 minutes [SOLVED]

That's great, knowing X-Raid is like Raid 4 helps me understand the logs and configuration of my disks. They are configured as expected because when I got my 4 drives I installed disk 1 first to make sure the NAS worked, then disk 2 and then decided as it took so long to rebuild the array that I cold booted with disks 3 and 4 to save time. At least that's what I think I did.

The messing around with the other versions of firmware was all done on my second Duo. This was primarily done so that I was sure that I could upgrade / downgrade firmware without issue, and much of the firmware updating was down to me trying, unsuccessfully, to get Share Mode security available. What I learned from this process was that 4.1.6, 4.1.7 and 4.1.13 seem solid and reliable. Like some other users I found that 4.1.10 a bit slow & flakey.

Having done the testing on the Duo I was confident that a move to 4.1.13 on the NV+ would be the right thing to do. I now have to get some drives for the spare Duo so I can use that as a backup for my backup 🙂
Message 30 of 31
StephenB
Guru

Re: NV+ slows after 15-20 minutes [SOLVED]

937carrera wrote:
...That's great, knowing X-Raid is like Raid 4...
XRAID just adds the expansion capability, and is layered on top of various standard RAID modes. With the sparc products, that RAID mode is RAID-4, on the newer products it is RAID-1, RAID-5, or RAID-6.
Message 31 of 31
Top Contributors
Discussion stats
  • 30 replies
  • 2576 views
  • 0 kudos
  • 4 in conversation
Announcements