× NETGEAR will be terminating ReadyCLOUD service by July 1st, 2023. For more details click here.
Orbi WiFi 7 RBE973
Reply

ddclient for DynDns on RN300 - Working

hksscom
Apprentice

ddclient for DynDns on RN300 - Working

It took me a while to get ddclient to work on my ReadyNAS RN300 series, but eventually, redstamp user provided the key hint I needed.

 

Note: I will be publishing this same post with more details at https://www.yuenx.com.

 

Here's how I got it to work.

 

  1. Enabled SSH for "admin" user (Enabling will ask you to enter your Current Password to verify)
  2. SSH in as "root" with same password as "admin"
  3. "sudo" is not needed when logged in as root
  4. If you do not log in as root (ie. you logged in as "admin" or any other admin account), trying to start ddclient resulted in error:
[....] Starting ddclient (via systemctl): ddclient.serviceFailed to start ddclient.service: The name org.freedesktop.PolicyKit1 was not provided by any .service files
See system logs and 'systemctl status ddclient.service' for details.
failed!

Instructions asked to create a new file at /data/ddclient/ddclient.conf, but that never worked for me. Instead, error logs showed that /etc/ddclient.conf was in use. Output from systemctl status ddclient.service:

 

Feb 18 15:41:41 READYNAS_HOST systemd[1]: Starting LSB: Update dynamic domain name service entries...
Feb 18 15:41:41 READYNAS_HOST ddclient[13244]: WARNING: file /etc/ddclient.conf, line 9: Invalid Value for keyword 'login' = ''
Feb 18 15:41:41 READYNAS_HOST systemd[1]: Started LSB: Update dynamic domain name service entries.

Edit /etc/ddclient.conf using "vi":

 

# /etc/ddclient.conf
# Author: https://www.yuenx.com
# Reference: https://help.dyn.com/ddclient
# Reference: https://sourceforge.net/p/ddclient/git/ci/60fe051b7a504573386e2df2ffa8703dd47a8cb9/tree/sample-etc_ddclient.conf # Reference: https://www.bleddynrichards.co.uk/posts/installing-ddns-provider-on-readynas # Basic configuration file for ddclient # daemon=600 # You SHOULD use SSL to securely send your credentials over to DynDNS to log in with! ssl=yes mail=my_readynas_user_with_email_address # mail all msgs to my_readynas_user_with_email_address mail-failure=my_readynas_user_with_email_address # mail failed update msgs to my_readynas_user_with_email_address use=web, web=checkip.dyndns.com, web-skip='IP Address' protocol=dyndns2 server=members.dyndns.org, login=my_dyndns_username password=my_dyndns_password my_host.dyndns.info,

 

Next, I started the ddclient service to see if any errors popped up:

/etc/init.d/ddclient start -daemon=0 -debug -verbose -noquiet

 

Use this to look for any errors: systemctl status ddclient.service

 

Use this to stop the service: /etc/init.d/ddclient stop -daemon=0 -debug -verbose -noquiet

 

For a while, I could not find any meaningful error messages that told me what was going on. Then I checked the mailbox associated with my "my_readynas_user_with_email_address" user and saw a message about libio-socket-ssl-perl needing to be installed. To install, I ran:
apt-get update -y
apt-get install -y libio-socket-ssl-perl

 

Started the ddclient app from ReadyNAS WebUI. From SSH, I checked for any errors again:

systemctl status ddclient.service

ddclient.service - LSB: Update dynamic domain name service entries
   Loaded: loaded (/etc/init.d/ddclient; generated; vendor preset: enabled)
   Active: active (running) since Fri 2022-02-18 15:41:41 PST; 32min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 12088 ExecStop=/etc/init.d/ddclient stop (code=exited, status=0/SUCCESS)
  Process: 13244 ExecStart=/etc/init.d/ddclient start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/ddclient.service
           └─13253 ddclient - sleeping for 70 second

Note: If you still see errors with the above output, check the timestamp. It may be the LAST error that was recorded.

 

"Sleeping for 70 second" is when it will run again.

 

Once successfully updated, email was received that stated:
SUCCESS: updating my_host.dyndns.info: good: IP address set to 100.100.1.100
regards,
ddclient@READYNAS_HOST (version 3.8.2)

 

Important: Disabled SSH for "admin" user (Disabling will ask you to enter your Current Password to verify). This it to prevent anybody from the internet to SSH into your NAS and cause havoc.

Message 1 of 5
Sandshark
Sensei

Re: ddclient for DynDns on RN300 - Working

Did you have trouble getting the ReadyNAS ddclient app by Poussin working?  It's old, but still works fine for me.

Message 2 of 5
hksscom
Apprentice

Re: ddclient for DynDns on RN300 - Working

Hi, Sandshark!

 

Indeed, I could not get Poussin's DDclient 1.0 to work today until after a few hours of research and trial and error. This was with the ReadyNAS RN314 and OS6 6.10.6.

 

I've written a full article (with screenshots) detailing the steps here: Netgear ReadyNAS: DDclient Configuration for Dynamic DNS (DynDNS, No-IP) - YuenX.

 

Hope this helps others!

Message 3 of 5
Sandshark
Sensei

Re: ddclient for DynDns on RN300 - Working

Oh, I remember now that I had to do this, then the configuration in the ddconf share works:

 

Create (or add to if it exists) /etc/frontview/samba/addons/addons.conf

 

With the following:

[global]
allow insecure wide links = yes
unix extensions = no
[ddclient]
  follow symlinks = yes
  wide links = yes

Those used to be the defaults, but changed in an update to SMB some time back.  I forget which OS version included that update.

 

Obviously, there's another way, which you have detailed.  Since both need SSH, I don't think there's a preference as to which is used.

 

Message 4 of 5
hksscom
Apprentice

Re: ddclient for DynDns on RN300 - Working

Thanks for sharing! Good to know that /data/ddclient/ddclient.conf could still work if making the extra changes you listed.

Message 5 of 5
Top Contributors
Discussion stats
  • 4 replies
  • 1311 views
  • 2 kudos
  • 2 in conversation
Announcements