× NETGEAR is aware of a growing number of phone and online scams. To learn how to stay safe click here.
× Introducing the new Orbi 770 Series Mesh System. To learn more click here.
Orbi WiFi 7 RBE973
Reply

Re: AC1900 Extender devices connect but no internet

railcars
Aspirant

AC1900 Extender devices connect but no internet

I have a AC1900 EV7000 extender that is connected to my netgear C6250 cablemodem/router.  No issues with connecting between the extender and the device however when i connect to the extended SSID network i get no internet.  Please help as i have spent alot of hours and have got no where.

Model: C6250|AC1600 WiFi Cable Modem Router
Message 1 of 7
LordPurple
Star

Re: AC1900 Extender devices connect but no internet

Railcars - if you just updated the extender's firmware to V1.0.1.78_1.0.140 - that would be your problem.  As reported in other threads (see index) this firmware seems to break EX7000 extenders, at least many of them - including mine.  Suggest downgrading the firmware to 1.0.0.66, that worked for me.

 

Message 2 of 7
railcars
Aspirant

Re: AC1900 Extender devices connect but no internet

Thanks. I upgraded the firmware but don’t know what version. Will look tonight and try. Thanks.
Model: EX7000|AC1900 WiFi Range Extender
Message 3 of 7
railcars
Aspirant

Re: AC1900 Extender devices connect but no internet

Are you running as extender or access point. I am running as extender.  

Message 4 of 7
LordPurple
Star

Re: AC1900 Extender devices connect but no internet

I am running as an extender, and the new firmware definitely broke it.

Message 5 of 7
pacoinconn
Aspirant

Re: AC1900 Extender devices connect but no internet

I'm very glad I found this thread.  We've been having the same problem with our two EX7000 extenders.  Both are being run as access points (ethernet cable to Netgear managed switch to Asus routher which assigns IP addresses and is connected to cable modem).

 

Both EX7000 are on firmware version V1.0.1.78_1.0.140.

 

Very frustrating.  WIll try to revert back to the previous firmware.  Hope Netgear fixes this soon.

 

Model: EX7000|AC1900 WiFi Range Extender
Message 6 of 7
Bendeego
Guide

Re: AC1900 Extender devices connect but no internet

Hi,I had a similar problem where after updating firmware I could not connect my iPad and smart tv to the extender,

i solved my problem by changing the security,,starting with none and finishing with TKIP setting ,,all now connect ,,

hope this helps

Regards

PeterH

Model: EX7000|AC1900 WiFi Range Extender
Message 7 of 7
Discussion stats
  • 6 replies
  • 2755 views
  • 2 kudos
  • 4 in conversation
Announcements

Orbi 770 Series