Reply
Highlighted

Verizon Fios issues!! Please help!

Hello all. I’ve been having a problem over the past few months and I’m at my end.
I purchased the XR450 during Christmas 2019 and at that time I called Fios support and had them assist with removing their gateway from my network. From that day, I had my full Gigabit speeds without fail using the XR450 until recently. I started losing connectivity. I would call Fios and they would reset the ONT and then everything would work for about 7 days to the hour and then go out again. Now if I reboot the router, I will sometimes only show 10% of my speeds I.e. 80/80 or it’ll show 900/900 but seem sluggish. Then I Speedtest again and it’ll be 850/130. The 130 is does not go higher at that point. So over the past few weeks it’s been like this. Netgear tells me it’s not the xr450, Fios came in last week re ran the fiber and changed the ONT and using THEIR gateway, speeds worked and steady for the most part.
I assumed the culprit was the XR450 so today I purchased the XR500. Everything went exactly the same. First after setup my speeds were 80/80. Then I reset the ONT and speeds jumped to 900/900. But that was temporary. I tried a speedtest on Verizon’s site that cannot be completed. It will not check the upload speed. It gives an error. This happened with XR450 as well. All the research I’ve read tells me there is something in my network setup but I just don’t know anymore. Verizon did their part and with their gateway everything is good. But I want to use MY router.. I’ve purchased 2 nighthawks and same issue.
Can anyone give me any ideas?
Model: XR500|Nighthawk Pro Gaming Router
Message 1 of 4
Highlighted
NetDuma Partner

Re: Verizon Fios issues!! Please help!

It sounds like your public IP is renewing every 7 days, do you have a dynamic or static IP? Find out what the MAC address of the gateway is and then in Internet setup on the XR change the MAC address to that instead. Then plug it directly into the ONT, does that resolve the issue?
Message 2 of 4
Highlighted
Initiate

Re: Verizon Fios issues!! Please help!

Does the Internet return after power cycling? I have a xr450 as well and started noticing issues after the update last year (FiOS here as well but different ISP). I went back to a Netgear 6500v2 which is pretty close to the same hw. It was solid for weeks/months, where the xr450 would not renew the ip like clockwork after several days after that fw update.

I also factory reset, reloaded fw, and etc with no change in behaviors after that update. The only thing that worked was loading a 3rd party ddwrt firmware. Since then I went from only days to months without issue (like the xr450 was pre update).

The xr450 and xr500 are based on the same fw and hw. If you browse the Duma forums this is a common complaint (ip not renewing) Fortunately there is an update fw in the works, unfortunately this fw has been promised over 12+ months ago.
Message 3 of 4
Highlighted
NetDuma Partner

Re: Verizon Fios issues!! Please help!

There is a beta people are taking part in now and so hopefully when the next build is out more people will be invited and you'll be one of them.
Message 4 of 4
Discussion stats
  • 3 replies
  • 439 views
  • 2 kudos
  • 3 in conversation
Announcements