Reply

Virgin Media TV home screen not loading thumbnails - Nighthawk XR1000

PachaTC
Guide

Virgin Media TV home screen not loading thumbnails - Nighthawk XR1000

Hi All

 

I hope someone knowledgable can help!? 

 

Yesterday i took the plunge and installed a Nighthawk XR1000, everything seems to have connected to it fine and I am now getting to grips with the DumaOS.

 

The one issue i now have is with the Virgin Media home screen, the thumbnails have stopped loading/displaying images, instead replaced by the descriptive text, same with the app icons like Netflix. I imagine i cant be the only person this has affected with a Nighthawk/VM setup, please can anyone share what i need to change in the DumaOS so that the VM allows the images to load?

 

I have done some searching on this and only found answers like 'the router must be using VM DNS' and 'the router must be set to DHCP / Automatic WAN IP' but ill be honest this doesnt mean much to me and i couldnt see anything obvious in the DumaOS that linked to it.

 

Any help would be greatly appreciated!! @Netduma-Fraser  hope you or another expert can help?!

 

Thanks

Message 1 of 14

Accepted Solutions
Netduma-Fraser
NetDuma Partner

Re: Virgin Media TV home screen not loading thumbnails - Nighthawk XR1000

It will be using those settings automatically so not need to worry about that. Toggle IGMP Proxying in WAN Settings, then see if it works please

View solution in original post

Message 4 of 14

All Replies
plemans
Guru

Re: Virgin Media TV home screen not loading thumbnails - Nighthawk XR1000

How are you actually connected? 

What modem/gateway is the XR1000 connected to? 

And is the "home screen" through one of virgin's streamers/media boxes?

Current setup: CM2000-> RBKE963B-> Trendnet TEG-S380-> GS716T-> pi-hole
also in AP setup: RAXE500->EAX80
1.4gig download/50mbps upload from Xfinity
We’re members of the public helping out on our own time.
Message 2 of 14
PachaTC
Guide

Re: Virgin Media TV home screen not loading thumbnails - Nighthawk XR1000

Hi!

 

The Virgin Superhub 3 is in modem mode, XR1000 connected to that via ethernet, Virgin Media Tivo box connected to XR1000 by ethernet also.

 

The Virgin box is happily connected and i can watch on demand for example, however the thumbnails dont load the images, same for the app icons.

Message 3 of 14
Netduma-Fraser
NetDuma Partner

Re: Virgin Media TV home screen not loading thumbnails - Nighthawk XR1000

It will be using those settings automatically so not need to worry about that. Toggle IGMP Proxying in WAN Settings, then see if it works please
Message 4 of 14
plemans
Guru

Re: Virgin Media TV home screen not loading thumbnails - Nighthawk XR1000

You might need to setup a vlan tag on your device. 

https://kb.netgear.com/29911/Configuring-VLAN-IPTV-setup-on-your-Nighthawk-router?cid=wmt_netgear_or...

 

I know this was for a nighthawk but I believe the XR450 supports vlan setup. 

Current setup: CM2000-> RBKE963B-> Trendnet TEG-S380-> GS716T-> pi-hole
also in AP setup: RAXE500->EAX80
1.4gig download/50mbps upload from Xfinity
We’re members of the public helping out on our own time.
Message 5 of 14
PachaTC
Guide

Re: Virgin Media TV home screen not loading thumbnails - Nighthawk XR1000

@Netduma-Fraser 

 

Thanks so much, toggling the IGMP to off has fixed it!! 

 

Thanks also Plemans for your help 🙂

Message 6 of 14
plemans
Guru

Re: Virgin Media TV home screen not loading thumbnails - Nighthawk XR1000

Glad it fixed the issue!

Current setup: CM2000-> RBKE963B-> Trendnet TEG-S380-> GS716T-> pi-hole
also in AP setup: RAXE500->EAX80
1.4gig download/50mbps upload from Xfinity
We’re members of the public helping out on our own time.
Message 7 of 14
PachaTC
Guide

Re: Virgin Media TV home screen not loading thumbnails - Nighthawk XR1000


@Netduma-Fraser wrote:
It will be using those settings automatically so not need to worry about that. Toggle IGMP Proxying in WAN Settings, then see if it works please


Happy new year @Netduma-Fraser 

 

Just an update on my issue.. Toggling the IGMP did initially solve the problem, but only for a day?! The issue has come back and remained since then.

 

Do you have any other solutions i can try please?

Message 8 of 14
Netduma-Fraser
NetDuma Partner

Re: Virgin Media TV home screen not loading thumbnails - Nighthawk XR1000

Happy New Year! Interesting, I had the same hub and I found the modem mode to be a bit finicky, put it back into router mode then copy the WAN IP from the XR System Information page and put it in the VM DMZ. Then see if the issue is resolved please.
Message 9 of 14
PachaTC
Guide

Re: Virgin Media TV home screen not loading thumbnails - Nighthawk XR1000


@Netduma-Fraser wrote:
Happy New Year! Interesting, I had the same hub and I found the modem mode to be a bit finicky, put it back into router mode then copy the WAN IP from the XR System Information page and put it in the VM DMZ. Then see if the issue is resolved please.

Thanks @Netduma-Fraser 

 

Ive done that and it has worked, hopefully it remains this time! 🙂

 

We do sometimes get power cuts here, will this affect what ive just done? i.e. the XR1000 be assigned a different IP address? I notice that the XR1000 has a completely different IP address anyway (on the system information page) once the superhub goes into modem mode.

 

Thanks again, itll keep the mrs from moaning at me for a bit 😄

Message 10 of 14
Netduma-Fraser
NetDuma Partner

Re: Virgin Media TV home screen not loading thumbnails - Nighthawk XR1000

Great to hear that! Yes if the power cuts then the XR would be assigned a new address and the DMZ would then not work. The IP you have when it is in modem mode is your public IP vs a local IP assigned when VM is in router mode.

So to combat it changing, take that same IP you put in the DMZ and make it reserved/static on the hub. That way the XR will always have that IP even after reboots/resets and the DMZ will always be valid.
Message 11 of 14
PachaTC
Guide

Re: Virgin Media TV home screen not loading thumbnails - Nighthawk XR1000

Thanks, ill sort that when the power next cuts

 

I have a different issue now though..!

 

I cant access the DumaOS? i get the error -

 

haserl CGI Error

Failed to readline from 'config get DumaOS_Theme_Version'

  

how do i fix this please?


Message 12 of 14
Netduma-Fraser
NetDuma Partner

Re: Virgin Media TV home screen not loading thumbnails - Nighthawk XR1000

Reboot the router using the button, wait 2 minutes then access and it should load correctly.
Message 13 of 14
PachaTC
Guide

Re: Virgin Media TV home screen not loading thumbnails - Nighthawk XR1000

That worked, but annoyingly restored everything to factory settings 😞

 

Thanks for your help 🙂

Message 14 of 14
Discussion stats
  • 13 replies
  • 1279 views
  • 6 kudos
  • 3 in conversation
Announcements

Orbi WiFi 6E