Reply

xr500 r-app is not loaded yet. Please tray again in a minute

StevenW1230
Guide

xr500 r-app is not loaded yet. Please tray again in a minute

Before starting I just want to say I have already searched the forums, I have already tried the fixes, I have already reset the router to default, and the router does not need to be updated as it is already up to date.

 

I am lost at what will fix this issue as I have run out of things to try in getting this fixed up. Post state the last update fixed this yet I am still getting this error. I purchased this router about a week ago from bestbuy so it hasn't been used a lot and is pretty much brand new. This error does not show up after the first setup is complete, but once I let it set for a few minutes and go back to editing it just errors out.

 

Model: XR500|Nighthawk Pro Gaming Router
Message 1 of 20

Accepted Solutions
Netduma-Fraser
NetDuma Partner

Re: xr500 r-app is not loaded yet. Please tray again in a minute

On the System Information page on the R-App panel, click the 3 line icon and change the retry attempts from 3 to 5 please and then reboot the router and see if the error disappears.

View solution in original post

Message 16 of 20

All Replies
Netduma-Fraser
NetDuma Partner

Re: xr500 r-app is not loaded yet. Please tray again in a minute

Is there anything specific you changed before the error appeared the first time? Does the error appear so you can't access the interface at all or does it just happen on specific pages?
Message 2 of 20
StevenW1230
Guide

Re: xr500 r-app is not loaded yet. Please tray again in a minute

No changes were made other than the basic setup on start, re naming two devices in the device manager and adding my playstation to the geo-filter. All areas work besides Geo-Filter, QoS, Device Manager, and Network Monitor. So basically the default items that are text based. One thing I did notice is in the installed R-apps you can't click any of the items to pause, play, or check the box to run on startup. They are all grayed out like the whole app system is not working.

Message 3 of 20
Netduma-Fraser
NetDuma Partner

Re: xr500 r-app is not loaded yet. Please tray again in a minute

You said you have tried fixes, what specifically have you tried so we know what not to advise.

That's normal behaviour for the Installed R-Apps panel at the moment.
Message 4 of 20
StevenW1230
Guide

Re: xr500 r-app is not loaded yet. Please tray again in a minute

So far I have tried resetting it to default using the little reset button in the back. Along with trying different web browsers, going into incognito mode to make sure no plugins were causing issues. I tried rolling the update back and also re installing the update. Tried tweaking settings in the config area. Tried letting it load up for a bit instead of running directly to the area I want to look at. Tried leaving just the default setup and testing for awhile without editing. Tried rebooting the router (which works for 1 selection then after that it errors).  It is as thou a part of the coding in the system is erroring out when it gets to a specific point in its operation.

Message 5 of 20
Netduma-Fraser
NetDuma Partner

Re: xr500 r-app is not loaded yet. Please tray again in a minute

Thanks for that, when resetting via the button in the back when going back onto the interface did it run you through the setup wizard? Could you do a factory reset via the interface instead please from Settings > Administration > Backup settings > Erase?
Message 6 of 20
StevenW1230
Guide

Re: xr500 r-app is not loaded yet. Please tray again in a minute

Yeah it ran me through the setup wizard when doing the reset on the back. I will try the in menu reset later tonight to see how that goes. I think this is hardware related thou in the coding that needs a fix.

Message 7 of 20
StevenW1230
Guide

Re: xr500 r-app is not loaded yet. Please tray again in a minute

Not sure how or if i can edit old post but anyways. I was going through my log file area during my work break and noticed the following error going through. I put it in a pastebin so that it won't clutter the post.

 

https://pastebin.com/KuP6scy7

 

Let me know if this could be the cause as it was working fine a moment ago when i logged in to check the log then stopped working moments later.

Message 8 of 20
Netduma-Fraser
NetDuma Partner

Re: xr500 r-app is not loaded yet. Please tray again in a minute

Yes possibly, before the issue started happening did you delete any devices/connect anything new? What devices do you have connected to the router?
Message 9 of 20
StevenW1230
Guide

Re: xr500 r-app is not loaded yet. Please tray again in a minute

The error has been happening from the start. Though today when i noticed the error and it stopped working after those few minutes of working. Nothing new was added or changed. The only devices I have added are 3 phones (android), 2 ps4's, 1 xbox, 2 desktop pc's, google home device, and just my security cameras. However none of those were connected when I first set the router up other than my pc that was used to set the device up.

Message 10 of 20
Netduma-Fraser
NetDuma Partner

Re: xr500 r-app is not loaded yet. Please tray again in a minute

Okay interesting. Could you downgrade to the very first router firmware here: https://www.netgear.com/support/product/XR500.aspx#Firmware%20Version%202.0.0.28 and see if the issue occurs then reupgrade back to the latest and immediately do a factory reset please?
Message 11 of 20
StevenW1230
Guide

Re: xr500 r-app is not loaded yet. Please tray again in a minute

Sorry for the delay as I have been working and some irl issues popped up I had to deal with. So I did what you said and the error did go away on the older version and the interface actually seemed a lot faster and more responsive. I tested it for a little to make sure it wasn't going to come back and nothing did. I then updated like you suggested and did a reset on the box within the admin area, letting it set for awhile and things seemed to be fine. There was one error within the QoS area when it was loading. Not the error stated above but "Error: The operation is taking longer than expected. Please briefly wait before using this R-App. Even thou I was in it moments earlier. This same error also happened in the Geo-Filter area.

 

Upon this I let it set for a bit longer before trying again and at first I thought it went away but even after it loaded that error came right back after about a minute on the page. To make sure maybe I just needed to re load the web browser. I closed it out fully and booted it up back to the router interface. Sadly this issue still shows.

 

But to give this the benifit I let it sit even longer and sadly the main error that I was having with the R-App is not loadded yet came right back.  So it seems like its the firmware is causing the issues as the older version had none of these bugs from what I was seeing.

Message 12 of 20
FURRYe38
Guru

Re: xr500 r-app is not loaded yet. Please tray again in a minute

I recommend opening up a support ticket and inform NG about this:

https://www.netgear.com/mynetgear/registration/login.aspx

My Setup (Cable 1Gbps/50Mbps)>CAX80 v2.1.3.5(Router mode/LAG Disabled) & EX7700x2
Additional NG HW: C7800/CM1100/CM1200CM2000, Orbi CBK40, CBR750, RBK953(v6.0.3.68) & XR450(v130), RBK853 v4.6.3.16(AP) & RBK752 v4.6.5.14, RBK50(v22), SXR30(v110), R7000(v34), R7800(v84), R7960P(v82), EX7500/EX7700, and WNHDE111
Message 13 of 20
Netduma-Fraser
NetDuma Partner

Re: xr500 r-app is not loaded yet. Please tray again in a minute

Are you using Google Chrome by any chance? It may be unrelated but the latest update on Chrome has caused issues with the interface. Could you try with Firefox or Edge browser and see if you see the same thing please?
Message 14 of 20
StevenW1230
Guide

Re: xr500 r-app is not loaded yet. Please tray again in a minute

Currently ive been using firefox to get into the web interface as chrome has been bugging from the start so I just moved over to that one instead of trying to figure out that issue.

Message 15 of 20
Netduma-Fraser
NetDuma Partner

Re: xr500 r-app is not loaded yet. Please tray again in a minute

On the System Information page on the R-App panel, click the 3 line icon and change the retry attempts from 3 to 5 please and then reboot the router and see if the error disappears.

View solution in original post

Message 16 of 20
StevenW1230
Guide

Re: xr500 r-app is not loaded yet. Please tray again in a minute

I upped that and it does seem to load a bit better but sadly I still get the error. However thou the page for it is fully showing the info and not just erroring out like before.

Message 17 of 20
Netduma-Fraser
NetDuma Partner

Re: xr500 r-app is not loaded yet. Please tray again in a minute

Okay that's good news, seems like we could narrow down the issue from there - I will let the developers know. Meanwhile it might be an idea to see if you can get the router replaced as doesn't seem to be affecting every router.
Message 18 of 20
StevenW1230
Guide

Re: xr500 r-app is not loaded yet. Please tray again in a minute

Thank you. I have been checking on it today here and there and oddly enough the errors are no more. I will try and get an exchange if that is what you suggest later this week on my day off. Smiley Happy

Message 19 of 20
Netduma-Fraser
NetDuma Partner

Re: xr500 r-app is not loaded yet. Please tray again in a minute

Well that's good news! Maybe see how it goes and if it continues then get it exchanged, otherwise may have just been one of those weird issues that resolve themselves.
Message 20 of 20
Top Contributors
Discussion stats
  • 19 replies
  • 5169 views
  • 3 kudos
  • 3 in conversation
Announcements

Orbi WiFi 6E