Orbi WiFi 7 RBE973

ReadySHARE Media Drive constantly disconnecting

Yelpy
Aspirant

ReadySHARE Media Drive constantly disconnecting

Hi all, I just made this account so that I could post an issue and it's fix. I have the Nighthawk X4 AC2350 (R7500v2) and for a while now the media hard drive I have connected via USB using ReadySHARE just vanishes from the media server list all my home devices (TV, Xbox, Playstation, Phone etc...) about 5 to 15 minutes after setting it up or rebooting to get it to work.

 

So basically I connect a hard drive, set it all up via ReadySHARE and it's there, visible on all devices for a VERY short amount of time. Then it vanishes, I can't find it on any device. I can however connect to the shared folders on it with my PC. It's had me stumped for ages. So much so I had just completely stopped using it for the last year. But I got a new hard drive and wanted to start using it again so I spent a long while trying to figure it out. I checked a lot of pages on here and noticed a lot of people had a similar, if not the exact same issue.

 

After a lot of messing around I found a fix that seems to be working perfectly. I downgraded my firmware back to R7500v2 v1.0.3.40 (from 2019) and amazingly this fixed the issue. ReadySHARE is working perfectly again, So somewhere along the way Netgear basically broke it via one of the firmware updates (the latest version being: R7500v2 v1.0.3.50 Hot Fix).

 

So this is a PSA; if you have this issue, downgrade your firmware to an earlier version from here: https://www.netgear.com/support/product/r7500v2#download (again R7500v2 v1.0.3.40 being the version that worked for me). If you have a different router and have this issue it might be an idea to try find an earlier firmware for your router too, something from around 2019.

 

If anyone from Netgear reads this please FIX THIS ISSUE IN A NEW FIRMWARE UPDATE!

 

Hope this helps someone. Cheers! 🤘

Model: R7500|Nighthawk X4 AC2350 Smart WiFi Router
Message 1 of 10
FURRYe38
Guru

Re: ReadySHARE Media Drive constantly disconnecting

Message 2 of 10
Yelpy
Aspirant

Re: ReadySHARE Media Drive constantly disconnecting

Maybe then they should write on the box, in big ass letters. THIS WILL BREAK AFTER 3 YEARS!!! 🤦

Message 3 of 10
FURRYe38
Guru

Re: ReadySHARE Media Drive constantly disconnecting

This model router was first released back in 2014. Well past 3 years.

Message 4 of 10
Yelpy
Aspirant

Re: ReadySHARE Media Drive constantly disconnecting

The link you posted said 3 years, hence 3 years!

Message 5 of 10
FURRYe38
Guru

Re: ReadySHARE Media Drive constantly disconnecting

Initial FW says 2016:

https://kb.netgear.com/25492/R7500-Firmware-Version-1-0-0-46

 

Hence well past 3 years. But please contact NG support and let then know as this is well beyond forum support. Nothing can be done here for some thats EoL.
https://my.netgear.com/support/contact.aspx
https://www.netgear.com/about/contact-us/

 

Good Luck.

Message 6 of 10
Yelpy
Aspirant

Re: ReadySHARE Media Drive constantly disconnecting

I don't know what point you're trying to make. Whether the product is 3 years or 10 years old the fact remains they broke it with a firmware update, didn't let the people who own the bloody thing know and just left it like that. The fix I posted will help those people. Your replies won't, they're not helpful in the slightest.

Message 7 of 10
FURRYe38
Guru

Re: ReadySHARE Media Drive constantly disconnecting

You said that NG should fix this. Just saying, NG probably won't since it's EoL.

Also if you want NG to fix something, it's best to let them know. Hence the links to contact them. Nothing like this will be fixed here in the forums.

Up to users to let NG know about issues like this.

 

Enjoy then.

Message 8 of 10
Yelpy
Aspirant

Re: ReadySHARE Media Drive constantly disconnecting

They have literally released a firmware update that breaks a pretty big part of the routers functionality and they push you to update the router with this new firmware every time you go to the routers settings page. That's a pretty big deal. They definitely need to fix their mistake regardless of how old it is. You can't just break your product and then say sorry I'd love to fix my mistake but your product is too old, go spend $200 plus on a new one.

 

This is a rather big issue and a very bad look. If you let companies away with this kind of thing then after 3 years they can push updates that break their products so you're forced to buy a new one all the time. I'm thinking the legality of that is dubious to say the least! 

 

So yes Netgear you 100% definitely need to fix this. Also after reading the forums here I'm pretty sure this issue is present of some of their other products.

Message 9 of 10
FURRYe38
Guru

Re: ReadySHARE Media Drive constantly disconnecting

Again hence let NG support know.

Good Luck.

Message 10 of 10
Top Contributors
Discussion stats
  • 9 replies
  • 1084 views
  • 0 kudos
  • 2 in conversation
Announcements

Orbi WiFi 7