Reply
Highlighted
Aspirant

Date and time not getting set correctly

So ive been having problems with my router not getting date and time correctly. I got this router from the store a few weeks ago. Only had one fairly minor issue with it. the network assigned time isnt working. The logs dont show too much. But since im no expert on this system nor the logging methods ill send them all. http://pastebin.com/4W3WeEP6. Its just it keeps saying the date and time is january x 2015 it will keep counting up from then a factory reset doesnt matter and it only did this when i did the firmware update from the old firmware it was running when i bought it. I'm unsure what is the real problem. the link proving the system time on this router is right here => link.
And yes the time zone settings r fine on this router i think. link

 

 

Firmware Version
V1.0.5.70_1.1.91

 

 

im unsure what else is relevent to this. If more information is needed ill provide.

Model: R7000|Nighthawk AC1900 Dual Band WiFi Router
Message 1 of 16

Accepted Solutions
Highlighted
Aspirant

Re: Date and time not getting set correctly

ya the fix was update to the newer version 1.0.7.2_1.1.93 and the system time corrected itself

View solution in original post

Message 16 of 16

All Replies
Highlighted
Aspirant

Re: Date and time not getting set correctly

Just wanted to update and say factory reset didnt work

Message 2 of 16
Highlighted
Retired_Member
Not applicable

Re: Date and time not getting set correctly

How is the router connected to modem, The Wan port must be used. What modem are you using.

Message 3 of 16
Highlighted
Master

Re: Date and time not getting set correctly

On the LOGGING tab under ADMINISTRATION (ADVANCED) is "Router operation (startup, get time etc)" checked?

 

The LOG entries for time should look like this:

 

[Time synchronized with NTP server] Tuesday, Jul 12,2016 06:21:03
[Internet connected] IP address: 184.88.19.241, Tuesday, Jul 12,2016 06:21:02 

I noticed you have TRAFFIC METER enabled. Turn it off and see if it still happens after a re-boot.

 

Others have reported the same here and have called Support and gotten a special Beta F/W for it and it fixed it.

 

Also see this one, https://community.netgear.com/t5/Nighthawk-WiFi-Routers/R7000-Time-and-date-is-wrong/m-p/1059600#M28..., it was a DNS problem.

Message 4 of 16
Highlighted
Aspirant

Re: Date and time not getting set correctly

in response to searay yes the wan port is being used and before I did the firmware upgrade on the nighthawk from the firmware it orriginally came with the time syncronization worked then on the old version. It quit working on the new version. Sadly idk the version it used to be running. And The modem isnt a modem Its a router that my isp gave us put into lan subports so our tv system still works. But like I said it worked before. it was a pace 5168n router though.

Message 5 of 16
Highlighted
Retired_Member
Not applicable

Re: Date and time not getting set correctly

go to router status and verify the WAN IP is NOT 192.168.1.x or 10.0.0.X it should be a Public IP

Message 6 of 16
Highlighted
Aspirant

Re: Date and time not getting set correctly

yes it is my publice ip this picture should be evidence of that.

 

IP Address: 207.161.xxx.xxx

Subnet Mask: 255.255.252.0

DNS Address: 142.161.2.155

                       142.161.130.155

Message 7 of 16
Highlighted
Aspirant

Re: Date and time not getting set correctly

I think ive proven that its not the traffic meter messing up this. http://pastebin.com/XptdLain Checked system time after and it still didnt seemt to be working.

 

I also tried changing the dns records to these from google. The ones on the other forum  didnt give me and websites or any changes in this either

googles dns

Primary = 8.8.8.8.8
Secondary = 8.8.4.4

and the ones from the other post didnt seem to work at all https://i.imgur.com/8O8eaXL.png

and the logs from this test with the google one that actually gave me internet and not no dns. http://pastebin.com/4rYaWbVs

 

The only thing i havent tested is the beta firmware by contacting support which ill probly do later today or something.

Message 8 of 16
Highlighted
Aspirant

Re: Date and time not getting set correctly

How would i contact netgear support?

Message 9 of 16
Highlighted
NETGEAR Employee Retired

Re: Date and time not getting set correctly

@popcorn9499 Kindly submit a case through your MyNETGEAR account.

ElaineM
NETGEAR Community Team
Message 10 of 16
Highlighted
Aspirant

Re: Date and time not getting set correctly

Thanks @ElaineM. I did that

Message 11 of 16
Highlighted
Apprentice

Re: Date and time not getting set correctly

Were you ever able to get this corrected at all? If so, what was the fix?

Message 12 of 16
Highlighted
NETGEAR Employee Retired

Re: Date and time not getting set correctly

@soyee7 Do you have the same model number of the router?
Did you already update the firmware of the router?

Have you tried factory reset?

ElaineM
NETGEAR Community Team
Message 13 of 16
Highlighted
Apprentice

Re: Date and time not getting set correctly

I have an R7500 (AC2350). Yes, I have the latest firmware on the router. I have even tried downgrading and re-upgrading the firmware as well. Yes, I performed a factory reset.  Here is a link to my post on this.

https://community.netgear.com/t5/Nighthawk-WiFi-Routers/R7500-System-Time-Not-Correct/m-p/1142348#M3...

 

Thanks,

Sasan

Message 14 of 16
Highlighted
NETGEAR Employee Retired

Re: Date and time not getting set correctly

Sorry but there's no available firmware update for that specific model number to correct the date and time.

The router is already considered EOL.

ElaineM
NETGEAR Community Team
Message 15 of 16
Highlighted
Aspirant

Re: Date and time not getting set correctly

ya the fix was update to the newer version 1.0.7.2_1.1.93 and the system time corrected itself

View solution in original post

Message 16 of 16
Top Contributors
Discussion stats
  • 15 replies
  • 7442 views
  • 0 kudos
  • 5 in conversation
Announcements