Reply
gerudoku
Tutor

Enabling dynamic QOS on R7000P causes internet to disconnect

I've had this router for a month. For the most part, it works fine. But I've been noticing random lag spikes and disconnects while playing World of Warcraft (my wife gets them too, seemingly at random, and never at the same time they happen to me, even when we're both playing WoW together). Both of our PCs are on wired connections to the router.

 

Per recommendations from the battle.net forums, I tried to enable Dynamic QOS on the router to see if that would help with the issue. However, as soon as I enable & apply Dynamic QOS (prompting a router reboot), all internet connectivity drops, and stays off after the router finishes rebooting. I can still access the router configuration, thankfully, but at that point all I can do to restore internet connectivity is turn Dynamic QOS off and reboot the router again.

 

I would try Advanced QOS instead, but I can't find that anywhere in the router configuration.

 

If it helps, I have Comcast Xfinity 100Mbps (speedtest.net says ~115Mbps upload, ~6Mbps download) using my own Motorola/Arris SURFboard SB6121 modem. I'm using the latest firmware (1.0.1.14). I can't find anyone else here or elsewhere reporting this problem. Any ideas?

 

Model: R7000P|Nighthawk AC2300 Smart WiFi Router with MU-MIMO
Message 1 of 12

Accepted Solutions
gerudoku
Tutor

Re: Enabling dynamic QOS on R7000P causes internet to disconnect

FYI- I worked with a Netgear support tech last night and was able to get Dynamic QOS working on my R7000P.

 

I'll still need to do more testing to determine if this resolves the random disconnection issues in battle.net games, but at least Dynamic QOS is working now.

 

Here's the procedure we followed:

 

  • Access Netgear Genie/router settings
  • Open Dynamic QOS page under Basic Settings
  • Check the "Activate Dynamic QOS" checkbox
  • In the menu that appears, click "Speedtest" and let it finish
  • Click "Update Now" for the Performance Optimization Database (mine did not find any updates, but it's worth checking)
  • On the same page, click "Apply"
  • The router will reboot. Allow the reboot to complete.
  • After the reboot completes, you will still not have an internet connection. Return to the router settings and verify that Dynamic QOS is still enabled.
  • Return to the main Router Settings page and click "Reboot" to reboot the router. (You may also be able to power cycle it with the physical button)
  • WHILE THE ROUTER IS REBOOTING, power cycle your modem. (I just unplugged my Arris SB6183 for 10 seconds)
  • Wait for the router and modem to finish rebooting and for the lights to stabilize.
  • If the procedure worked, Dynamic QOS should still be enabled, and you should now have internet access

Hope this helps. Like I said, I'm not sure if this solves my other issue, but I'll update this post after I've had a few days to test it out.

Thanks to the Netgear support person, Eduard, for the assistance.

 

Good luck!

 

View solution in original post

Message 8 of 12

All Replies
Dummah1
Aspirant

Re: Enabling dynamic QOS on R7000P causes internet to disconnect

I am experiencing the same thing. I installed my router, set it up using the app you guys provided and since then I've been having random disconnects, both on my PC and on mobile. It usually happens while gaming. If we are watching videos, movies, etc. It doesn't happen or at least we don't notice it. But it does disconnect us during games.

Please help.
Message 2 of 12
gerudoku
Tutor

Re: Enabling dynamic QOS on R7000P causes internet to disconnect

I updated to the new firmware about a week ago ( V1.2.0.22_1.0.78) and unfortunately, both problems I described in the original post are still happening.

 

I'm still randomly getting disconnected while playing WoW, sometimes as often as thrice per hour.

 

I still can't enable Dynamic QoS (to see if that remedies the issue) because after rebooting to apply that setting, the internet refuses to connect.

 

I hope someone from Netgear can respond. I'm getting very close to returning this to Best Buy and trying a different brand.

 

Message 3 of 12

Re: Enabling dynamic QOS on R7000P causes internet to disconnect

I have just installed a router and updated firmware and have the same issue: after enabling QoS (one of the features that sold me on this router), I get no internet connection (amber light). Looking forward to receiving help. 

Model: R7000P|Nighthawk AC2300 Smart WiFi Router with MU-MIMO
Message 4 of 12
JamesGL
Master

Re: Enabling dynamic QOS on R7000P causes internet to disconnect

Hi jacobfeldman4,

 

If you disable QoS, will internet connection works again?

Did it happen after the update?

Reset and reconfigure the device.

Message 5 of 12
JamesGL
Master

Re: Enabling dynamic QOS on R7000P causes internet to disconnect

Hi jacobfeldman4,

 

We’d greatly appreciate hearing your feedback letting us know if you need further assistance.

Message 6 of 12

Re: Enabling dynamic QOS on R7000P causes internet to disconnect

I do not see any firmware update available. I have reset the advice. After doing so, turning on QoS still leads to no internet connection after the router is done rebooting. Turning off QoS and restarting the router again brings the internet connection back.

Message 7 of 12
gerudoku
Tutor

Re: Enabling dynamic QOS on R7000P causes internet to disconnect

FYI- I worked with a Netgear support tech last night and was able to get Dynamic QOS working on my R7000P.

 

I'll still need to do more testing to determine if this resolves the random disconnection issues in battle.net games, but at least Dynamic QOS is working now.

 

Here's the procedure we followed:

 

  • Access Netgear Genie/router settings
  • Open Dynamic QOS page under Basic Settings
  • Check the "Activate Dynamic QOS" checkbox
  • In the menu that appears, click "Speedtest" and let it finish
  • Click "Update Now" for the Performance Optimization Database (mine did not find any updates, but it's worth checking)
  • On the same page, click "Apply"
  • The router will reboot. Allow the reboot to complete.
  • After the reboot completes, you will still not have an internet connection. Return to the router settings and verify that Dynamic QOS is still enabled.
  • Return to the main Router Settings page and click "Reboot" to reboot the router. (You may also be able to power cycle it with the physical button)
  • WHILE THE ROUTER IS REBOOTING, power cycle your modem. (I just unplugged my Arris SB6183 for 10 seconds)
  • Wait for the router and modem to finish rebooting and for the lights to stabilize.
  • If the procedure worked, Dynamic QOS should still be enabled, and you should now have internet access

Hope this helps. Like I said, I'm not sure if this solves my other issue, but I'll update this post after I've had a few days to test it out.

Thanks to the Netgear support person, Eduard, for the assistance.

 

Good luck!

 

View solution in original post

Message 8 of 12

Re: Enabling dynamic QOS on R7000P causes internet to disconnect

Yes, this seems to have worked. Thank you!

Message 9 of 12
gerudoku
Tutor

Re: Enabling dynamic QOS on R7000P causes internet to disconnect

I'm happy to report that after a few days of testing, enabling Dynamic QOS on my R7000P seems to have stopped the random, frequent disconnects from Blizzard battle.net games like World of Warcraft and Overwatch.

 

Message 10 of 12
zackpyle
Aspirant

Re: Enabling dynamic QOS on R7000P causes internet to disconnect

Worked for me. Thank you!

Message 11 of 12
vasanimanish
Aspirant

Re: Enabling dynamic QOS on R7000P causes internet to disconnect

Thanks, this fixed Dynamic QoS for me!!

Model: R6900|Nighthawk AC1900 Smart WiFi Router
Message 12 of 12
Top Contributors
Discussion stats
  • 11 replies
  • 25591 views
  • 6 kudos
  • 6 in conversation
Announcements