Reply

Nighthawk X4S R7800 does not upgrade

Twinsen
Tutor

Nighthawk X4S R7800 does not upgrade

Just read the news about this router being vulnerable for hackers attacks and found a new firmware file on netgear site.

However, the router itself does not accept it telling me that this new firmware is not supported. I get two kinds of errors. For attached file I get: "This firmware file is incorrect! Please get the firmware file again and make sure it is the correct firmware for this product." and for a firmware update assistant I first get the notification that the new firmware is found (current version: 1.0.2.04, new version 1.0.2.90) and then after I press yes, it downloads it and says "MD5 verify error". So either way I can't upgrade it on my own. What else could I try? Thanks in advance.

Model: R7800|Nighthawk X4S AC2600 Wifi Router
Message 1 of 6

Accepted Solutions
plemans
Guru

Re: Nighthawk X4S R7800 does not upgrade

Under the downloads section click on "+view previous versions"

Try a stepped approach. Go a couple versions newer and see if you can update. 

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->

View solution in original post

Message 4 of 6

All Replies
plemans
Guru

Re: Nighthawk X4S R7800 does not upgrade

the version you're on is around 22 versions behind. You might try doing a stepped process versus going from 0 to 100. 

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->
Message 2 of 6
Twinsen
Tutor

Re: Nighthawk X4S R7800 does not upgrade

Thanks! I believe I can only find the most recent version on netgear site? Where should I look for the "middle" versions?

Message 3 of 6
plemans
Guru

Re: Nighthawk X4S R7800 does not upgrade

Under the downloads section click on "+view previous versions"

Try a stepped approach. Go a couple versions newer and see if you can update. 

Current Setup: CM2000-> RBK750-> GS716v2-> RAXE500-> Pi-hole->

View solution in original post

Message 4 of 6
mickeydean
Aspirant

Re: Nighthawk X4S R7800 does not upgrade

My router is on firmware version V1.0.2.82 and I am encountering the same error

Message 5 of 6
Twinsen
Tutor

Re: Nighthawk X4S R7800 does not upgrade

Thank you, it helped! I've gone from 2.04 to 2.28 to 2.40 to 2.52 to 2.68 to 2.80 to 2.86 (previous version) to 2.90 and it worked this way!

Message 6 of 6
Top Contributors
Discussion stats
  • 5 replies
  • 240 views
  • 2 kudos
  • 3 in conversation
Announcements

Orbi WiFi 6E