Reply

Wireless Roaming not seamless

karlf2059
Aspirant

Wireless Roaming not seamless

I am having difficulty with wireless devices connecting to their nearest access point. I have tried enabling or disabling the "enable fast roaming" feature but it doesn't seem to make a difference. A majority of my devices seem to just connect to the base router and not the satellites, even if it is a few feet away from a satellite and it never changes once connected. If I am upstairs for a long while, my phone does seem to connect to the upstairs satellite, but if I then go downstairs, I notice that internet slows to a crawl and sometimes I have to disable wi-fi on my phone (which connects to mobile network) and data suddenly starts coming in. If I re-enable wi-fi again, sometimes it is better, sometimes it seems as if I am still connected to upstairs. Similar issue with my Google Nest doorbell, the closest connection is a satellite directly above it one floor up, but it always seems to connect to the router only on the opposite side of the house and it affects the speed at which I receive notifications. Any suggestions on how to fix this and get devices connected to the nearest router/satellite instead of autp connecting to the router?

Message 1 of 5
JohnD333
Apprentice

Re: Wireless Roaming not seamless

You ask 2 questions.

1. Every time the mesh reboots (firmware update, reconfiguration change, or power failure) the base (router) reboots first, then the satellites. The satellites can take 5 minutes longer to come on line depending upon signal strength.

Meanwhile, all devices are searching for a signal, any signal. Naturally they find the base because because it is the only mesh component that is on line yet. The solution is to wait until the satellites come back on line and cycle your devices’ power off then on. In some cases, the device will connect to the sat simply by cycling the device WiFi off, then on.

With the current firmware there is no way to assign a specific device to wait to be connected to a specific satellite. This is a big pia for everyone with WiFi devices that never move (cameras, doorbells, thermostats, speakers, etc.). Hopefully this will be addressed in the future, particularly since the WiFi6 mesh is being marketed as IoT solution. If not, we may find that going back to a router with extenders or WiFi access points will provide a better solution for those devices. I sure hope not.

2. If all of your satellites are on line AND have good signal strength back to the base, walking around (with a phone, tablet or portable pc should result in changing between the base and the strongest satellite automatically. How quickly that happens depends upon the age of your device, it’s operating system updates, and if a pc it WiFi driver updates.

Be sure your mesh system firmware is up to date in the base and all satellites. If still experiencing this, call Netgear tech support or chat on line.

Good luck.
Message 2 of 5

Re: Wireless Roaming not seamless

Are you using MAC ACL security?  My experience is that roaming is pretty seamless with MAC ACL security off and exceedingly slow with it turned on.  I haven't used the more basic "Access Control" so can't say how that affects roaming.

Message 3 of 5
karlf2059
Aspirant

Re: Wireless Roaming not seamless

No, MAC ACL is disabled. 

Message 4 of 5
schumaku
Guru

Re: Wireless Roaming not seamless

What Orbi system(s) and current installed firmware(s) are we facing here?

 


@karlf2059 wrote:

I am having difficulty with wireless devices connecting to their nearest access point. I have tried enabling or disabling the "enable fast roaming" feature but it doesn't seem to make a difference. A majority of my devices seem to just connect to the base router and not the satellites, even if it is a few feet away from a satellite and it never changes once connected. ... Similar issue with my Google Nest doorbell, the closest connection is a satellite directly above it one floor up, but it always seems to connect to the router only on the opposite side of the house and it affects the speed at which I receive notifications. Any suggestions on how to fix this and get devices connected to the nearest router/satellite instead of autp connecting to the router?


This unrelated to the subject "Wireless Roaming not seamless". As @JohnD333 already explained, these are so called sticky clients, apparently very basic WiFi clients which don't care about 802.11k radio resource management where Orbi does certainly offering a list of all access points and radios (a list of BSSIDs [Radio MAC] for each SSID). Similar, 802.11v assisting.

 

Appers there would be room to enhance for non-802.11k/.11v aware clients, Orbi could disassociating clients with weak signals expecting these will find the better suited BSSID.

 


@karlf2059 wrote:

If I am upstairs for a long while, my phone does seem to connect to the upstairs satellite, but if I then go downstairs, I notice that internet slows to a crawl and sometimes I have to disable wi-fi on my phone (which connects to mobile network) and data suddenly starts coming in. If I re-enable wi-fi again, sometimes it is better, sometimes it seems as if I am still connected to upstairs.


This would be a typical case where 802.11k/.11v would help - all these are available on the Orbi system ... but again the undefined mobile phone WiFi must be able to deal with it, too. Apple has provided a reference for devices and operating systems for iPhone, iPad & Co. Wi-Fi network roaming with 802.11k, 802.11r, and 802.11v on iOS  

Message 5 of 5
Top Contributors
Discussion stats
  • 4 replies
  • 221 views
  • 0 kudos
  • 4 in conversation
Announcements